Manjaro ARM Alpha5 for PinePhone - Testing Branch

Manjaro ARM Alpha5 for PinePhone!

The Manjaro ARM project is proud to announce the fourth ALPHA release for the PinePhone!

This image are running the 5.5 kernel from , which is designed for the PinePhone devices.

We strongly suggest flashing this image, instead of updating the Alpha4 image.

Thanks for @Strit for helping me in all this work!

image image

Changes since Alpha4:

  • Outgoing and Incoming Audio Call works.
  • New SMS app called spacebear, A re-write of spacebar.
  • Added some new apps.
  • Angelfish browser is quite smooth and can add webpages to homescreen.
  • Updated and more stable Plasma Mobile interface.
  • Current Alpha image is using Testing branch.

List of new Apps in Alpha5:

  • Buho - Simple Note Taking app.
  • Nota - Simple Text editor app.
  • Vvave - Audio player app. (Can play youtube Videos in it)
  • Qwikaccess - Simple shortcut buttons app by @Librewish
  • Peruse - Comic Book reading App.
  • Koko - Kde Plasma Image gallery.

Plasma Mobile for PinePhone

Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher ( sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 1234

User: root
password: root

Known Issues:

  • Power savings is not optimized, but better than alpha3.
  • Can't control Bluetooth from Settings, but can be controlled with a widget!
  • Screen rotation does not work. (but will soon)
  • Receiving SMS works but not stable, it cannot fetch the first incoming sms after every boot.


Please consider supporting Manjaro ARM directly via Patreon , Ko-Fi or Open Collective .
You can also donate to our upstream, which is Arch Linux ARM .


Very very nice! Glad to see everything up to date now! Now, if only it could include crust firmware... :stuck_out_tongue:

Very nice work guys!!!

I just want to pitch some form of full disk encryption option, because i need that for the system im gonna choose. I want to use manjaro but as of now, the only one offering fde without hassle is postmarketos.

Full Disk Encryption is not possible with the current version of Uboot we use on the the device.

1 Like

Aha ok :frowning:
I hope that's get updated and supported in the future then :slight_smile: But will you support it in manjaro if it's technically possible? Would be a super wanted feature I think, as it's a portable and easy to loose device :slight_smile:

1 Like

Sure, if we can find an easy way to set it up. :slight_smile:

Yeah, i guess the pmbootstrap thing that pmos uses to prepare the sd-card is quite powerful. Only other way I assume is a installer, like the regular manjaro, that you boot up from sd-card and then install to emmc maybe?

the text messaging app text bubbles are black, and the text is black/dark as well, making it very hard to read the text.

Yes the re-written sms app is WIP. So that will change soon.

1 Like

Great work! Many apps work much better.
I'm experiencing an issue with "scaling" kde interface after screen wake up on dev's pinephone version.
Did anybody else experience this issue with the new image?

Can you explain this in detail? What do you mean by scaling? If you play with font size and others then it might break the ui as its still experimental.

I mean that sometimes after locking and unlocking the display resolution changes (with max font value in gui setting fonts are very small) however after reboot comes back to normal. Cannot reproduce it as for now.

First off: awesome to see alpha 5 coming out. Thanks a lot for all your hard works guys!! :slight_smile: Will take my time this week to test it! :slight_smile:

I immediately seem to be having an issue with wifi however. Connecting to my wifi seems to work by using the gui, although this is challenging; the entries in the wifi list keep changing places while you're attempting to enter your password.

Then once I have a connection, it seems like it is not setup properly. It looks like the phone is successfully assigned an IP address, because running ip a through konsole on the phone does show an IP for device wlan0. The phone is also visible in my router interface with this same IP. I can't see the phone when I'm scanning my network with nmap from my laptop though, and I can't connect to it through SSH either. When I ping on the phone I do get a result, however, when I then open Angelfish and attempt to surf somewhere it can't load the page. Seems like some DNS error. All other wireless devices on my network work fine.

Does this problem seem familiar to anyone?

Do you have a sim card inserted which have a data activated? If so yes this seems to be a conflict in DNS when both the sim and the wifi is connected.

If there is no sim and still you have this issue then this is something new to me.

Nope, no SIM card is inserted unfortunately :confused: I also turned off mobile data on the phone through the pull-down menu, just to be sure. I'll just test some more with the connection then.

Again, thanks for all the work, really good to see progress being made so quickly! Will report back any other issues and successes of course :slight_smile:

Edit: okay, it worked after I removed the saved connection from the list, and then reconnected. Strange that it didn't work the first time although the phone did obtain an IP address... Oh well! Now I can test the phone properly, awesome :wink:

Edit 2: Hm, it seems that the connection is very brittle. Whenever the phone screen goes black the wireless connection drops. Following that, the connection goes into the state I described above; the phone does say it's connected, and I sometimes can and sometimes can't see the phone listed in the network from other devices (my router, my laptop). In that state the internet connection on the phone is not usable any longer. Only a reboot seems to fix this.

Could it perhaps be that the phone goes into a suspend state and the connection does not get reinitialised properly?

1 Like

Yes that's temperamental, but in my test it have been working fine. Can you confirm whether your phone is Braveheart edition or dev edition?.

Thanks for your quick response :slight_smile: I'm testing on a braveheart edition.

Ok, let me check with one of our dev who have BH edition.

Ill get back to you after checking with him.

Thanks for reporting.

I noticed a few issues while testing this image for last 24 hours:

  1. During an incoming call, you need to be looking at an unlocked screen to notice the call, the phone doesn't vibrate or make any sound. (I suppose this is not news to anyone, I just really want to use it as a daily driver, and this is the only thing preventing me to do so)
  2. vvave doesn't make any sound at all, I suspect it doesn't detect the output device (pulse audio).
  3. The dialer app doesn't send keypresses during a conversation, e. g. when you call a robot and need to select an option
  4. sometimes, on boot the UI is not responsive, there's a blank square blinking in center of the screen (I noticed this before).
    P. S. I hope this sort of testing is welcome, I'm not just trying to criticize you guys.

Under development by plasma team and not implemented yet.

Not sure. I have tested it with youtube video inside vvave and it worked fine.

Under development by plasma team and not implemented yet.

Known issue and plasma team will fix in the next release.

Not at all, As it says Alpha release and testing is always welcome at Manjaro, We try our best to solve the issues as soon as we can but most of the Plasma Mobile component are currently WIP and under heavy development.
I would like to know if you have the BraveHeart edition or dev edition device? Also can you test Wifi stability and report back? As for @p1x3l3d he is having issues with wifi being unstable and lose connection after suspend while its not the case for my device.

Thank you for taking the time to test our build, Highly appreciated.


Forum kindly sponsored by