Manjaro ARM i3 for the PinebookPro

I am happy to announce that the updated i3 image for the PinebookPro is now available for

SD image:
direct | sig | sha1 | torrent
emmc-installer image:
direct | sig | sha1 | torrent



  • The current keyboard firmware of the PinebookPro does not support key-combinations Super+ arrow keys
    For that reason the default i3 mod-key is Alt !
  • touchpad pointer acceleration still deserves come more tweaking. If anybody would like to suggest some config, you are more than welcome! :wink:

Have fun testing and as always, thanks a lot for your valuable feedback!


Awesome @oberon! :slight_smile:

@oberon Thank you so much for your work and making this available. I am going to flash it right now! :bowing_man:

Thank you for your hard work.
It seems to work very well except Terminal refresh. Sadly, it's barely unusable because of refresh rate is very slow (line by line, not all screen). Do you have an idea about this ?

Hm. I did not experience this :thinking:
will investigate more tomorrow.

1 Like

Hello!!!! I'm actually interested in a Pinebook now! This could make it worthwhile (if I can find it instock ever.) Also, I'd sell off a kidney for an 8gb ram model. But I LOVE the idea of i3 on it!! Thanks for the great work!

LOL!!! its not so expensive :stuck_out_tongue: Only $199 and you can order it, Once the Pre-Order Booking starts tomorrow.


I'm almost positive it only comes in 4gb. . . Unless ram is upgradeable which I thought it wasn't. . . I sold off my Chromebook because that's just not quite enough ram for me current computer. I've got 16gb, but I really only need 8 honestly.

There is no way to increase the RAM as it is an SOC. Only possibility is to add zram to it as we normally do with ARM devices :wink:

I've never heard of such a thing. I will definitely look into it that's a very interesting idea. The only issue I have is I have no real need for another computer necessarily. But I really love what they are doing and would be willing to buy my first new computer in an insanely long time just because I could. I'd be willing to spend more if it just had enough ram where I know I wasn't buying a computer that was already under powered for me.

I am experiencing the same issue, weirdly I didn't have that when I while back I created an i3 image with the manjaro arm installer.


I experienced the slowness in terminals too. I actually ended up removing the compton.conf and rebooting. That seems to have solved the slowness I was seeing. So, even though I probably killed a ton of capability configured into picom, I think I isolated the issue to some sort of compton/picom configuration.

In addition, the default i3 configuration sets the trackpad settings using a prop name in xinput that seems to be different than what I saw in the list of props configured in the system. I changed the prop name to 'Pine64 Pinebook Pro Touchpad' and that seemed to make the pointer work more as expected. I assume there might have been a kernel update that changed some of the pinebook pro drivers and the way they are reported. The line in the i3 config that worked for me is:

exec --no-startup-id xinput -set-prop 'Pine64 Pinebook Pro Touchpad' 'libinput Accel Speed' 0.6

Hope that helps someone..


I was installing a different terminal emulator (e.g. st from suckless tools) and it was way more performant than the build-in uxvrt...

I've some issues with audio...

  • in the Firefox browser I can play audio / video properly on local speakers, but not to a connected bluetooth speaker
  • in the terminal I've installed ncspot, can start an audio track, but will not hear anything
  • when starting the PulseAudio Volume Control from the dmenu, it stucks with "Establishing connection to PulseAudio..."

Any tipps?

hmm looks like a log-off / log-on solved these issues....

I am also experiencing the refresh issues...

great observations, thank you!

For now I think we just need to settle with an alternative terminal emulator.
urxvt lags even with picom turned off...

for me this isn't working at all. Looks like hardware ID changed at some point in production :wink:

I have now made available @Chrysostomus's sterminal which makes use of st and tmux on our arm-unstable branch. Will test more and most likely replace urxvt with that for the arm-i3 edition.

If you want, I can also look into patching the scrolling into the terminal instead of using tmux for it. I remember it making the terminal significantly heavier before (like 10Mb total), but the situation might have changed.

EDIT: tested now. With current patches st-manjaro is 4,7Mb ram. With scrollback added it is 10,6Mb. St+tmux is still lighter.

For comparison, termite is 16Mb and lxterminal is 21Mb. Lxterminal is the lightest of these for tiling wms because of it's server model. It's still only 23Mb with 7 terminals open.

1 Like

Forum kindly sponsored by