Manjaro ARM (KDE) gets stuck while booting on my Raspberry Pi 3 B+

hello everyone. i tried to install manjaro arm on raspberry pi 3b+ using etcher. I downloaded the image (kde) from the official website and burnt it to my formatted usb drive using etcher. when i boot it up , it succesfully starts but it gets stuck on fb: switching to vc4dfrmb from simple. i left it on all night but in the morning its still stuck. how do i fix this?

i've never used arm with any linux, are you sure you downloaded the actual ARM release of manjaro and not the x64 one?

Yes i got it from manjaro-arm website

i believe @Strit is the ARM guy, have you read through for similar issues? sorry i cant be of more help but like i said, i know nothing about ARM/linux.

How are you plugging in the monitor?
With a HDMI to HDMI cable or a HDMI to DVI cable?

I've had similar issues when using HDMI to DVI cables.

PS: Moved to ARM category.

I used Hdmi To Hdmi Cable @Strit

Hm, can you try with another cable?
Like a high quality one?

Also, confirm that the rpi is actually booted by connecting via SSH.

@Strit an you explain how to connect it to a ssh( im a newbie)
Also can you post what a high quality cable looks like (i thought they were all the same)

Turn on the rpi3 and plug in an ethernet cable from the router.
Then from your desktop, run the following command:
ssh manjaro@<IP of rpi>
If it's booted, it will ask for the password for manjaro user, which is manjaro by default.

A high quality HDMiIcable are usually gold on the inside (the connectors themselves).

ok ill try and i will infrom you . Thanks @Strit

I tried high speed hdmi cable but there is no differnce @Strit

Ill try ethernet. ill post by tommorow @Strit

Hi @Strit I connected ethernet cable to my Rpi while Manjaro Started up and the issue seems to be resolved as it didn't get stuck there. I encountered another issue though. It said "failed to load regulatory.db". How do i fix this?

According to this post it should not be anything to worry about. Sounds like left over kernel code from pre-4.15 days.

@Strit Sorry to bring this up again, but now it says no ethernet found even though ethernet is connected. The ethernet light is also not on but it worked on raspbian on a different sd card.

Now it doesn't boot either.

It's starting to sound more and more like a corrupt SD card.
Can you try installing 18.12.1 on another SD card?

I also noticed that behavior on a 3B+.

Sometimes things get stuck during boot, sometimes the GUI won't open up, and sometimes it boots OK.

I tried different SD cards.
I tried different power supplies.
Peripherals attached: Keyboard/mouse

I did it on a usb stick and i'm pretty sure that it isn't corrupt because it booted up raspbian just fine.

i tested it on a sd card and that issue was resolved but now it seems that its stuck at

[ 12.876075] Bluetooth: Generic Bluetooth SDIO driver ver 0.1

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by