Manjaro ARM minimal for rpi4 + twm best option?

I would really like to run a twm like qtile or Awesome or i3 on my rpi4. I’ve seen that there are a few i3 releases for Manjaro ARM, but none for the rpi4.

Is my best bet just going ahead and installing the minimal release and then getting a twm up and running on my own afterwards?

Thanks for any help or advice.

Yes this is one of the option, as we cannot maintain many desktop environments atm.
If you would like to contribute then please use
manjaro-arm-tools from here and arm profiles here, push ur changes if you plan to maintain the de.

Thanks for taking interest in manjaro arm, your support will be very helpful to the community.

1 Like

Planning on getting this project underway, but having a very frustrating problem now. Have install the rpi4 minimal img and everything was fine. Configured my wifi using systems-networkd and wpa_supplicant. Pinging sites all over the place (Google, manjaro.org, facebook.com, etc) so I know I have a good stable connection.

But, every single pacman mirror is returning a 404-error. I have tried updating, reseting, optimizing the mirrors via pacman-mirrors utility with no success.

Is there something I am overlooking?

Pacman-mirrors doesn't work for ARM mirrors (maybe it will) as arm is not mirrored on the same server as the official 64-bit (and unofficial 32-bit).

I think there is a special version of pacman-mirrors for arm and there has been a similar thread on the 404 when the arm project changed some infrastructure.

Pick a mirror at gitlab and edit your mirror list and put at the top.

e.g. the dotsrc mirror

Server = https://mirrors.dotsrc.org/manjaro-arm/$branch/$repo/$arch

You are probably using on old image, with the old mirror structure, that no longer exists.

We did not provide new minimal images with version 20.02, so your best course of action is to use the Manjaro ARM installer or the Manjaro ARM Tools to create the image/SD card.

Thanks to you both for your answers - but @Strit it is a little bit hard to use the tools when you can install any packages because you get 404’s on every single mirror.

My only other available machine is an iPad Pro, so I am forced to rely on the rpi4 for my only Linux environment.

Also, I tried to follow those instructions in the threads you listed, with no success.

@linux-aarhus I have updated my etc/pacman.d/mirrorlist according to your instructions, and double checked it against the current mirrors listed at https://gitlab.manjaro.org/manjaro-arm/applications/pacman-mirrors/-/tree/master/data%2Fmirrors.

Here was my mirrorlist file:

##
## Manjaro Linux repository mirrorlist
##
## Use pacman-mirrors to modify
##

## Location  : Denmark
## Time         : 0.139
## Last Sync : 
Server = https://mirrors.dotsrc.org/manjaro-arm/$branch/$repo/$arch

## Location  : Germany
## Time         : 0.257
## Last Sync : 
Server = https://manjaro-arm.moson.eu/$branch/$repo/$arch

## Location  : United States
## Time         : 0.386
## Last Sync : 
Server = http://ftp-osl.osuosl.org/pub/manjaro-arm/repo/$branch/$repo/$arch

## Location  : Switzerland
## Time         : 0.768
## Last Sync : 
Server = https://mirror.scachemaille.ch/manjaro-arm/$branch/$repo/$arch

Got all 404 errors.

Then just to check again, I ran

sudo pacman-mirrors -g

And got this output, where it appears to make contact successfully with some mirrors and then updates my mirrorlist appropriately, but I am still getting 404’s for every single one

:: Querying servers, this may take some time...
Australia
-> 0.737 http://notmaindomain.me/stable/$arch/$repo
Denmark
-> ..... https://www.uex.dk/public/manjaro-arm/stable/$arch/$repo
Error: Failed to reach the server: Not Found
-> 0.195 https://mirrors.dotsrc.org/manjaro-arm/stable/$arch/$repo
Germany
-> 0.235 https://manaro-arm.moson.eu/stable/$arch/$repo
Switzerland
-> 0.754 https://mirror.scachemaille.ch/manjaro-arm/stable/$arch/$repo
United_Kingdom
Unites_States
-> 0.390 http://ftp-osl.osuosl.org/pub/manjaro-arm/repo/stable/$arch/$repo
-> ..... http://y0sh.co/manjaro-arm/stable/$arch/$repo
Error: Failed to reach the server: Not Found
:: Generated and saved ‘/etc/pacman.d/mirrorlist’ mirrorlist.

Obviously these are the wrong mirrors though, because they are the old ones, and I have to go back and put the new mirror links in mirrorlinks - but it doesn’t matter because it doesn’t fix the problem anyway.

A real pull-out-your-hair one, this! Any way to get this resolved without building a minimal image using the 20.02 release?

This is not a mirror problem but a device specific network problem.

Screenshot of dotsrc.org mirror

20200315-100414_451x777_screenshot

@linux-aarhus
Edited - sorry misunderstood. So what you are saying is that it is still a netowrk problem on my end?

Why am I able to ping that url with no package loss and good response time?

Both the tools and the installer is not meant to be used on the ARM devices. They are meant to be used on the x64 machines that create the images.
I can't help you create images, if your only device is the rpi4. You are better of using an image with a DE then.

@Strit Sorry to continue to be a pain - but I managed to get enough screen time on a laptop to create a virtual Manjaro XFCE machine, and use the manjaro-arm-tools to create and img file - and according to the virtual terminal I have been successful in creating an image with networkmanager and wget as additional packages, called Manjaro-ARM-rpi4.20.03.img

Now according to the documentation and conf file, it should have put the created img in

/var/cache/manjaro-arm-tools/pkg/

But the only thing there is the folder pkg-cache, and it doesn’t have that img in it, just all the images it uses to create img files...

I tried to do a find as well, no dice?

How did you install the tools?

The tools need those folders to actually exist.
The filename should be Manjaro-ARM-minimal-rpi4-20.03.img.xz.

Followed the readme.md here.

Could it be in the /img directory instead (would make more sense?)

1 Like

Ah yeah. Images will be in the img folder.
It actually says so in the readme:

This script will compress the image file and place it in /var/cache/manjaro-arm-tools/img/

TMF - Thanks...I can’t believe I missed that....onwards!

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by