Manjaro ARM no HDMI signal on Raspberry Pi 4

Hi!

I have no HDMI signal on screen (LG 24MT47D-PZ), with Raspberry Pi 4 Model B 4GB (firmware is up-to-date-> Bootloader: Tue 10 Sep 10:41:50 UTC 2019 , VL805: 000137ab) and
Manjaro-ARM-xfce-rpi4-19.12.img flashed on a 16 GB Kingston SD card.

Previously I tried to boot with Raspbian Buster Lite, but it also had no HDMI signal.
Then I changed parts of the Raspbian Buster Lite config.txt (according to the help of this video: https://youtu.be/JYrGoLbiyj8) and after that there was HDMI signal, the screen worked well.
So I think the problem is not in the screen, nor in the SD Card, nor in the HDMI cable, nor in the Raspberry Pi.

Please Help!
Have somebody ever experienced this problem before?
I want to migrate my whole life from Windows 7 to Manjaro and Rasberry Pi. :slight_smile:
Thank You!

Post your /boot/config.txt. What is the screen resolution of the LG 24MT47D-PZ

See /boot/overlays/README for all available options

gpu_mem=64
initramfs initramfs-linux.img followkernel
kernel=kernel8.img
arm_64bit=1
enable_gic=1
disable_overscan=1

#enable sound
dtparam=audio=on
hdmi_drive=2

#enable vc4
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

1 Like

Which hdmi port is the LG 24MT47D-PZ on
Still need the screen resolution of the LG 24MT47D-PZ

1366x768
16:9

Still need the hdmi port on the rpi4 the LG 24MT47D-PZ is on

It has only one HDMI port on the backside.

hdmi1 on the rpi4 (second to the USB-C)

1 Like

Try this and reboot after making changes:

gpu_mem=64
initramfs initramfs-linux.img followkernel
kernel=kernel8.img
arm_64bit=1
enable_gic=1
disable_overscan=1
 
#enable sound
dtparam=audio=on
hdmi_drive=2
 
# Most TV's will default to 1366x768
# Monitor attached to rpi4 hdmi port 1 1366x768
hdmi_mode:1=39
hdmi_drive:1=2
hdmi_group:1=2
hdmi_force_mode:1=1
hdmi_ignore_edid:1=0xa5000080
 
# If you want 1920x1280 instead use this:
# Monitor attached to rpi4 hdmi port 1 1920x1080 (1280p)
hdmi_mode:1=16
hdmi_drive:1=2
hdmi_group:1=1
hdmi_force_mode:1=1
hdmi_ignore_edid:1=0xa5000080
 
#enable vc4
dtoverlay=vc4-fkms-v3d
max_framebuffers=2
 
## Config's for hdmi port 1
 
# Monitor attached to rpi4 hdmi port 2 1366x768
hdmi_mode:2=39
hdmi_drive:2=2
hdmi_group:2=2
hdmi_force_mode:2=1
hdmi_ignore_edid:2=0xa5000080
 
# If you want 1920x1280 instead use this:
# Monitor attached to rpi4 hdmi port 2 1920x1080 (1280p)
hdmi_mode:2=16
hdmi_drive:2=2
hdmi_group:2=1
hdmi_force_mode:2=1
hdmi_ignore_edid:2=0xa5000080

Depending on the screen resolution of the other monitor I like the screen resolutions to be the same. The LG is probably capable of 1920x1280. If you want that let me know so we can make different config if this works.

6 Likes

It works!!! You are a life saver! Thank you very much!

Your welcome.

Hi, my new RPi4B-4GB has the same problem - the config.txt is standard as the one above but the monitor is an older LG 1680x1050 screen resolution connected to hdmi port 1. Can you tell me the correct parameters for this resolution?
Thanks!

Hi, with
#DMT-Betriebsmodus aktivieren
hdmi_group=2
#Auflösung: 1680x1050 / 60 Hz
hdmi_mode=58

I get an output on the port named "hdmi1" - never on "hdmi0". I tried it with your "~1:x" - nothing, and with "~0:x" - nothing, too. But the "hdmi0" is not dead - booting Raspian Buster works fine on "hdmi0".
Clueless...

This was a really useful post, thanks.

For anybody who wants to get their own screen working, all the settings you need are in these docs:

https://www.raspberrypi.org/documentation/configuration/config-txt/video.md

Have a read of the docs for hdmi_drive and hdmi_group before trying to set hdmi_mode.

I had to set hdmi_drive to 1 because I've connected to an old monitor with a DVI socket. Set it to 2 if you're using an HDMI screen.

Then you can decide whether you want hdmi_group to be 1 or 2. tl;dr — use 1 for TVs and 2 for monitors.

Finally, now you know which group you should be using, you can read the value for hdmi_mode out of the relevant table.

To control which HDMI port you're applying it to you can specify :0 or :1 (for the left and right ports on the Pi 4).

I've configured one of the ports to work with my vintage 1600x1200 60Hz monitor and (hopefully) left the other so it'll work if I take the Pi somewhere that I'd like to use a TV.

Here's the patch I applied to the config.txt that ships with 19.12:

patch /boot/config.txt <<'EOPATCH'
--- /boot/config.txt.orig       2020-02-08 18:47:17.000000000 +0000
+++ /boot/config.txt    2020-02-08 18:47:31.000000000 +0000
@@ -9,8 +9,16 @@
 
 #enable sound
 dtparam=audio=on
-hdmi_drive=2
+hdmi_drive:1=2  # HDMI, with sound, on second HDMI port
+
+# Configure first HDMI port to work with 1600x1200 60Hz monitor.
+#
+# See https://www.raspberrypi.org/documentation/configuration/config-txt/video.md
+#
+hdmi_drive:0=1  # DVI  (no sound)
+hdmi_group:0=2
+hdmi_mode:0=51
 
 #enable vc4
-dtoverlay=vc4-fkms-v3d
-max_framebuffers=2
+#dtoverlay=vc4-fkms-v3d
+#max_framebuffers=2
EOPATCH
3 Likes

Hi, I have the same problem with version 20.02.
I tried with 1080, but still didn't worked.
i have Panasonic TX-L37ET5E 1920x1080 60hz

Now it looks like that and still no video, only some random piksels

pu_mem=64
initramfs initramfs-linux.img followkernel
kernel=kernel8.img
arm_64bit=1
enable_gic=1
disable_overscan=1

#enable sound
dtparam=audio=on
hdmi_drive=2

#enable vc4
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

Force the monitor to HDMI mode so that sound will be sent over HDMI cable

hdmi_drive=2

Set monitor mode to DMT

hdmi_group=2

Set monitor resolution to 1920x1080 XGA 60Hz (HDMI_DMT_XGA_60)

hdmi_mode=82

Make display smaller to stop text spilling off the screen

overscan_left=20
overscan_right=12
overscan_top=10
overscan_bottom=10

Hi!
So, just starting with Manjaro and I thoght this was going to be my solution, but it wasn't. Then I read the documentation and starting changing parameters, but still nothing: "No signal" on my TV.
I don't even get a the green light flashing now... I don't know if that's ok.
The 1366x768 config should work, but it doesn't.
Let my copy my config.txt:

See /boot/overlays/README for all available options

See https://www.raspberrypi.org/documentation/configuration/config-txt/video.md

gpu_mem=64
initramfs initramfs-linux.img followkernel
kernel=kernel8.img
arm_64bit=1
enable_gic=1
disable_overscan=1

#enable sound
dtparam=audio=on
hdmi_drive=2

Most TV's will default to 1366x768

Monitor attached to rpi4 hdmi port 1 1366x768

hdmi_drive:1=2
hdmi_group:1=2
hdmi_mode:1=39
hdmi_force_mode:1=1
hdmi_ignore_edid:1=0xa5000080

#enable vc4
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

My TV is a Samsung 32" (HD UN32J4290AGCZB)

Any recommendation? Do you think the problem is on the file?

This is for the 2nd hdmi port on the board. You did not mention you were using dual monitors.

This is for the 1st hdmi port on the board. The one next to the power supply inlet. Make sure you are plugged into the 1st hdmi port with your hdmi cable.

hdmi_drive:0=2
hdmi_group:0=2
hdmi_mode:0=39
hdmi_force_mode:0=1
hdmi_ignore_edid:0=0xa5000080

OK, that was fast! fast and effective. Now is working.
By the way, how do you know I'm using dual monitors? :slight_smile: :

Although is slightly exceeding the limits of the screen (I will see how to fix it) I was able to make it work. Thanks a lot - and if you know how to force it to adapt it to the screen dimensions please let me know.

Looking at your config you said you was using indicated using the 2nd hdmi port.

Depending on which ever port the issue is on try this:

1st port:

disable_overscan:0=1

2nd port:

disable_overscan:1=1

Thanks, that worked really well for me.

Forum kindly sponsored by