Manjaro ARM Preview1 for Khadas Vim 3

Manjaro ARM Preview1 for Khadas Vim 3!

The Manjaro ARM project is proud to announce the first test release for the Khadas Vim 3!

This is our first official Khadas board support.

No screenshots of MATE yet


Torrents are back!


The VIM3 SBC is the latest addition to our popular Khadas VIM series. It is equipped with the powerful Amlogic A311D SoC, based on the big-little CPU architecture: x4 Cortex A73 performance-cores clocked at 2.2Ghz, and x2 Cortex A53 efficiency-cores clocked at 1.8Ghz, are merged into a hexa-core configuration, and fabricated with a 12nm process to maximize performance, thermal and electrical efficiency.

VIM3 is designed with the same form-factor as our popular VIM2 and VIM1. It is the size of a credit-card, and fits perfectly inside our DIY Case. Although diminutive, VIM3 is competitively-priced and fully-featured; everything you need is already built-in. The Pro-model comes with onboard 4GB LPDDR4/4X RAM, 32GB of EMMC storage and 2T2R 802.11ac Wi-Fi with Bluetooth 5.0.

How to install:

Download the image/zip file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn it to an SD card (8 GB or larger).

Put the SD card into Vim3's SD card slot and boot it up (might have to use the Key Mode). The Vim 3 should recognize the SD card as a bootable device and boot from it.

On the first boot, it will display an OEM type install. After you have made your choices it will reboot into your newly setup system.

Known Issues:

  • No HW acceleration. (yet)
  • No BT/Wi-Fi (yet)
  • No audio (at least in my test, although audio device did show up).
  • No eMMC images yet.
  • M.2 SSD not tested.


Please consider supporting us via Patreon.


Please advice which DTB have you used for this image? As there are S922x and A331D for the same VIM3 SOC. Just for others to know.

I will try this tonight.

Pretty sure we use the A331D, because that's the version we have.

:+1: Then its good for me. no need for me to check anything.


Hey, I tried it but its doesn't seem to boot.

I flashed the latest Ubuntu emmc using the usb flasher by amlogic and now it boots Ubuntu directly but with upgrade mode on it cannot recognize the manjaro usb

Hello dear,
Is this only for sd? I tried with USB stick but was not able to boot it.
I have Android pie in the EMMC already. I am able to boot other roms from usb while Android is still present.
Please advice how to make your img boot from usb stick.

Since we are using the SD card uboot in this image, it will probably only boot from USB.

But we are working on getting the OS to boot without uboot, as long as android is still present on the eMMC. So maybe it will work from USB there.

I have this one already dear. The current vim1 os works fine with vim3 if we just change the dtb file in the uEnv.ini
It can work from sd or usb and there is a script to install on emmc if required

We also have it. But we are trying some stuff, because we want to try to modify the kernel config. but the source from balbes does not allow us to do that it seems.
So I am currently trying to build the linux-next (which has vim3 support) and see how that goes.

What config do you want to modify? Can't we do it using the config file?
For linux support for vim3 I think we might have to wait for some time. Have you tried building manjaro from balbes kernel? If yes did you get any success with hdmi audio?.

I tried the mesa git version on vim3 with manjaro i feel the video on vlc is more smoother from before but laggy on full screen mode.
So we need to wait more for a working hw acceleration for mali :frowning:

I want to disable audit for one, but the menuconfig does not allow me to change it.
And setting CONFIG_AUDIT=n in the config directly, does not work. The resulting kernel still spams audit lines.

That's what I have been doing for the last couple of days. It boots fine, but as you also have noticed, it's missing HDMI audio and Wifi. Bluetooth works though.

Well, the mesa stuff has nothing to do with video acceleration. To get video acceleration you need the SoC's video decoder enabled. I don't know what the video decoder for AMlogic SoC's is called. For Allwinner it's called Cedrus and for Rockchip it's called Hantro.

Finally I was able to get Linux 5.3.0-rc5 working along with audio fix.
Screenshots and download Link

Able to watch 720p Videos smoothly on VLC even with full screen. But with CPU Load not HW Acc :smiley:

1 Like

Nice, I wonder if the sound fix will work on the 5.2.1 kernel from balbes aswell?

No I tried that on 5.2.1 and it didn't work, But I didnt try it after removing the pulseaudio. Maybe it should work.

Can you try those steps on 5.2.1 ?

Will try when I get home. :slight_smile:

What kernel source did you use for 5.3-rc5?

balbes repo with "LE" branch.

Thanks for that. :slight_smile:

Dont forget to remove the Extraversion in Makefile and keep it no blank space for the PKGBUILD to work.

And compile it on VIM3 itself with -j6 takes only 1hr 50mins :smiley: with a fan though.

Any luck with this? I tried it with 5.2.0 which was not too old than 5.2.1 and it didn't work for me.

Couldn't get it to work either. But then again, I can't on the 5.3 either.

Forum kindly sponsored by