Manjaro ARM Preview1 for Pinebook Pro

Manjaro ARM Preview1 for Pinebook Pro!

The Manjaro ARM project is proud to anounce the first test release for the Pinebook Pro!
These first images may not support all the hardware in the Pinebook Pro yet.
But thanks to @tsyseu and @Manawyrm, we do have a working 5.4 RC kernel with most things working!

These images are running a 5.4 RC kernel, which is basically mainline, but with a few patches to include Pinebook Pro support. They are also running the Panfrost driver, which may result in a few graphical issues on XFCE, like the wallpaper being deactivated on first login and some tray icons missing.



KDE Plasma


The Pinebook Pro is meant to deliver solid day-to-day Linux or *BSD experience and to be a compelling alternative to mid-ranged Chromebooks that people convert into Linux laptops. In contrast to most mid-ranged Chromebooks however, the Pinebook Pro comes with an IPS 1080p 14″ LCD panel, a premium magnesium alloy shell, 64 of eMMC storage, a 10,000 mAh capacity battery and the modularity / hackability that only an open source project can deliver – such as the unpopulated PCIe m.2 NVMe slot (an optional feature which requires an optional adapter). The USB-C port on the Pinebook Pro, apart from being able to transmit data and charge the unit, is also capable of digital video output up-to 4K at 60hz.

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn it to an SD/eMMC card (8 GB or larger).

The Pinebook Pro should recognize the SD/eMMC card as a bootable device and boot from it.

On the first boot, it will display an OEM type install. After you have made your choices it will reboot into your newly setup system.

Known Issues:

  • No Bluetooth.
  • Unstable Wifi (might crap out after around 10 minutes)
  • No audio cards.
  • Brightness and Volume function keys do not work.
  • Does not power off completely from software.
  • Suspend does not work.
  • To show the OEM setup on the XFCE edition, wait until the bootsplash has run for 10-15 seconds, then press ESC.


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.


Awesome! Thanks for this!

Happy day! That was incredibly quick!

Out of curiosity, if we need to disable/remove our eMMC to boot this from SD, is there a command to get Manjaro to find the eMMC after putting it back? I really want to rock Manjaro again, but I don't want to wait for my USB adapter, lol.

sudo fdisk -l

Check if you can see mmcblk2 116.49GB.

For now use Manjaro with SD Card until eMMC IMG is available.

Users can try the following to make the WiFi stable on idle.
Edit /etc/default/tlp with the following command

sudo nano /etc/default/tlp

Change the following Line




then save this file with CTRL + o and then CTRL + X
Restart the TLP Service with sudo tlp start

Hope this solved the wifi issue for now. Please test and report back.


wifi has been much more stable after this.

have some panfrost crashes in dmesg, but sounds like those have been anticipated. let me know if someone wants me to collect a dump or something.


Good to know this is SD only currently. I can certainly wait for the USB adapter in that case.

Has there been any discussion about adapting mrfixit2001's uboot fix script, to let SD booting be prioritized over eMMC on Manjaro too?

We're using his uboot only. So yes it will always prioritize sd card first and then eMMC.


It also prioritizes USB 2.0 for boot. So, if you've got an old USB stick somewhere, and just want to try some build you could use that. In the future, USB 3.0 booting will also be an option.


They are also running the Panfrost driver, which may result in a few graphical issues on XFCE, like the wallpaper being deactivated on first login and some tray icons missing.

Is this issue being tracked anywhere?

Great work!

We don't really know why this is happening so...

1 Like

Can't install gnome.

looking for conflicting packages...
warning: removing 'gnome-themes-standard' from target list because it conflicts with 'gnome-themes-extra'
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: gedit and gedit-code-assistance are in conflict (gedit-code-assistance<=3.16.0+4+gd19b879-1)

Are you just installing the gnome package group?

Because gedit-code-assistance is only in gnome-extras group, so it shouldn't get installed, when installing gnome.

1 Like

It's runs now. :stuck_out_tongue:

yeah. gedit-code-assistance is an old Arch Linux ARM package, that could probably use a rebuild without the group tag, or even dropped entirely, if gedit now supports it all.

This is awesome, great work!

During testing, when I installed a larger amount of packages, ~900 MB, the root filesystem disappeared during installation, leaving the SD-card unbootable even after a fsck -fy. First i suspected the SD-card, so I tried another one. Unfortunately, the result was the same.

Re-flashing the image and starting from scratch works fine, if I don't use storage too heavily.

Forum kindly sponsored by