Manjaro ARM Preview2 for Khadas Vim 3!

Manjaro ARM Preview2 for Khadas Vim 3!

The Manjaro ARM project is proud to announce the second test release for the Khadas Vim 3!
These images also work when flashed to a USB drive/stick!





The VIM3 SBC is the latest addition to our popular Khadas VIM series. It is equipped with the powerful Amlogic A311D SoC, based on the big-little CPU architecture: x4 Cortex A73 performance-cores clocked at 2.2Ghz, and x2 Cortex A53 efficiency-cores clocked at 1.8Ghz, are merged into a hexa-core configuration, and fabricated with a 12nm process to maximise performance, thermal and electrical efficiency.

VIM3 is designed with the same form-factor as our popular VIM2 and VIM1. It is the size of a credit-card, and fits perfectly inside our DIY Case. Although diminutive, VIM3 is competitively-priced and fully-featured; everything you need is already built-in. The Pro-model comes with onboard 4GB LPDDR4/4X RAM, 32GB of EMMC storage and 2T2R 802.11ac Wi-Fi with Bluetooth 5.0.

How to install:

Download the image/zip file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn it to an SD card or USB drive (8 GB or larger).

The Vim 3 should recognize the SD card/USB drive as a bootable device and boot from it.

On the first boot, it will display an OEM type install. After you have made your choices it will reboot into your newly setup system.

Known Issues:

  • No HW acceleration.
  • No Wi-Fi.
  • No audio. Seems to be conflicting with PulseAudio.
  • No eMMC images yet.
  • M.2 SSD not tested.


Please consider supporting us via Patreon.


Worked Perfectly.
Kernel 5.3.0-rc4 and not the rc6.

I like this new theme. When I am updating the manjaro-arm-tools it doesnt seem to update the profile directory. I am on the git version.

Profiles use a different git. You can update those, when you have manjaro-arm-tools-git installed with: sudo getarmprofiles -f

1 Like

My Vim3 is powered by my monitor which incorporates a USB hub. If I connect my mouse and keyboard to my monitor they are unusable in Manjaro ARM. I tried both Preview1 and Preview2.
When using the Khadas Ubuntu image, the USB hub of my monitor works without issues.
Is there anything I can do to enable it?

What mouse and keyboard is it?

The recent linux kernels have had some issues with some models of Logitech.

If you're using the usb-c port as power than it will not work as the otg-host.
You should power on the vim with power adaptor and connect 1 usb from vim to monitor to make it work as usb hub.
I hope this will help you.

It's a minor nuisance. I need an extra USB port for the WiFi dongle as the built-in one does not work.
It works with the Ubuntu image with 4.x kernel.
Brand of mouse and keyboard is HP.

Hola soy nuevo en estas distros y estoy usando manjaro Arm en Rasberry pi4 pero no tengo audio es algún problema o hay que esperar alguna actualización gracias

Hola y bienvenidos a la comunidad.

Compruebe el hilo del problema de audio para rpi4, ya que esto es para VIM3.
Aquí está el enlace para el hilo de problema de audio RPI4.

Lo siento, solo uso el traductor de Google para español.

Gracias y dónde consigo el enlace

Compartí el enlace de arriba

Forum kindly sponsored by