Manjaro ARM Preview2 for Pinebook Pro

Hi there, noticed three issues so far (using an up-to-date KDE version):
1, Chromium is quite choppy (scrolling on a page, typing, switching tabs, etc.). In comparison, Firefox is quite smooth.

2, I tried using the surf browser, but it turns out the whole window is just blank (grey), except for quick flashes of the actual page being displayed when i (de)maximize the window. Anybody tried this? What's your results with surf?

3, The trackpad doesn't seem to do taps, I have to physically click the pad to get a left mouse click out of it.

4, Restart and shutdown don't seem to completely work. Shutdown - doesn't seem to fully shut down. I get a blank screen and the power led is off, but I cannot boot up afterwards, unless I press the power button for approx 10 sec, and then power it on normall with a 2-3 second press of the button. Restart - similar, it never goes back up, I just end up with a blank screen and power led off and have to recover like from shutdown.

my 2 cents of the KDE version.

  • breeze-gtk should be included by default to be able to return to stock plasma without having to install other package (same problem on normal manjaro, I don't understand why to don't include it)
  • Man pages should also be installed by default (it's kind of a core linux fonctionality)

yeah chromium on youtube is unusable..

We use Firefox as default. We don't test Chromium or other browsers.

See answer to question 1.

Tap To Click will be enabled in KDE Plasma and XFCE in the next preview release.

This was fixed in a kernel update not that long ago, which is included in this (preview2) release.

Good suggestion. Will be included going forward, since it's a small package.

You are right. It's an oversight, since I barely use man pages. :stuck_out_tongue:

Just to inform..
Just updated my server and It seems I have some problems with apache.
so my mirror will be offline until I find the issue.
edit: there is just a php problem so the mirror work but may be offline time to time while I resolve my php issue.

EDIT2: all back to business

1 Like

So far so good (xfce edition)! I haven't had too many problems with wifi.. it has crapped out on me twice, and both times it was after leaving the laptop idle for a while. I'm not sure if there's a link.

The only issues that I've found so far that haven't been mentioned:

  • mugshot is missing by default. If you click the profile icon in Whisker menu, it'll throw an error.
  • Display settings have no refresh rate options (0.0 is the only option, on Debian 60hz was available)

I'm not entirely sure the graphics are working correctly, but I'm not terribly familiar with ARM graphics either. Retroarch has all 6 cores pinned at around 75% with no games running and background animations disabled. mpv and vlc are both pretty choppy playing videos. I'm not sure if the GPU is actually being used or if everything's being rendered/decoded on the CPU Nevermind, I just read that h264 decoding isn't there yet.

Either way, it's great option for the PBP so far!

Screenshot_2019-11-14_11-12-16

1 Like

BUT, it does not support VP8 and h264 yet.

Ouch. This won't help the Youtube situation (VP8 is extremely popular - and the next one is AV1 for which there aren't embed cores in the wild yet and which will probably rely on Neon SIMD optimisation) and on most video player through VLC (a lot of the popular videos are h264/MPEG4-AVC)

mpv and vlc are both pretty choppy playing videos. I'm not sure if the GPU is actually being used or if everything's being rendered/decoded on the CPU

The current lack of H264 implementation mentionned by @Strit above would very likely explain the chopiness.

Yeah I just saw that seconds after submitting my reply :confounded:

Thanks for the clarification, understood.

I'm well aware of that, and I did install preview2 (hence why I'm posting in this thread). I wonder if I'm the only one still having the issue. Are there any debugs I can grab that would be useful to provide?

Hello dear,
Have you tried to update linux-pinebookpro?

Can you get uart logs? If you have a uart cable for pinebook pro.

AFAIK power off issue was resolved for everyone in the latest kernel release.

please try updating using `sudo pacman -Syyuu'
This should update all the apps including the kernel and it should solve power off issue.

Hiya!
First, let me just say that I really appreciate all the work and effort you're all putting into this.

Second, I would also appreciate if you read what I write before responding to it, because right now it seems like you just don't, and I hope you understand how frustrating that can be. No offense intended!
As I've written in my first post here (a few responses above), I'm running from the preview2, with everything updated. No updates-to-be-done come out of -Syyuu. pacman -Q linux-pinebookproreturns version 5.4.0-0.7, same with uname -a. Can you confirm if that's new enough?

Good point about UART output, thanks for that. I'll grab it and post it here as soon as I get back home in two days. (bad timing for traveling :slight_smile: )

As a side-note, I've noticed the system time after boot-up continues from the time when I shut it down, despite RTC time being correct, and only self-corrects after a bit of time (probably when I get online?). Probably not worth investigating right now, given the irregular-shutdown/boot-up I'm having to do currently, but I just wanted to share it somewhere in case somebody has the same issue.

Again, thanks for all the awesome work, looking forward to further improvements!

That is the correct kernel.

I also am using kde on the pbp and having similar issues but I do not have to hold the power button for 10 seconds; it is more like 3 or 4 where it does not do that with the stock ubuntu image.

I was told today that the latest fix was a hack until it gets straightned out so may be that may be the issue.

Just noticed a small bug in the xfce version. Very minor but maybe worth mentioning. I have tap to click enabled for the touchpad and that works fine, but on reboot, it doesn't work in the lightdm greeter. I can click the mechanical buttons but tapping doesn't work.

Yeah. The Tap To Click you set in the DE only works in that DE. So not in the Display Manager, since that's not part of that DE.

Forum kindly sponsored by