Manjaro ARM Preview3 for Pinebook Pro

Manjaro ARM Preview3 for Pinebook Pro!

The Manjaro ARM project is proud to anounce the third test release for the Pinebook Pro!

But thanks to @tsyseu and @Manawyrm, we do have a working 5.4 RC with most things working!

These images are running a 5.4 RC kernel, which is basically mainline, but with a few patches to include Pinebook Pro support.

The Manjaro ARM Installer 1.2.8 has support for the Pinebook Pro, as well as all the other supported devices!

Changes since Preview2:

  • Fixed crackling speaker sound.
  • Tap To Click enabled by default in KDE Plasma and XFCE.
  • Add wireless tools (wpa_supplicant).
  • Now using fbturbo driver.

KDE Plasma


KDE Plasma


The Pinebook Pro is meant to deliver solid day-to-day Linux or *BSD experience and to be a compelling alternative to mid-ranged Chromebooks that people convert into Linux laptops. In contrast to most mid-ranged Chromebooks however, the Pinebook Pro comes with an IPS 1080p 14″ LCD panel, a premium magnesium alloy shell, 64 of eMMC storage, a 10,000 mAh capacity battery and the modularity / hackability that only an open source project can deliver – such as the unpopulated PCIe m.2 NVMe slot (an optional feature which requires an optional adapter). The USB-C port on the Pinebook Pro, apart from being able to transmit data and charge the unit, is also capable of digital video output up-to 4K at 60hz.

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn it to an SD/eMMC card (8 GB or larger).

The Pinebook Pro should recognize the SD/eMMC card as a bootable device and boot from it.

On the first boot, it will display an OEM type install. After you have made your choices it will reboot into your newly setup system.

Known Issues:

  • No Bluetooth.
  • Unstable Wifi.
  • Suspend does not work.
  • USB and Display from USB-C port does not seem to work.
  • To show the OEM setup on the XFCE edition, wait until the bootsplash has run for 10-15 seconds, then press ESC.
  • Audio gets played on both speakers and headphones when headphones are connected.


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.


There are still some issues with the audio. There doesn't seem to be any difference between the built-in audio and 3.5mm headphones (USB headset works fine). If I plug the headphones in, the audio is sent to both the headphones and the built in audio. In the settings of KDE it doesn't show any difference, it always says built-in audio.
Furthermore, with the headphones, it seems that after some time the card shuts down when no audio is being played. This is accompanied with a quite loud pop. When again some audio output is being played, a smaller pop is played (turning on of the DAC?)

Our kernel dev is aware of this issue.

I will add it to known issues in original post.

Hi Strit, spikerguy (and other devs working on this),

Would just like to say thanks for the amazing work :slight_smile: Manjaro already was my distro of choice on the (intel x64) laptops of my girlfriend and myself for the last few years. I think it's pretty amazing to see it's now running on ARM laptops as well!

I've booted up preview3 (KDE) on my PBP using an sdcard and wanted to share some experiences (some of which you and others already wrote about, so kicking in some open doors):

Good stuff:

  • It runs very smoothly. Somehow it feels more responsive than the default Debian install that is running from emmc, actually
  • Playing 1080p content on Youtube (the Diablo 4 trailer, it's sheer beauty :p) works very well and smoothly (apart for some screen tearing, see below)
  • Browsing in Firefox for an afternoon and also seems stable (Firefox crashes regularly in the default Debian install)

Not-quite-but-almost-there stuff:

  • Screen tearing is visible throughout the DE (e.g. when watching video's, scrolling through pages, etc.)
  • Wifi works but disconnects regularly,
  • Audio playback works but is on low volume, has a constant noticeable hiss and crackles now and then (the crackles seem to be louder)

I haven't attempted to use Bluetooth, the suspend functionality, or playing audio through headphones.

All in all using Manjaro KDE on the PBP is already very enjoyable and smooth. Again, thanks guys, your efforts are very much appreciated. Best of luck with the remaining obstacles.

I have testing here lately pinging google's dns server every 5 seconds and seems to help with the wifi dropping out so far.

ping -i 5

I really want to get to the bottom of the sound issue. I have not had any issues in the last preview and the only issue with the last kernel here is a pop when the sound is initialized and when a program stops using it. If you can with out me burning a new image is alsa-tools is installed. If it is not install it.

The default /var/lib/alsa/asound.state can be improved with upping the sound. Open up alsamixer in a terminal and do a F6 and choose the Rockchip device. When it comes up use your right arrow button and move 1 time to (Headphone Mixer) and max out the second bar using the up arrow then move over with your right arrow button 2 places to (Playback Polarity) and use the up arrow and change it to R Invert.

Now test the sound leaving the alsamixer open and see if it sounds ok. If it does then
Leave the alsamixer terminal open and open up another terminal and type:

sudo alsactl store

If you still hear crackling (not a pop) then let me know and do not do a sudo alsactl.

1 Like

Now using fbturbo driver.

How did you manage to get fbturbo working together with panfrost acceleration ?

When I pacman -S xf86-video-fbturbo-git, the Xorg.0.log files mentions:

[   266.444] (II) FBTURBO(0): no 3D acceleration because the driver has been compiled without libUMP
[   266.444] (II) FBTURBO(0): if this is wrong and needs to be fixed, please check ./configure log
[   266.452] (II) AIGLX: Screen 0 is not DRI2 capable
[   266.833] (II) IGLX: Loaded and initialized swrast
[   266.833] (II) GLX: Initialized DRISWRAST GL provider for screen 0

(btw: the libUMP mentionned above is for the closed source Mali drivers anyway. Not for Panfrost)

and glxinfo confirms that it's the llvmpipe (software) driver running, not panfrost.

If I uninstall fbturbo, acceleration works again under fbdeev.

1 Like

To me, thus seems like the symptom of fbturbo blocking the panfrost acceleration. as mentioned right above. Going back to fbdev fixed it for me

1 Like

Strit went back to fbturbo because in testing some desktop environments was having issues with panfrost. Panfrost is getting there but it still has a ways to go. I personally have not had any issues with KDE Plasma and panfrost.

Fbturbo when enabled does block panfrost. Anyone who wants to experiment and decide what is best for you and your DE you are using just do this to disable fbturbo and the opposite to enable it again. Reboot each time you make a change.

sudo mv /etc/X11/xorg.conf.d/99-fbturbo.conf /etc/X11/xorg.conf.d/99-fbturbo~
1 Like

Can I upgrade from the Preview 2? Or should I install from scratch instead?
Thank you

You can upgrade, but you won't get the pre-enabled tap-to-click functionality we added.
You would also need to install xf86-video-fbturbo-git to use the FBTurbo driver in KDE Plasma.

sudo mv /etc/X11/xorg.conf.d/99-fbturbo.conf /etc/X11/xorg.conf.d/99-fbturbo~

I just tried this and it caused a boot loop of sorts that I can't seem to get out of. I have the Preview2 Xfce variant installed to eMMC. I can't drop to TTY or even get an SD card/USB stick to boot with the image flashed, it does the same thing. Any idea how I can un-break this? I need to get in and rename the file back to what it was, but I can't access the files.

Screen recording:

This is not making much sense. It should boot with or with out fbturbo on the emmc and if you have a bootable sdcard it should boot from it. Are you sure there is not anything wrong with the sdcard meaning it has booted up before.

I do not use xfce but seems like on xfce you have to hit the Esc key after 10 or 15 seconds to get the login screen. Did you try that but that still does not explain not being able to boot off the sdcard unless it is not powering off. Hold down the power key until the power led goes off.

I got it fixed. I'm not sure what happened, but renaming fbturbo config does prevent my Xfce install from booting.

I renamed the config file as you suggested and rebooted and it started bootlooping. I did actually press escape in the screen recording, briefly towards the end of the video. It just showed a cursor in the corner, and continued to loop.

I had a working, unchanged copy of preview2 still installed to my SD card that I used to dd my permanent image to eMMC. I couldn't get that SD to boot up, it continued to bootloop. So I burned a fresh copy of the preview3 KDE version to a USB stick, and it continued to boot loop and wouldn't boot to the USB stick.

So on my third try, I re-burned a fresh copy of the KDE preview3 image to my SD card and managed to get in to rename the file. Now Xfce boots again from eMMC with the fbturbo config file restored.

Good. I know xfce was one of the DE's that @Strit mentioned that had issues with panfrost but he never mentioned doing something with xfce to disable anything. I have been turning off and on fbturbo today several times testing for differences with video, web and such and had no issues.

Strit has gone to bed but he will see this tomorrow and maybe he has some explanation for this.

It sounds like it was still powered on when you tried to boot off the sdcard and it was still doing it's thing when you inserted the sdcard and was still using the emmc and inserting and removing the sdcard during that time could have corrupted the data when it was accessing it by you removing the card with it being safely removed from the system.

Nope, it was completely powered off (at least according to the power LED). I'm careful about power states and safely unmounting removable storage before ejecting anything. Who knows. I think I'm going to install the KDE version permanently anyway :slightly_smiling_face:

1 Like

Yes there is the most important person who is working on the kernel development. We're all grateful for the work he is doing for the pbp device and manjaro community. @tsys

Thank you for those who support manjaro and appreciate teams effort.


I love KDE and that is my OS since I tested it a while back.

1 Like

Well.. GZDoom compiles and runs! It runs like :poop:, but it runs!



Got Preview 3 installed on the eMMC yesterday evening. Used the eMMC USB adapter to dd directly onto it.


  • For some reason, I ended up with root partition of ~5/6GB (the rest of the eMMC wasn't utilized). This wasn't the case when installing onto the SD Card

  • To reclaim the rest of the eMMC, I had to use the build on the SD Card (gparted couldn't make modifications to the root partition while booted from the eMMC) => 1 minute job to open gparted, hit that check and apply the change.

  • KDE Plasma edition boots a lot faster on eMMC and the whole system feels more responsive :smile:

  • I could be imagining it but it seems like the WiFi is a bit more stable when running from eMMC (but I haven't stressed it yet as I did when using the sd card)

  • Removed fbturbo directly instead of keeping it around. Most likely I will try it out when I get to install Krita or smth similar :slight_smile:

For whatever reason, I can't use virtualenv? That's something I will need to figure out (the depot tools used for building dart && flutter require python2). Using pyenv to install different python version throws an error as well.
Got the dart sdk cross compiled yesterday so for the next few days, it will be reading the Flutter source code and docs to get the engine compiled :smile:

On another topic, any ideas on how to debug properly GLX issues with Panfrost? The best I could do is to use LIBGL_DEBUG=verbose and get a bit more from Godot rinning in es2 mode but nothing that would lead me to which calls exacly aren't happy.

Awesome work! Manjaro runs really well on the Pinebook even in it's preview form :grin:

Forum kindly sponsored by