Manjaro ARM Preview4 for Pinebook Pro

Manjaro ARM Preview4 for Pinebook Pro!

The Manjaro ARM project is proud to anounce the 4th test release for the Pinebook Pro!
We are now nearing a quality where we can include the Pinebook Pro images in the regular release cycle. Hopefully it will be ready with 19.12.

But thanks to @tsyseu and @Manawyrm, we do have a working 5.4 RC with most things working!

These images are running a 5.4 RC kernel, which is basically mainline, but with patches to include Pinebook Pro support.

Changes since Preview3:

  • Fully working bluetooth
  • Fixed Wifi instability
  • Enable NVME in kernel config



KDE Plasma


The Pinebook Pro is meant to deliver solid day-to-day Linux or *BSD experience and to be a compelling alternative to mid-ranged Chromebooks that people convert into Linux laptops. In contrast to most mid-ranged Chromebooks however, the Pinebook Pro comes with an IPS 1080p 14″ LCD panel, a premium magnesium alloy shell, 64 of eMMC storage, a 10,000 mAh capacity battery and the modularity / hackability that only an open source project can deliver – such as the unpopulated PCIe m.2 NVMe slot (an optional feature which requires an optional adapter). The USB-C port on the Pinebook Pro, apart from being able to transmit data and charge the unit, is also capable of digital video output up-to 4K at 60hz.

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn it to an SD/eMMC card (8 GB or larger).

The Pinebook Pro should recognize the SD/eMMC card as a bootable device and boot from it.

On the first boot, it will display an OEM type install. After you have made your choices it will reboot into your newly setup system.

Known Issues:

  • Suspend does not work. (needs kernel changes)
  • USB and Display from USB-C port does not seem to work. Fixed with kernel update
  • To show the OEM setup on the XFCE edition and eMMc flasher images, wait until the bootsplash has run for 10-15 seconds, then press ESC.
  • Sound gets output to both speakers and headphones jack at the same time.
  • Missing sound in bluetooth headsets on Plasma. Install pulseaudio-bluetooth and reboot.


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.


I don't see anything about the sound issue (output on both speakers as wel as headphones and noisy output). Has this been fixed?

1 Like

How much changes between previews?

I would assume there is a reason that I can't just boot into preview and pacman update into "preview 4", as there is some bit of install script that runs at install time that differentiates this.

Bluetooth is working after updating my preview3 install.. and Panfrost performance seems to have improved significantly

I set kwin to use OpenGL and renamed my 99-fbturbo.conf file to disable it, and the desktop is running smoothly. Firefox runs well now, which was the biggest problem I was having.

Nice update, thanks guys

Thanks. Added to known issues.

Sometimes you can just update between previews, other times we make changes not possible with package updates. It depends on the preview.
From Preview3 to Preview4 you can just update, as the fixes are done in package updates.

1 Like

Do you know when the update will be pushed out to pacman's download mirrors?

It depends on when the mirrors syncronize.
But I pushed it out yesterday.

My NVMe drive should arrive today. I look forward to trying the NVMe boot!

I better clarify this, before you get disappointed.

We enabled the NVME drivers into the kernel.
This makes it possible to have the /boot on the eMMC or SD card and then ROOT on the SSD and boot into that.

What's the kernel version number in this build?


This doesn't sound right to me. Most likely the compositor isn't enabled when the session starts. It's either Xrenderer (software compositor) or no compositor at all. Either provides good experience on the PBP.

If it runs well, then don't play further with it for the moment :slight_smile: Once qt with gles2 (hopefully kwin with gles2 compositor as well) hit the distro, then it will run even better :grin:

I tried it too, but I got a washed out white effect everywhere when the OpenGL compositor is turned on. (shutting down composition with Alt + Shift + F12 makes the white disappear and the display usable again to switch back to XRender)

Does anyone else get the following warning message whenever linux-pinebookpro is updated and the fallback image is created, i.e. /boot/initramfs-linux-fallback.img:

==> WARNING: Possibly missing firmware for module: wd719x

Internet says the warning is generated because wd719x-firmware is missing. However, this would be Western Digital firmware for PCI-SCSI host adapters. Are there any WD PCI-SCSI host adapters in the Pinebook Pro?

That is normal. There are a couple of those warnings from time to time. It has been that way for a while on the x64 desktop kernel also. It is an old SCSI card firmware. I had one many years ago. The SCSI drives were a whole lot faster than the IDE's at that time. I had a RAID 5 configuration.

I am guessing they could be obsolete as they are in AUR. You can build and install the firmware packages if you do not like the warnings.

I still need to press Esc during install for both KDE and XFCE after the Manjaro splash screen goes on for a while. Whether its install on uSD or the emmc.

And, while I am trying out KDE.. after boot or fresh login, on the first app/window you open, I can't see any minimize/maximize/close options. I can see all those options on all future apps/windows.. i just take my cursor to the top right corner of the first window and click, window closes. so it's not a major issue, but the first window opened does not have those three main options..

This has been an issue since we switched to using Matcha themes in KDE.

So maybe we should go back to Breath themes again?

  • Switch back to Breath theme
  • Stick with current Matcha theme
  • I don't care about the theme, I change it anyway

0 voters

aah, okay.. interesting.. I haven't tried othre themes yet. it's not really a big deal. but finding the cause/solution is probably a better idea than just switching to Breath.. i'll try to see what's happening there..

Okay. I've been testing this a bit.

It seems to be connected to the hardware acceleration. By default we ship KDE Plasma with software acceleration to save on computing power. This disables a lot of effects.

If I enable HW acceleration, reboot and open an app, I get the minimize/maximize/close buttons.
If I disable it again, they are gone on the next reboots first app launch.

The Pinebook Pro is capable of running with HW acceleration enabled though. But you need special qt5 packages and panfrost driver for it.

Forum kindly sponsored by