Manjaro awesome freezes on logout / shutdown

Hi everyone !
I searched for this on google but I didn't find anything that worked for me. When I try to shutdown manjaro through GUI or terminal, it just freezes and stays like that. Any ideas ?
ps: sorry if I posted this in the wrong place.

This may be useful :

System:    Host: telno-pc Kernel: 4.19.85-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: Awesome 4.3 
           dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 5593 v: N/A serial: <root required> Chassis: type: 10 
           serial: <root required> 
           Mobo: Dell model: 09PY2G v: A00 serial: <root required> UEFI: Dell v: 1.2.0 date: 09/26/2019 
Battery:   ID-1: BAT0 charge: 38.3 Wh condition: 38.3/42.0 Wh (91%) volts: 13.1/11.4 model: BYD DELL 1VX1H99 type: Li-ion 
           serial: 1836 status: Full 
CPU:       Topology: Quad Core model: Intel Core i7-1065G7 bits: 64 type: MT MCP arch: Ice Lake rev: 5 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23968 
           Speed: 908 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 1033 2: 933 3: 828 4: 1101 5: 867 6: 1084 7: 1081 8: 945 
Graphics:  Device-1: Intel vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:8a52 
           Device-2: NVIDIA GP108M [GeForce MX230] vendor: Dell driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:1d11 
           Display: x11 server: X.Org 1.20.5 driver: modesetting alternate: fbdev,intel,nouveau,nv,vesa compositor: compton 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics (Ice Lake 8x8 GT2) v: 4.5 Mesa 19.2.6 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:34c8 
           Sound Server: ALSA v: k4.19.85-1-MANJARO 
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel port: 3000 
           bus ID: 02:00.0 chip ID: 10ec:8136 
           IF: enp2s0 state: down mac: 98:e7:43:23:81:98 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell driver: ath10k_pci v: kernel 
           port: 3000 bus ID: 03:00.0 chip ID: 168c:0042 
           IF: wlp3s0 state: up mac: 40:5b:d8:01:14:79 
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-10:4 chip ID: 0cf3:e009 
Drives:    Local Storage: total: 476.94 GiB used: 8.75 GiB (1.8%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: PM991 NVMe 512GB size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: S509NE0MA80307 rev: 25304039 scheme: GPT 
Partition: ID-1: / size: 47.81 GiB used: 8.67 GiB (18.1%) fs: ext4 dev: /dev/nvme0n1p7 
Sensors:   System Temperatures: cpu: 57.0 C mobo: N/A gpu: nouveau temp: 511 C 
           Fan Speeds (RPM): cpu: 2982 
Info:      Processes: 212 Uptime: 1m Memory: 15.44 GiB used: 1020.0 MiB (6.5%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: zsh v: 5.7.1 running in: lxterminal inxi: 3.0.36 

nouveau, it's always nouveau.

did you install with the free drivers on purpose, or because the nonfree drivers would not boot?

I didn't install anything on purpose, I just added nouveau.modeset=0 because I saw that in some other post and I though that would maybe work

if you auto-install the proprietary drivers on that laptop you'll get bumblebee because it's an optimus laptop, it's a roll of the dice if it will actually work or leave you with a black screen.

nouveau, which are the nvidia open source drivers that work ok on much older hardware but on newer hardware cause a lot of problems.

this describes different optimus solutions you have available, i definitely dont recommend bumblebee. optimus-switch and prime both work well

if you go with optimus-switch, this is the version you would use, meant to work with lightdm. it's what i use on my optimus awesome-wm laptop

@linesma made this that's meant to work with optimus-switch (you would set it up after)
https://github.com/linesma/manjaroptimus-appindicatorhttps://github.com/linesma/manjaroptimus-appindicator

So I should run this install script and then run set-nvidia.sh to get both nvidia and intel ?

you want to get rid of video-linux first. your hardware bus id's already match the defaults set in optimus switch so this would be the express way to go without having to read my messy instructions on the readme

run these commands 1 at a time, if any command fails (they shouldn't), stop and post the output of that command.

sudo mhwd -r pci video-linux
sudo mhwd -i pci video-nvidia-430xx

cd ~
sudo pacman -S linux419-headers dkms acpi_call-dkms xf86-video-intel git
git clone https://github.com/dglt1/optimus-switch.git
cd ~/optimus-switch
chmod +x install.sh
sudo ./install.sh

once thats done, post these outputs and i'll let you know if it all looks good.

mhwd -li
ls -laR /etc/X11 ; cat /etc/X11/xorg.conf.d/*.conf
ls -la /etc/modprobe.d ; cat /etc/modprobe.d/*.conf
ls -la /etc/modules-load.d ; cat /etc/modules-load.d/*.conf
2 Likes

On the first command, it tells me video-linux isn't installed

Continue with the rest of the posted commands, but before that, post this

mhwd -li
1 Like

I can't show you the exact output because my pc freezes right after it runs the command but it tells some warnings about USBs

15757280578937117407988398969333
It tells me some command failed

Also it seems to be stuck now

1575729608476632489641437428694
Could not get the whole output before my PC froze, here's what I got

1575729726568244161012634618019 My PC unfroze for a sec, here's what I see now

Anyways it seems to work now. Thanks !

1 Like

make sure your manjaro is up to date

sudo pacman -Syyu

and that you have headers installed for each kernel you have. if the output of mhwd-kernel -li shows that you have linux419 and linux53for example, make sure you have both of these installed

linux419-headers
linux53-headers

your welcome, glad it worked out. :+1:

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by