Manjaro becoming very slow

System:
  Kernel: 5.7.9-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  Desktop: Gnome 3.36.4 wm: gnome-shell dm: GDM 3.36.3 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: ASUSTeK product: VivoBook S14 X411UF v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: X411UF v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: X411UF.201 date: 12/05/2017 
Battery:
  ID-1: BAT0 charge: 25.9 Wh condition: 27.3/42.1 Wh (65%) volts: 11.5/11.5 
  model: ASUSTeK ASUS Battery type: Li-ion serial: <filter> 
  status: Discharging cycles: 937 
Memory:
  RAM: total: 7.66 GiB used: 4.36 GiB (56.9%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 8192 KiB bogomips: 32012 
  Speed: 763 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 784 2: 800 
  3: 801 4: 800 5: 740 6: 800 7: 800 8: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon 
  art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm 
  lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae 
  pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti 
  pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:5917 
  Device-2: NVIDIA GM108M [GeForce MX130] vendor: ASUSTeK driver: nouveau 
  v: kernel bus ID: 01:00.0 chip ID: 10de:174d 
  Display: x11 server: X.org 1.20.8 driver: nouveau compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.1.3 
  direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.7.9-1-MANJARO

At the base of my installation I think everything was working fine. I could have instances of Postman, VScode, and open Chrome without any worries. But for the past few weeks; just opening vscode + Postman has caused my system to crash despite my hardware performance.

So far I don't know which indicator to check to fix the problem if there is one.

  • I still have space on my system disk (45GB)
  • my system is up to date

Is it processor or memory problems or just my system being corrupted ???

Any help on the source of the problem and how to improve performance would be welcome

Welcome to the forum! :beer:

Please don't take this the wrong way, but do take a look at this post below... :arrow_down:

1 Like

wow that scared the op off

Considering that the OP put a like on my post, I consider this unlikely. :man_shrugging:

:sweat_smile:
I'm a bit new to Manjaro. And thank you for your input. I'm open to all kinds of help, guys.

1 Like

hi my post is better now :sweat_smile:

Have you tested your RAM for errors? Try testing it with memtest86+ and let it run for about 24 hours.

Another possible source of crashes could be overheating due to dust in the fans or in the cooling vents. Check those too, and clean them out if necessary.

for memtest86+ I got

bash: memtest86+: command not found

It is not a command. It's a modified kernel that loads no userspace components and does nothing but test your RAM. If it's installed, then it should be available as a boot option. If you don't have it installed... :arrow_down:

sudo pacman -Syyu memtest86

There are also bootable live images with memtest86+, if you'd rather not install it.

From the inxi (even tho truncated) it seems your system is using nouveau drivers. Is well know to make hybrid laptops underperform. Look up for optimus-manager in the forum.

There is a newer BIOS for it

I would recommend using a swapfile ar systemd-swap, even tho i don't know how you created the partitions ...

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by