Manjaro Boot Fails

I've just installed Manjaro on my ASUS K550V alongside Windows 10 from Live USB. Given the amount of problems that other distros have given me on this PC I was surprised by how smooth the Live was.
However, after the installation completed and I was prompted to restart the system, even though GRUB works fine the OS just won't start.
Selecting the Manjaro GRUB Option brings back the ASUS splashscreen and nothing else, I can't even get a boot log to see if any errors occur. I've tried waiting for a long time and nothing happens.
The first thing I tried was to edit GRUB to boot Manjaro with 'nomodeset' because that had been an issue before but not this time.
Searching the web I found a lot of questions related to GRUB errors but as I said the GRUB works correctly in my case. I am even able to boot into Windows from GRUB and it's all good.
I tried editing boot options from BIOS and boot straight into the OS but whatever I do it just takes me back to the GRUB and it's all over again.

My PC is an ASUS K550V with an Intel Core i5-6300HQ and NVidia Geforce GTX 950M plus 12 GB of RAM and a 500GB HDD (which is partitioned 300 for Windows and approx 170 for Manjaro).
I did install Manjaro in UEFI mode and no errors occurred during installation.

Make sure you disable the fast boot and secure boot from BIOS.
Also try with
acpi_osi=! acpi_osi=“Windows 2009”
acpi_osi=! acpi_osi=“Windows 2012”
acpi_osi=! acpi_osi=“Windows 2015”
instead of nomodeset or along with it...

1 Like

Nope, still the same.
What do those commands do?

I may misunderstood.. These are grub cmdline parameters. You can add them at grub command-line at your Grub menu (press E to edit, find the line that starts with linux and add these at the end, or before resume=UUIDxxxxx. Boot with F10).
They randomly help boot problems on several "difficult" HW.

Can you clarify this? WHERE do you select Manjaro? At UEFI menu or at Grub menu?
What do you mean "Grub works fine" exactly?


Yes I figured those were grub parameters, but still they didn't help, I was just curious about their exact functioning because I'd hate to waste a chance to learn something.

The PC boots into the GRUB menu, from there I'm able to choose between Manjaro, Advanced Options for Manjaro (I've already tried booting into fallback mode but it doesn't change a thing) and Windows.
Windows works as expected but Manjaro does what I've described.
I've also tried to boot into Manjaro straigh through the UEFI menu and maybe I'm missing something but I'm only able to start the GRUB again.

I think I didn't express myself correctly, my apologies.
What I mean is that I can't tell if there's something wrong with GRUB or with Manjaro itself, but to me it looks like it's not GRUB's fault since there are no errors shown at any point and also because I can boot into Windows like normal.
I'm not familiar with GRUB though, is there a way I can access boot logs from the GRUB command line and take a look?

Not the grub cmdline, but edit Manjaro entry and, at linux line, remove quiet and add 3 (Number) at the end of the line. Then press F10 to boot, so you can see the logs and finally end up to TTY. There you may login as user and troubleshoot, get logs etc.
Read this for how-to and post info (from TTY)

inxi -SMCGpuoxxxz
mhwd -li
journalctl -b -p3 | cat
cat /var/log/Xorg.0.log
1 Like

After a long timeout, this gives the following output:

ACPI Error: Method parse/execution failed \_SB.PCI0.PGON, AE_AML_LOOP_TIMEOUT (20180810/psparse-516)
ACPI Error: Method parse/execution failed \_SB.PCI0.PEG0.PG00._ON, AE_AML_LOOP_TIMEOUT (20180810/psparse-516)

If I let it run some more it keeps repeating:

INFO: task lspci:723 blocked for more than 120 seconds.
            Tainted: G                      OE        4.19.0-3-MANJARO #1

The same goes for mhwd -li .
Also I can't seem to stop this process and reacquire control of the terminal so I've had to reboot.
Shutdown hangs at:

A stop job is running for Session 1 of user skrymr ( X m YY s / 3 m 00 s)

Waiting for the timeout to finish allows it to reach:

Reached target Shutdown.
Reached target Final Step.
Starting Power-Off...

And here it loops again the same message as before:

INFO: task lspci:723 blocked for more than 120 seconds.
            Tainted: G                      OE        4.19.0-3-MANJARO #1

Forcing me to manually turn it off by holding the power switch.

journalctl -b -p3 | cat returns:

tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/response buffer. [mem 0xfed40000-0xfed4087f flags 0x200] vs fed40080 f80
tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/response buffer. [mem 0xfed40000-0xfed4087f flags 0x200] vs fed40080 f80
nouveau 0000:01:00.0: bus: MMIO read of 00000000 FAULT at 022554 [ IBUS ]
nouveau 0000:01:00.0: bus: MMIO read of 00000000 FAULT at 10ac08 [ IBUS ]
nouveau 0000:01:00.0: DRM: Pointer to TMDS table invalid
dell_smbios: Unable to run on non-Dell system

Finally I ran cat /var/log/Xorg.0.log | grep -e EE -e WW for brevity and this was the output:


I understand that a lot of the previous stuff might be useless but I copied it all in the sake of completeness.

During installation, have tried booting with "non-free" drivers option at the initial screen?
Those tpm _crb messages are not critical. It seems there is a problem with video drivers.

I would suggest you install Manjaro with non-free drivers. Check first the Live media if it works fine with non-free and if so, go ahead and do install.
Alternatively you could boot to TTY and uninstall free, install non-free with mhwd, but it is a fresh installation, you can just re-install fully.. :wink:

1 Like

I figured that was the problem, however the thing is that free drivers were the only ones that worked with my PC on linux.
I changed many distros and everytime I couldn't get the GPU to work, neither with free drivers (tried both Nouveau and Bumblebee) nor with non-free. However with the free drivers I was still able to use the system's GUI because the built-in CPU graphics would work.
Installing non-free drivers would cause my computer to instantly freeze completely and the GPU fans would start whirring full speed.
Matter of fact, it's exactly what happens if I try to boot the Manjaro Live media with non-free drivers.

Can you please boot into a live environment and provide system details...

inxi -Fxxxz

Without these makes if difficult to know what we are dealing with hardware wise.

1 Like

Have you tried this kernel parameter:

  Host: manjaro-gnome Kernel: 4.19.0-3-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Gnome 3.30.1 wm: gnome-shell dm: GDM 3.30.0 
  Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK product: X550VX v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: X550VX v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: X550VX.302 date: 05/04/2017 
  ID-1: BAT0 charge: 42.5 Wh condition: 42.5/44.2 Wh (96%) volts: 14.4/14.4 
  model: ASUSTeK ASUS Battery type: Li-ion serial: <filter> 
  status: Not charging cycles: 175 
  Topology: Quad Core model: Intel Core i5-6300HQ bits: 64 type: MCP 
  arch: Skylake-S rev: 3 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18436 
  Speed: 800 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 
  Device-1: Intel HD Graphics 530 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:191b 
  Device-2: NVIDIA GM107M [GeForce GTX 950M] vendor: ASUSTeK driver: nouveau 
  v: kernel bus ID: 01:00.0 chip ID: 10de:139a 
  Display: x11 server: 1.20.3 driver: nouveau compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) 
  v: 4.5 Mesa 18.2.3 compat-v: 3.0 direct render: Yes 
  Device-1: Intel Sunrise Point-H HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a170 
  Sound Server: ALSA v: k4.19.0-3-MANJARO 
  Device-1: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter 
  vendor: XAVi driver: rtl8821ae v: kernel port: d000 bus ID: 02:00.0 
  chip ID: 10ec:8821 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: c000 bus ID: 03:00.1 
  chip ID: 10ec:8168 
  IF: enp3s0f1 state: down mac: <filter> 
  Local Storage: total: 494.64 GiB used: 88.1 MiB (0.0%) 
  ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: Kingston model: DT microDuo 3.0 
  size: 28.88 GiB serial: <filter> rev: PMAP scheme: MBR 
  ID-1: / size: 8.72 GiB used: 88.1 MiB (1.0%) fs: overlay source: ERR-102 
  System Temperatures: cpu: 39.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2400 
  Processes: 193 Uptime: 2m Memory: 11.63 GiB used: 1.08 GiB (9.3%) 
  Init: systemd v: 239 Compilers: gcc: N/A Shell: bash v: 4.4.23 
  running in: gnome-terminal inxi: 3.0.27 

Doesn't work, I've also tried it in combination with nomodeset.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by