Manjaro boot stuck at 'started Network Manager script dispatcher service'

I am using dual boot with manjaro and windows 10
i had wiped my efi partition and hence i had to restore the partition using this guide for UEFI

this helped me restore grub but after selecting manjaro from grub, i was getting black screen with HP logo.

then i followed this

i was able to boot into manjaro but got stuck at
started Network Manager script dispatcher service

please help me fix this.
Thank you

1 Like

if you could provide some more info it would be helpful to both you and the person willing to help.

also, is this a new install?
was this install working before you deleted the efi partition? if yes, do you remember needing certain kernel parameters to get manjaro to boot properly?

any other changes made while trying to figure out how to fix the efi issue?

I have used the install for almost 4-5 days. I did set nomodeset while booting from USB because I use nvidia GPU. I just followed the guide in the link I provided while trying to fix efi.
I'd be happy to provide any other details that you'd want.

Also here's the link to the topic where I thought it was a grub error rather than os boot error

This topic was created by me because I. Thought there was some issue with grub

since your having trouble booting manjaro, it would be easier for you to boot the live usb, once on the live desktop connect to network, use manjaro-chroot to get into your already installed manjaro and be able to copy/paste needed terminal command outputs so i/we can better assist you.

for now, from terminal:
manjaro-chroot -a
if it asks for pw its "manjaro"
inxi -Fxxxz
cat /etc/default/grub
be sure to post each output separately with 3 backticks ``` before and after each output. or just click the </> button above the forum post text box

I'm unable to chroot using - a

sudo manjaro-chroot - a

==> Detected systems:
 --> 0) ManjaroLinux
==> Select system to mount [0-0] : 
==> ERROR: You can't mount 0!

Should I manually mount partitions and chroot?

sudo mount /dev/sda9 /mnt
sudo manjaro-chroot /mnt

Yes, posting the results of lsblk -f might also help, it will show us your partition layout.

select 1 not 0 !

try entering "1" like @stephane said, if that doesnt work you can follow the mhwd-chroot instructions in the grub wiki to chroot in.

OP is able to boot from grub as sid in his first post.
It is at booting OS that he hangs at "started Network manage".
There is no need to fix grub.

it was more about seeing if he/she has any added parameters in /etc/default/grub that could be causing the system not to finish boot to graphical environment, i just figured why not check since manjaro was booting fine prior to mistakenly removing the efi partition

Here are the outputs

inxi -Fxxxz

12System:    12Host manjaro-i3 12Kernel 4.19.2-1-MANJARO x86_64 12bits 64 12compiler gcc 12v 8.2.1 
           12Desktop i3 4.16 12info i3bar 12dm N/A 12Distro Manjaro Linux 
12Machine:   12Type Laptop 12System HP 12product HP Pavilion Gaming Laptop 15-cx0xxx 
           12v Type1ProductConfigId 12serial <filter> 12Chassis 12type 10 12serial N/A 
           12Mobo HP 12model 8478 12v 70.39 12serial <filter> 12UEFI Insyde 12v F.11 12date 08/13/2018 
12Battery:   12ID-1 BAT1 12charge 36.9 Wh 12condition 51.8/52.8 Wh (98%) 12volts 11.6/11.6 
           12model Hewlett-Packard PABAS0241231 12type Li-ion 12serial <filter> 12status Discharging 
12CPU:       12Topology Quad Core 12model Intel Core i5-8300H 12bits 64 12type MT MCP 12arch Kaby Lake 12rev A 
           12L2 cache 8192 KiB 
           12flags lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 12bogomips 36872 
           12Speed 1108 MHz 12min/max 800/4000 MHz 12Core speeds (MHz) 121 1100 122 1100 123 1100 124 1100 
           125 1100 126 1100 127 1100 128 1100 
12Graphics:  12Device-1 Intel UHD Graphics 630 12vendor Hewlett-Packard 12driver i915 12v kernel 
           12bus ID 00:02.0 12chip ID 8086:3e9b 
           12Device-2 NVIDIA GP107M [GeForce GTX 1050 Mobile] 12vendor Hewlett-Packard 12driver N/A 
           12bus ID 01:00.0 12chip ID 10de:1c8d 
           12Display 12server X.Org 1.20.3 12driver none 12compositor compton 12resolution 1920x1080~60Hz 
           12OpenGL 12renderer Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) 12v 4.5 Mesa 18.3.1 
           12compat-v 3.0 12direct render Yes 
12Audio:     12Device-1 Intel Cannon Lake PCH cAVS 12vendor Hewlett-Packard 12driver snd_hda_intel 
           12v kernel 12bus ID 00:1f.3 12chip ID 8086:a348 
           12Sound Server ALSA 12v k4.19.2-1-MANJARO 
12Network:   12Device-1 Intel Wireless-AC 9560 [Jefferson Peak] 12driver iwlwifi 12v kernel 12port 5000 
           12bus ID 00:14.3 12chip ID 8086:a370 
           12IF wlo1 12state up 12mac <filter> 
           12Device-2 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 12vendor Hewlett-Packard 
           12driver r8169 12v kernel 12port 3000 12bus ID 03:00.0 12chip ID 10ec:8168 
           12IF eno1 12state down 12mac <filter> 
12Drives:    12Local Storage 12total 946.36 GiB 12used 10.81 GiB (1.1%) 
           12ID-1 /dev/sda 12vendor HGST (Hitachi) 12model HTS721010A9E630 12size 931.51 GiB 
           12speed 6.0 Gb/s 12serial <filter> 12rev A3T0 
           12ID-2 /dev/sdb 12type USB 12model SMI USB 12size 14.84 GiB 12serial <filter> 12rev 1100 
12Partition: 12ID-1 / 12size 68.40 GiB 12used 9.03 GiB (13.2%) 12fs ext4 12dev /dev/sda9 
           12ID-2 /home 12size 432.75 GiB 12used 1.67 GiB (0.4%) 12fs ext4 12dev /dev/sda10 
12Sensors:   12System Temperatures 12cpu 43.0 C 12mobo 29.8 C 
           12Fan Speeds (RPM) N/A 
12Info:      12Processes 230 12Uptime 5m 12Memory 7.68 GiB 12used 716.1 MiB (9.1%) 12Init systemd 12v 239 
           12Compilers 12gcc 8.2.1 12Client Unknown Client: systemd 12inxi 3.0.28 

cat /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=6b4e4449-c0a6-44d0-8188-f5df22ea6c83"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

lsblk -f

|-sda1                     212.6M    17% /boot/efi
|-sda9                      55.9G    13% /
`-sda10                      409G     0% /home

i figured it was optimus (intel/nvidia) dual gpu issues, lets see what video drivers your using
can you post out put of:
mhwd -li
NOTE: the following directions are dependent on which drivers you currently have installed, also remember you need to either chroot in from live usb to make these changes or you can also edit the grub at boot so it drops you at a tty instead of a graphical environment, to make manjaro boot to a tty do the following:
when you get to the grub screen during boot, select your manjaro from grub, dont hit enter, instead hit " e " to edit and on the line beginning with "linux" you need to only delete the word "quiet" and replace it with the number " 3 " then hit ctrl+x or F10 to boot, and then do the following.

im guessing bumblebee installed by default, for me to be able to boot to a graphical environment an added kernel parameter makes it work. depending on what you have installed for video drivers (at this point im assuming they are most likely bumblebee)

if that is whats installed when you check mhwd -li then do the following:

sudo nano /etc/default/grub
this is from your posted grub output (original)

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=6b4e4449-c0a6-44d0-8188-f5df22ea6c83"

now edit and make it exactly the way shown here:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=\"!Windows 2015\" resume=UUID=6b4e4449-c0a6-44d0-8188-f5df22ea6c83"

now save (ctrl+x, then "y" to save)

sudo update-grub
then reboot and see if its working.

1 Like

I did change the line and now I'm stuck at
started accounts Service during boot15469692643347461951686710260617

which did you change? replacing "quiet" with "3" or you edited /etc/default/grub ?

what was the output of mhwd -li ??
if you chrooted in, how? and are you sure you were actually in? im sure there are better ways but i usually look for something i explicitly installed or check folder contents.

Here is the output of

mhwd -li

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI
           video-linux            2018.05.04                true            PCI
         network-r8168            2016.04.20                true            PCI

Warning: No installed USB configs!

I did replace quiet with 3 during boot but since id be unable to copy the exact same line in /etc/default/grub, i booted a live disk and chrooted to manjaro and then changed

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=6b4e4449-c0a6-44d0-8188-f5df22ea6c83"


GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=\"!Windows 2015\" resume=UUID=6b4e4449-c0a6-44d0-8188-f5df22ea6c83"

I chrooted using

manjaro-chroot -a

==> Detected systems:
 --> 0) ManjaroLinux
==> Select system to mount [0-0] : 
==> Mounting (ManjaroLinux) [/dev/sda9]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
 --> mount: [/mnt/home]

ok, lets try some different parameters, if the one i had you use before doesnt work, these should.
edit /etc/default/grub and change the line to this:
sudo nano /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=! acpi_osi=“Windows 2009” resume=UUID=6b4e4449-c0a6-44d0-8188-f5df22ea6c83"

save and then update grub
sudo update-grub
reboot and let me know how it goes


changing to

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=! acpi_osi=“Windows 2009” resume=UUID=6b4e4449-c0a6-44d0-8188-f5df22ea6c83"

works fine and now im able to boot into the system.

If you dont mind can you explain what went wrong why this actually worked?
Thanks a lot!

glad to hear it worked out for you.

some optimus laptops can be problematic and need further steps to work properly with linux and nvidia not being open source only makes it more difficult. there are a few different ways of making them work.

  • bumblebee (what your using)that often needs kernel parameters to make work properly and for everyday use works for most but not the best option if graphical performance is your main priority but allows for gpu switching (uses your integrated intel gpu by default which saves power and allows to run certain programs with optirun <name of app/game>. bumblebee has other limitations/issues i'm not crazy about but it works fine for me (for the past week or two anyway) on my openbox install that i dont intend on doing anything graphic intensive.
  • prime (my preference, what i use on my main kde install) where all rendering is done on the nvidia gpu and then offloaded to the intel gpu for display. this has both nvidia and intel gpu powered on at all times so no switching is needed but also uses a bit more power, it also uses the proprietary nvidia drivers. i prefer this option because it just works, once setup ive never had to make any changes to it or run into any issues and since my primary objective is perfermance over battery life (its a gaming laptop, i didnt buy it for its long battery life).
  • optimus-manager which allows for switching per session and re-writes configuration files each boot. so if your doing general use tasks you can just use the integrated gpu and if you want to do some gaming you would run optimus-manager --switch nvidia which would write new configuration files, log you out of your current session and start a new session running on the nvidia gpu(that while enabled would work similar to the way PRIME works). to go back to intel you would need to run optimus-manager --switch intel log out of session and back in again. this option like bumblebee works well for conserving power when on the intel gpu and keeps the nvidia powered off unless you switch to it. this also provides performance advantage over bumblebee since it works like prime when the nvidia gpu is used to run the session. i dont have much experience with optimus-manager, i briefly tried setting it up but didnt get it working properly and in all fairness i didnt really try to hard to make it work so its more of a "me" issue rather than an "optimus-manager" one.

another option (easiest one) if your fortunate enough to have the option available in bios to disable the intel gpu(i dont have that option) you can then just install using video-nvidia and not have any of the optimus related issues since your machine will behave like a single gpu system.

there are some good tutorials i know of for prime and optimus-manager.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by