Manjaro boots from USB, shuts down right after on HP Spectre x360

I have manjaro installed to a USB drive, and I can boot into the loader and select manjaro to boot. It opens a command line and runs a series of startup stuff, but then runs the following:
umount: can't unmount /dev/loop3: Invalid argument
umount: can't unmount /dev/loop2: Invalid argument
umount: can't unmount /dev/loop1: Invalid argument
umount: can't unmount /dev/loop0: Invalid argument
umount: can't unmount /oldrun/miso/cowspace: Invalid argument
[ 55.066465] reboot: Power down

and then immediately shuts the laptop down. I've used two different USB drives, I've tried the gnome and KDE iso's, I've burnt in ISO and DD mode in rufus, as well as using belenaEtcher and also just using dd on my friend's manjaro install. I've set drivers to free and nonfree, and I still have no idea why this is happening. I can't seem to find anything about this online anywhere, so any help at all would be appreciated. Thanks in advance

HP is "sometimes" not linux friendly.
Maybe read here


welcome-01-sgs :slight_smile:


Thanks for the welcome! That HP Envy thread seems to be mostly about getting compatibility with Ryzen, but I'll keep giving it a read and seeing if I can come up with a solution. Thanks!

Post from live ISO

$ inxi -Fxxxza --no-host

too, please and read

1 Like

Hi wadamboat,
Did you find a solution at the end? I am facing the same issue with an Asus laptop.

while booting the usb it all of a sudden shuts down right?

this only happens when you try to boot with the free drivers, yes?

the nonfree drivers either freeze or load to a black screen?

I am very neewby to Linux so i don't know exactly what you are talking about, sorry...
Though i can tell you thatyes, it shuts down and it gives me exactly the same error message of wadamboat (i have an Asus laptop) even when trying to boot it with "nomodeset" rather than "quiet".

ok well without knowing exactly what hardware your using there is no way of helping you. and you should create your own thread since your hardware is ASUS and the this thread is in regards to HP hardware.

in the new thread you create, include the exact model of laptop your using, and answer these as well.

explain the steps taken and when exactly does the system power down? during boot? after your on a desktop?

when you boot the manjaro usb a grub screen comes up where you can select free(open source) or nonfree (proprietary) drivers. have you tried booting with both of them?

the question is self explanatory.

i think i know the problem your having but i would prefer not to guess. **again, dont reply here, create a new thread of your own **.

My bad, thanks for making me notice all of this.
I have created the new topic with the suggested information, here is the link if you want to check it / help.

Thank you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by