Manjaro boots into console instead of KDE

Hi, sorry again for the delay in replying. I installed the 5.3 kernel. I tried the mhwd tool. I get the following, when running mhwd -l -d:

--------------------------------------------------------------------------------
> PCI Device: /devices/pci0000:00/0000:00:03.1/0000:1d:00.0 (0300:1002:673e)
  Display controller ATI Technologies Inc Barts LE [Radeon HD 6790]
--------------------------------------------------------------------------------
  > INSTALLED:

   NAME:        video-ati
   ATTACHED:    PCI
   VERSION:     2017.03.24
   INFO:        X.org ati video driver. Standard open source driver for AMD graphic cards.
   PRIORITY:    2
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   video-catalyst video-hybrid-intel-radeon-prime video-hybrid-radeon-amdgpu-prime video-hybrid-intel-ati-bumblebee 
   CLASSIDS:    0300 0380 
   VENDORIDS:   1002 



  > AVAILABLE:

   NAME:        video-catalyst
   ATTACHED:    PCI
   VERSION:     2017.03.12
   INFO:        Closed source catalyst drivers for linux.
   PRIORITY:    5
   FREEDRIVER:  false
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 
   VENDORIDS:   1002 

   NAME:        video-linux
   ATTACHED:    PCI
   VERSION:     2018.05.04
   INFO:        Standard open source drivers.
   PRIORITY:    2
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 0380 0302 
   VENDORIDS:   1002 8086 10de 

   NAME:        video-vesa
   ATTACHED:    PCI
   VERSION:     2017.03.12
   INFO:        X.org vesa video driver.
   PRIORITY:    0
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 
   VENDORIDS:   * 


--------------------------------------------------------------------------------
> PCI Device: /devices/pci0000:00/0000:00:01.3/0000:03:00.2/0000:16:01.0/0000:18:00.0 (0200:10ec:8168)
  Network controller Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
--------------------------------------------------------------------------------
  > AVAILABLE:

   NAME:        network-r8168
   ATTACHED:    PCI
   VERSION:     2016.04.20
   INFO:        RealTek RTL-8168 Gigabit Ethernet driver
   PRIORITY:    0
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0200 
   VENDORIDS:   1186 10ec 

When running inxi -G, I get this:

Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Barts LE [Radeon HD 6790] driver: radeon v: kernel 
           Display: x11 server: X.Org 1.17.4 driver: fbdev FAILED: modesetting unloaded: vesa resolution: 1920x1080~N/A 
           OpenGL: renderer: N/A v: N/A 

Somehow this seems to contradict, doesn't it? mhwd says that the open source driver is installed (I assume it's amdgpu, but probably I'm wrong), inxi says that fbdev is installed. I'm not sure what to do from here. I consulted the mhwd page and wanted to remove the video-catalyst driver, as this seems to be the only non-free driver. But mhwd replies:

Error: config 'video-catalyst' is not installed!

Thanks for your input so far. I will now try remnoving the splash parameter and tell in a moment what's happened after that.

Removing splash didn't do anything except list the things that were done before showing the login prompt (terminal). Since that passed so quickly that I couldn't grasp anything from the screen, I guess there was no error.

How would I solve the problem (I do not know how this situation came to life, but I'm pretty sure it doesn't need to be that way), i.e. get the newer driver and an up-to-date xorg server?

Normal version of xorg-server is at 1.20.
Yours is at 1.17. It's because you installed catalyst xorg server, which has serious problems, but some users prefer to solve those problems, for their own reasons.

When/while you have decided to do that, you broke your system.

Now you have to install the normal xorg-server.

I don't know a one-line command for this, but I may tell you how you do it.
In terminal TTY

  • Try to install xorg-server with
sudo pacman -Syu "xorg-server>=1.20"

If asked to replace other packages answer yes.

I would search the forum for other similar issues (about catalyst-server), to get an idea what maybe needed.

I did that, but now I can't get to KDE at all. startx or systemctl start sddm produce only a screen with a blinking cursor in the top left corner.
I had to remove before that the catalyst-server with pacman -Rdd.
Edit: startxdoesn't produce that screen, but some error message:

Nö screens found (EE) 

In the X server log I find the message

Failed to load Module "vesa" (Module does not exist, 0)

So you have xorg-server installed. Check

pacman -Qs xorg-
inxi -Gxxxz
mhwd -li

Re-install video drivers

sudo mhwd -i -f video-linux

Thanks a lot for not giving me up. :slight_smile: I did what you suggested. To install the divers, I had to remove a few conflicting libraries, then that worked fine. However, even now I get the same error from startxand systemctl start sddmproduces the blank screen with the blinking cursor.
Output of

is too long (I currently use my mobile), but I see xorg-server 1.20.5-4.1 in the list.

Indicates:

driver: radeon v: Kernel.... 
Display: server: X.org 1.20.5 driver: none alternate: vesa tty: 240x67 
No advanced graphics data found on this system. 

I installed video-linux, it's listed when I run mhwd - li (Version 2018.05.04)

Ok, I'm back in KDE. There seemed to be a problem with the /etc/X11/xorg.conf file. After replacing it with an older copy, it works. Thanks for your help. However, the initial problem still remains: I still boot into the console (tty) instead of the GUI.

1 Like

It's better to delete this file (backup for reference )

Then let's start a new round of providing logs. But better use a pastebin service.
Either follow this:


Or instal pastebinit and pipe all outup into it like this

cat /var/log/Xorg.0.log | pastebinit
cat journalctl -p 3 -xb | pastebinit

Ok, here is the output of cat /var/log/Xorg.0.log | pastebinit:
https://pastebin.com/VCUyUf40

This command didn't give any output, only error message about a wrong option.

should be
journalctl -p 3 -xb | pastebinit

Your Xorg log looks just fine. I don't know how you can get a black screen or a dysfunctional SDDM screen.

As far as I'm concerned I'm not very keen on finding the root cause for a system which a user might have modified in many ways. Install a new system and see if the problem occurs there, too.

Do

sudo pacman -Syu sddm
sudo systemctl enable sddm

Reboot.


Note: you could start sddm before reboot, if you want

systemctl start sddm

Explanation:

It's essential to note down what is removed in such cases (troubleshooting, etc.).:wink:

Sorry for taking so long to reply. i'm getting used to logging in the uncomfortable way, though I don't really like it. But every time I turn on the computer, there are other, more pressing issues I need to take care of. Hence no reply. Now:
@AgentS: I run systemctl start sddm
every time I start the computer, i.e. when it "lands" on the console screen. It starts then just fine. Having it enabled doesn't make any difference, though.
@eugen-b: I installed Manjaro in order to not to reinstall the system now and then. It takes me a day to set up the desktop again the way I have it set up now (particularly printer settings and network connections, install the software I use and is not automatically installed, and other things), and I am not at all eager to go through that again. So I hope someone else is willing to help.

Thanks!

You haven't provided the requested journalctl output.

Sorry. Here it is: https://pastebin.com/dFA7x2zB

Any takers? I would really like to solve this problem. If any info is missing, please let me know.

Finally,

yesterday I found the solutions. It's quite simple. Manjaro was set to boot into multi-user modus (I don't know how this happened, but it happened). With the command

# systemctl set-default graphical.target

the issue was solved. Thanks to all who tried to help.

Here is a more detailed discussion about the issue: https://bbs.archlinux.org/viewtopic.php?id=213460

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by