Manjaro boots to black screen.

Hey community,

I'm new to Linux and have been using Manjaro for the past three days. It was going fine until I booted up to a black screen and a cursor. I don't have access to the command line, but I do have access to grub. I've referred to this troubleshooting post, (Manjaro doesn't boot, boots to a black screen, or stops at a message) but no dice.

I have Windows 10 and Ubuntu on my PC, but I've gotten accustomed to Manjara for the time I've had the distro, should I just reinstall it? What can I do to ensure this problem doesn't happen again? The machine I'm on is an XPS 12 9365.



Welcome to the forum.

This means what? you weren't able to reach the TTY? pacman -Syyu did not install anything? How about the chroot? You have to tell us what you did and what didn't work with which outputs.

More details would also help:

1 Like

Happy to be here! Thanks for your patience.

I was able to open up TTY and it gave me the error messages below saying that it failed to synchronize all databases.


I also ran startx, the cut-off portion says 'Internal error: Could not resolve keysym XF86FullScreen'.


I'm on mobile, so if the pictures come out weird I will repost.

Looks like update gone wrong and to be exact, as if you forced stop during update or as if system crashed during update.

Usually when I run into database, mirrors, keys troubles (those are different kind of issues but like to come in pairs) I use this (not always in the order provided below, depends on the issue and situation):

  1. delete pacman db:

sudo rm -r /var/lib/pacman/sync/core.db

  1. restore pacman db:
sudo pacman -Syy
  1. If the issue is with the keys, do this:
sudo rm -r /etc/pacman.d/gnupg
sudo pacman -Sy gnupg archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
sudo pacman -Sc
sudo pacman -Syu
  1. If mirros are a problem, at this moment it's good to try:

sudo pacman-mirrors --fasttrack

All of those should clean and restore correct files as databases, mirrors, keys.

And finally:

sudo pacman -Syyu

I was able to remove the directory for step one, but doing step two resulted in the same error as the first picture.

Do step 3 and 4 then.

EDIT: Check first if you have an Internet connection:


If it shows line like:

64 bytes from ( icmp_seq=1 ttl=55 time=57.1 ms

then it's all good and you can stop the ping with ctrl+c

First, welcome to the forums! Hopefully we can help you get this fixed.

In TTY I get that scrolling error failed retrieving file cascade when I'm not connected to the internet first.



first and then activate an internet connection then go back and you should then be able to update. Everything failed because it has no way of verifying databases if you can't communicate with them.

Can you give me the output of the following commands:

mhwd -li
inxi -G

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by