Manjaro-bspwm 20.0.1 Lysia Released

Manjaro-bspwm 20.0.1

Happy to announce Manjaro-bspwm 20.0.1 is now available! This release presents an updated look while continuing the same ergonomic feel and suckless inspiration.

bspwmv20cleanscreen

DLOSDN
direct | sig | sha1 | sha256 | torrent

Manjaro-bspwm 20.0.1 updates include:

  • Transparency by default
  • Show/Hide Limepanel function
  • Updated RofiMenu with easy dot file access
  • New Pacman and Yay fzf search and install functions
    --Must update pacman file database once before getting full functionality
    ( sudo pacman -Fy && yay -Fy)
  • Replaced Etcher with Popsicle.
    --Very simple cli & gui image flashing utility that also does hash checks!

bspwmv20dirtyscreen

Bonus: The default terminal emulator sterminal has a newly discovered right-click menu!

sterm-menu

:white_check_mark: Don't forget to check the keybindings help file (Super + F1) for new commands!

This is the Full iso built against Stable branch on kernel 5.6. Both Full and Minimal versions, with any choice in branch and/or kernel, are install-able via manjaro-architect.

21 Likes

Now I am trying to migrate to this desktop.

I just installed it.

I try. It is my first time with bspwm.
Now I want to configure it to my workflow.

Thanks for the work done for this flavor.

1 Like

Hi thanks for the release. I have been using bspwm for awhile now and its great, though im not yet a suckless user so i prefer gtk for some stuff. anyways i see some few issues:

  • picom can fail to load due to duplicate "vsync =" entries
  • typo in bspwm-ruler, item 5
  • bar has to big of a font (but that just might be me)

ill all more if i find some.

UPDATE:
ive just read this. Maintainer wanted
is this still the case for this edition? not that i am offering..

Sorry for the delay in response, this post totally slipped by me.

I have picked up maintenance on this edition. Thanks for reporting your findings. I believe the duplicate 'vsync' entries may be from a check for intel graphics. After fixing picom.conf has the duplicate line reappeared?

yes, because i have an intel gpu, an additional check has added vsync=true at the end of picom.conf instead of replacing the already existing label before it.

I looked into this on this release but, have no intel graphics for testing and had noticed no complaints. So I left it as is. Did you find a solution? Is it still adding the line? If you're willing to test, the block of code is found both at the very end of ~/.config/bspwm/bspwmrc and starting line 11 of ~/.config/bspwm/autostart and looks like:

# Alter picom settings if using intel graphics
GRAPHIC_CARD=$(lspci | grep -i "vga" | sed 's/.*://' | sed 's/(.*//' | sed 's/^[ \t]*//')
if [[ $(echo $GRAPHIC_CARD | grep -i 'intel\|lenovo') != "" ]]; then MCODE='initrd=\intel-ucode.img'
  sed -i 's/"xrender"/"glx"/' ~/.config/picom.conf
  grep -q 'vsync = true;' ~/.config/picom.conf || echo 'vsync = true;' >> ~/.config/picom.conf
fi

You can try to comment one or the either out and see if it stops adding the line? I would start with the one at the end of bspwmrc personally. Also do you mind posting your picom.conf?

im already on a different config that the stock, but i believe this is the cause of the double vsync=
label

grep -q 'vsync = true;' ~/.config/picom.conf || echo 'vsync = true;' >> ~/.config/picom.conf

or at least the "echo 'vsync = true;' >> ~/.config/picom.conf". Since there is already an existing label for "vsync = false" at line #51, then this command should use "sed" instead of echo, replacing the existing label "vsyng = false" to "vsync = true" instead of adding a new label.

something like this probably (im no shell script expert but this does the job):

grep 'vsync = true' ~/.config/picom.conf || sed -i 's/vsync = false/vsync = true/g' ~/.config/picom.conf

thanks.

just to reclarify: by default, the stock config has vsync = false and backend = xrender. When an Intel gpu is used and the appropriate drivers are loaded, the config should change backend = to "backend = glx" (which it does) and change "vsync = false" to "vsync = true", which it does not. instead it adds a new label using the echo command causing double lebels causing picom to fail to load.

1 Like

Ah, I see. Thank you for the tips! I will address this for the next iso update.

I moved previous week to Manjaro BSPWM. It's the best OS I ever used! I love the speed, the looks and how smart are the default keybindings. Although I'm new to tiling window managers and I was hestitant to shift from openbox , I got used to it in less than 3 days.

I still need to setup some minor things like switching languages but everything else works perfect.

I hope that Manjaro bspwm will be maintained in the long run because it's exactly what I was looking for to run on my desktop PC.

Congrats and many thanks to the hard work the Manjaro developers put to maintain this gem!

2 Likes

Forum kindly sponsored by