Manjaro Can't connect to home internet


I have been trying to access the internet on my laptop for a bit now, but can only connect to my phone's hotspot internet. The Wifi and Ethernet do not work when connected to my home internet. It just keeps asking for the wifi password.
Here is my inxi -Fx

  Host: manjaros Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.1.0 Desktop: Xfce 4.14.2 Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 81QG 
  v: Lenovo IdeaPad S340-15APITouch serial: <root required> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40700 WIN serial: <root required> 
  UEFI: LENOVO v: AMCN22WW(V1.06) date: 05/10/2019 
  ID-1: BAT1 charge: 48.9 Wh condition: 48.9/52.5 Wh (93%) 
  model: LENOVO PABAS0241231 status: Full 
  Topology: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen+ rev: 1 L2 cache: 2048 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 33550 
  Speed: 1224 MHz min/max: 1400/2100 MHz Core speeds (MHz): 1: 1253 2: 1232 
  3: 1262 4: 1277 5: 1243 6: 1361 7: 1225 8: 1226 
  Device-1: AMD Picasso vendor: Lenovo driver: amdgpu v: kernel 
  bus ID: 04:00.0 
  Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati unloaded: modesetting 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD RAVEN (DRM 3.36.0 5.6.16-1-MANJARO LLVM 10.0.0) 
  v: 4.6 Mesa 20.0.7 direct render: Yes 
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 04:00.1 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Lenovo driver: N/A bus ID: 04:00.5 
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 04:00.6 
  Sound Server: ALSA v: k5.6.16-1-MANJARO 
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Lenovo driver: ath10k_pci v: kernel bus ID: 02:00.0 
  IF: wlan0 state: up mac: e8:d0:fc:d6:cc:4f 
  Device-2: ASIX AX88179 Gigabit Ethernet type: USB driver: ax88179_178a 
  bus ID: 2-1:2 
  IF: eth0 state: down mac: 00:90:9e:9d:c8:7b 
  Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 3-2:3 
  Local Storage: total: 238.47 GiB used: 20.01 GiB (8.4%) 
  ID-1: /dev/nvme0n1 vendor: Lenovo O.E.M. model: RPFTJ256PDD2MWX 
  size: 238.47 GiB 
  ID-1: / size: 47.81 GiB used: 19.98 GiB (41.8%) fs: ext4 
  dev: /dev/nvme0n1p5 
  System Temperatures: cpu: 65.4 C mobo: N/A gpu: amdgpu temp: 65 C 
  Fan Speeds (RPM): N/A 
  Processes: 237 Uptime: 31m Memory: 5.81 GiB used: 1.05 GiB (18.1%) 
  Init: systemd Compilers: gcc: 10.1.0 Shell: bash v: 5.0.17 inxi: 3.0.37

You did verify your passwords, I'm certain. You probably also rebooted your modem and laptop. I'd guess you also checked your BIOS.

By the sounds of the problem, I'd say your issue is with the modem. Since manjaro seems to connect with your phone hotspot (device) which I assume is different from from the modem (which sounds like it has a generalized problem since your issues are wired and wireless).

Do other devices connect to your modem????

Edit: If you do not have other devices try using a LiveUSB on this laptop and see if it will connect that way either wired or wireless.

Yes, other devices can connect to the router via ethernet and Wifi. I believe it has something to do with the DHCP as my phone internet is a static connection while my home wifi is strictly DHCP.

Does the same failure occur running manjaro from a LiveUSB?

Consider disabling MAC address randomization in Network Manager with the following command:

echo -e "[device]\nwifi.scan-rand-mac-address=no" | sudo tee /etc/NetworkManager/conf.d/disable-random-mac.conf

Reboot (or restart NM) after creating, modifying, or removing any Network Manager configuration file.

I'm not sure, I would check it but I'm limited on internet data. It worked when I first installed Manjaro about 2 months ago on the same current version.

Did not work, I also have Connman installed.

Well then no, that fix won't work on Connman. The fix is intended to be used only on Network Manager. As Network Manager is the default on most Manjaro spins I was assuming that was what you were using.

If you have modified the default network setup you should really post all relevant information when you request help on your OP.

What network modifications have you made?

Have you installed the changed your DE, or installed multiple DE's?

Have you tested other kernels?

Have you performed ping tests via domain names and IP addresses?

Have you searched for fixes with the Qca9377 adapter?
There are tons of posts about this adapter as it has tons of issues.

Do you not keep backups? Otherwise you could roll your system back to before the internet breakage.

Which specific update caused the breakage? Do you know the specific date or packages involved?

If you actually expect others to help you fix this you need to start providing way more information than you have to this point. We are not mind readers, you need to tell us the specifics if you expect assistance.

I know there is kernel issues with Atheros network devices.

I had a fluke with my TP-LINK WN722N using the AR9271 chipset. The device driver would not load. After reading this topic I checked if any recent update has solved it.

As of kernel 5..7.7-1 on unstable branch my device is again functional.

Issues at

I was using Network Manager for the command, I just wanted to add the information that I have connman if you want to use that as I know you created a guide for Connman, but that did not work for me.
I have not changed DE
I have not tested other kernels
Ping tests do not work as I cannot even connect to the wifi network.
I have not searched with the adapter but I will now.
I do not keep backups as this laptop is not really a main concern, now if I was using this on my actual desktop, I would keep backups.
No updates have been ministered on this laptop since I first downloaded the original version.

I downgraded my firmware to a 2018 release for my specific adapter, but now I’m stuck on the OEM window for my laptop when booting.

I generally don't give this advice very often, but considering the changes you have made I'd consider doing a reinstall.

If you have an external backup drive in ext4 format I would install timeshift and create a backup after you reinstall. If you don't have an external drive you can still backup your system using timeshift to your internal drive. While possible, this is not really a reliable method of doing backups. It will at least help till you get your network running properly by allowing you to roll back changes that did not work to the original state.

One of the first things I would do after reinstallation is test other kernels. Manjaro is capable of running multiple kernels and you should always keep at least 2 kernels installed at all times. I would start by testing kernel 5.7.

OK, I did a little research on your USB to Ethernet issue. Have you attempted to install and test this driver before:

Let's make a fresh start, then try fixing things up for you. Reinstall Manjaro, then create a system backup using timeshift so things hopefully won't get messed up again.

Install the asix-ax88179-dkms driver:

Let's start by installing this driver from the AUR to hopefully get your USB to Ethernet adapter working.

To install the driver properly follow the instructions below:

Before proceeding, make sure your Manjaro installation is fully up to date with this command:

sudo pacman-mirrors -f 5 && sudo pacman -Syyu

If updating was required, then reboot after the updates are completed.

If you don’t already have pamac-cli installed, then install it before proceeding any further:

sudo pacman -S pamac-cli --needed

The linux-headers must also be installed for any DKMS driver version to function prperly. You must install the required linuxXXX-headers package before installing any DKMS driver. You can use the command below to install the headers for all currently installed kernels.

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ') 

Before installing the driver we are going to install the required dependencies. This step is not normally required, but some DKMS driver versions may not install if the dependencies are not installed first.

Install the required dependencies with:

pamac install dkms git base-devel

Once those package installations are complete, reboot.

Then install the driver from the AUR with:

pamac build asix-ax88179-dkms

Then reboot once more.

Hopefully that helps, (and at least your Ethernet becomes operational).

My Ethernet works fine when I connect it to my raspberry pi with a static IP. Once again, I am thinking that it is a DHCP issue and something on my system is conflicting with it. I have Manjaro on a boot usb, is there anyway to recover my old Manjaro via this usb? I will also try your other solutions once I am booted into Manjaro.

Currently following this guide: How to save your Manjaro installation when it breaks

Your inxi output from your system lists your USB Ethernet adapter as being "down". That means your USB apapter is not initialized (and has nothing to do with dhcp). Whether the adapter works on your Pi is irrelevant. If you were not concerned with getting this adapter working on Manjaro, then why did you include it in your inxi output?

I would suggest you search the forum on how to install an alternate dhcp server if you feel that is part of your problem.

Unfortunately, I will have to take my leave of assisting on this thread as I simply find it too frustrating to help users that are all over the map when it comes to following instructions and providing proper feedback.

Good luck getting your system working.

I don’t think you get what I was saying. I was saying that I used the usb Type-C to Ethernet to tether a Ethernet cable from my pi to my laptop on Manjaro. The Ethernet is not my issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by