Manjaro can't see M2 nvme drives

Hi, new to Manjaro, and about 10 years since I last used any Linux seriously, so please be kind :slight_smile:
I have an Acer Nitro 5 laptop, Intel i7 & dual Intel/nVidia graphics. The system comes with a single 500Gb M2 nvme drive, which contains Windows 10. I have added a second M2 nvme and also a SATA internal drive. Manjaro is on the SATA SSD.
Manjaro cannot see either of the m2 cards, they simply do not exist. KDE Partition Manager does not see the drives. Ideally, I'd like the second M2 to be a data drive visible to both OS's.
I've done some searching that indicated that M2 support was working in the 4 series kernels, but broken in some 5 series kernels. Although I have seen posts saying it's fixed now, I am running the 5.6.7-1 kernel and still can't see them. Any help would be greatly appreciated. Thanks in advance.

Welcome to the forum.

What I would do is try it on the version 4.19 of the kernel. If that works, then you'll probably just have to use 4.19 or wait until it gets fixed in the version 5 of the kernel.

Also, I would try it with GParted Partition Editor. There are rumours (the veracity of which I cannot confirm) that KDE Partition Manager is inferior to GParted.

Thanks for your prompt response. Unfortunately 4.19 kernel cannot see the nvme drives either, and also does not recognize my WiFi device! System Info does not show the devices, so I don't think it matters which partition editor I use. BTW Windows 10 sees it and accesses it fine.

Further: In grub, ls -l shows all 3 drives. I've also tried the 5.7.rc2 kernel with no success. :frowning:

Try setting disk device mode to AHCI in your systems firmware.

I agree, and make sure secure boot is disabled. Then go back into your live environment and see if it sees the two M.2's before going back in to your installed system.

Thanks all. I had to disable secure boot to install Manjaro, and, on the advice of Acer gurus, also disabled Fast Boot.
The BIOS shows the SATA mode as "RST Premium with Optane" but I can see no way to change that. No firmware setting has a "AHCI" option :frowning: I'll query the Acer forums.
The live system still sees only the Samsung SSD and the USB media. The installed system still does not see M2 drives.

Acer forums say the AHCI switch is hidden, need to press ctrl-s to show it! and changing it is likely to kill my Win 10 install. So that is not an option until I can travel home (after the COVID-19 lockdown is lifted). Looks like this is as far as I'm getting for now. Thanks all for your help. It is much appreciated.

:warning: Disclaimer: If you choose to implement the solution in the following link, proceed at your own risk!

Sorry to hear Acer screwed up. AHCI should of been on by default and the manufacturer knows it. At least you now know at least part of the reason.

Your decision to wait is probably wise :slight_smile:

Intel Optane is unsupported using Linux - IMO it should not affect your Windows installation because it is solely used as as cache - at least to my knowledge - often limited due to my missing contact with the Windows world - not that it is dark in Linux - you know the light metaphor :slight_smile:

I appreciate the new knowledge that some firmware's hide the AHCI option - in this case a hidden keyboard combo to make it visible.

One keeps wondering and thinking - those vendors - they really think - they are convinced they are doing the owner a favor - let's turn it around - if Linux did the same thing - the srceaming would be so loud - cripple fingers - take away our choices - and what not.

1 Like

OK, so after ensuring my backups were up to date, I hit the magic switch, and, lo and behold, my nvme drives appeared in Linux. However, as the Acer gurus predicted, no Windows boot. Restoring the SATA setting to its default, and Windows returned. I hope that if I create a Windows Recovery disk (my laptop has no CD burner, so I can't do it immediately) I can switch to AHCI and then restore the Windows boot. That will get me to my desired result :slight_smile: Again, thanks all for your assistance.

Some has succeeded without reinstalling

Thank you!

Personally I'd wipe it completely after downloading a fresh copy of Windows and whatever apps you have for Windows and do a fresh install of Windows and Manjaro after turning ACHI back on. To be honest ACHI should of never been off and your manufacture knows it.

The link posted by linux-aarhus worked. :slight_smile: I can now see all my drives under Manjaro. I did not need to reinstall Windows, which would have been a pain given the number of apps requiring registration and the large downloads some require - I'm out in remote central Queensland Australia using satellite internet which is slow and expensive.

All working as desired. Once again, thanks all. :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by