Manjaro crashes after Hibernation

Hello to everyone,
If my notebook was idle (manually or automatically) then Manjaro crashes. I can no longer move windows or exit programs.
I've had this problem since I installed it and haven't found anything in the forum that could cause it?

  Host: macbookpro Kernel: 4.19.14-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN Distro: Manjaro Linux 
  Type: Laptop System: Apple product: MacBookPro6,2 v: 1.0 serial: <filter> 
  Mobo: Apple model: Mac-F22586C8 v: MacBookPro6,2 serial: <filter> 
  UEFI: Apple v: MBP61.88Z.005D.B00.1804100943 date: 04/10/18 
  ID-1: BAT0 charge: 52.7 Wh condition: 69.8/75.2 Wh (93%) 
  model: SMP bq20z451 status: Discharging 
  Topology: Dual Core model: Intel Core i5 M 520 bits: 64 type: MT MCP 
  arch: Nehalem rev: 5 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19158 
  Speed: 1253 MHz min/max: 1197/2395 MHz Core speeds (MHz): 1: 1463 2: 1463 
  3: 1463 4: 1463 
  Device-1: Intel Core Processor Integrated Graphics driver: i915 v: kernel 
  bus ID: 00:02.0 
  Device-2: NVIDIA GT216M [GeForce GT 330M] vendor: Apple driver: nouveau 
  v: kernel bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.3 driver: intel,nouveau 
  unloaded: modesetting resolution: 1440x900~60Hz 
  OpenGL: renderer: NVA5 v: 3.3 Mesa 18.3.1 direct render: Yes 
  Device-1: Intel 5 Series/3400 Series High Definition Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: NVIDIA GT216 HDMI Audio driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 
  Sound Server: ALSA v: k4.19.14-1-MANJARO 
  Device-1: Broadcom and subsidiaries NetXtreme BCM5764M Gigabit Ethernet 
  driver: tg3 v: 3.137 port: 2000 bus ID: 02:00.0 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Broadcom and subsidiaries BCM43224 802.11a/b/g/n 
  vendor: Apple AirPort Extreme driver: wl v: kernel port: 2000 
  bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
  Local Storage: total: 298.09 GiB used: 9.42 GiB (3.2%) 
  ID-1: /dev/sda vendor: Hitachi model: HTS545032B9SA02 size: 298.09 GiB 
  ID-1: / size: 145.55 GiB used: 9.40 GiB (6.5%) fs: ext4 dev: /dev/sda3 
  System Temperatures: cpu: 65.0 C mobo: N/A gpu: nouveau temp: 69 C 
  Fan Speeds (RPM): N/A 
  Processes: 182 Uptime: 37m Memory: 3.72 GiB used: 1.33 GiB (35.9%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 inxi: 3.0.28
`type or paste code here`

I would try disabling both network adapters before hibernation. Your ethernet looks just messed, and you have a very problematic wifi adapter as well.

Run the set of commands below before suspending.

Please do not cut and paste all the commands together at once.

Enter and run each command separately with a few seconds between each command.

Please post all inputs, and all outputs of that sequence of commands.

Please do not give me a summary, such as "there were no outputs".

It is very important that you post each input and output for troubleshooting purposes.

nmcli networking off

sudo systemctl stop NetworkManager

sudo ip link set enp2s0 down

sudo ip link set wlp3s0 down

sudo modprobe -r tg3

sudo modprobe -r wl

After running those commands put your computer to sleep. Wait 20 seconds then attempt to resume. If your resume is successful you now know that your network components are causing the problem. If that is the case it can usually be corrected by writing a service.

Information on how to properly post hardware specs and logs:

Please format any terminal output with three backticks before and after, as shown in this picture:


(I formatted my first post afterwards, thanks for the info)

I entered the commands you gave me but I had no other message at the terminal?
Which output messages did you mean?

I put the computer into sleep mode and could start it again!

I didn't mention anything else important: The hibernate button has no function in the logout window!

Well good news then, as I suspected you network components were causing the problem. I will work on some services for you.


Systemd Network Disable/Enable Services

Disable Network Service

With a text editor create:


Service file suspend unit contents:

#sudo systemctl enable network-suspend.service
#sudo systemctl start network-suspend.service
#sudo systemctl status network-suspend.service
#sudo systemctl daemon-reload
Description=Network suspend service

ExecStart=/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli networking off'
ExecStart=/usr/bin/sleep 1
ExecStart=/usr/bin/systemctl stop NetworkManager
ExecStart=/usr/bin/sleep 1
ExecStart=/usr/bin/ip link set wlp3s0 down
ExecStart=/usr/bin/ip link set enp2s0 down
ExecStart=/usr/bin/modprobe -r wl
ExecStart=/usr/bin/modprobe -r tg3


Then in the terminal, enable the service:

sudo systemctl enable network-suspend.service

Enable Network Service

With a text editor create:


Service file resume unit contents:

#sudo systemctl enable network-resume.service
#sudo systemctl start network-resume.service
#sudo systemctl status network-resume.service
#sudo systemctl daemon-reload
Description=Network resume service

ExecStartPre=/usr/bin/sleep 5
ExecStart=/usr/bin/modprobe tg3
ExecStart=/usr/bin/modprobe wl
ExecStart=/usr/bin/sleep 2
ExecStart=/usr/bin/ip link set enp2s0 up
ExecStart=/usr/bin/ip link set wlp3s0 up
ExecStart=/usr/bin/systemctl start NetworkManager
ExecStart=/usr/bin/sleep 2
ExecStart=/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli networking on'
ExecStart=/usr/bin/sleep 2
ExecStart=/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli r wifi off'
ExecStart=/usr/bin/sleep 2
ExecStart=/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli r wifi on'


Then in the terminal, enable the service:

sudo systemctl enable network-resume.service

Then reboot and test the services on a sleep cycle.


Vow, thank you so much for writing me the services. And the quick help. This is really a great forum!

1 Like

You really should find out if they work, before you thank me. :smile:

I've wriitten a lot of services, so I think they should work for you though.

You are welcome, and I hope they work.


Please post back here and let us know if this worked for you. I take a lot of interest in wether a service is working, or not. So please be sure to give us a confirmation on the service files effectiveness.

If the services are not working for you, please post:

systemctl status network-resume.service
systemctl status network-suspend.service
1 Like

Excuse me, I won't be able to try the service for another few days. I'll write here again what the result was like!

1 Like

It's me again. I have now come to the following result: The code you gave has already solved the problem!

nmcli networking off
sudo systemctl stop NetworkManager
sudo ip link set enp2s0 down
sudo ip link set wlp3s0 down
sudo modprobe -r tg3
sudo modprobe -r wl

then of course I had to enter this(that my internet is running again):

sudo systemctl start NetworkManager
nmcli networking on

And there haven't been any problems since.
I don't think I need the service anymore?

That's good that the code I gave you fixed your problem. I'm not sure if you've rebooted yet, after rebooting you may find the issue returns. If that happens simply create the services I wrote.

If you're happy with the way things are now, then I guess you can mark your thread solved

It must be a mistake, Don't know why my reply is marked "Solved", of course you solved the problem! No question at all

You can simply switch the solution check mark by tapping the three dots below any post.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by