Manjaro Deepin not present in boot loader after dual boot

So I installed Manjaro along side Win 10. Now I made partitions for swap, root, home and a boot and selected boot loader to be installed in this /boot. After reboot, grub doesn't come up and neither does it show up in boot loader menu.
I've tried not creating /boot and installing bootloader in dev/sda (default) but it has same problems.
I also tried creating a /boot/efi partition but that didn't work.
Any ideas?

Q1. Is your windows uefi or bios-legacy?
Q2. Is your disk gpt or msdos?


Legacy option is enabled though. I've installed many distros before this the same way and only this time I am experiencing this problem

If your windows is uefi/gpt, and you want to keep it when you dual-boot, you should install any Linux OS in uefi/gpt.

If you have not installed Manjaro in uefi/gpt, suggest (easier) you reinstall in uefi.
Make sure you select the $esp as mount point /boot/efi and do not format $esp.

If you are sure you had installed Manjaro in uefi and also selected the $esp as /boot/efi and grub is missing, check out this topic..

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by