Manjaro Deepin Stable 18.0.1 to 18.0.4 Illyria Bugs

I recently downloaded Manjaro Deepin Stable 18.0.2 ISO, made sure that the SHA1 provided on the download page is the same as the one generated from the ISO. I used Rufus on Windows to generate the SHA1 hash and the hashes were the same. After writing the ISO to USB by using Rufus with DD mode because the Isohybrid mode causes it to start grub rescue. After booting the Manjaro live system on UEFI mode with non-free drivers and starting the Manjaro installer, it states that I am installing Manjaro 18.0.1 instead of 18.0.2 which is part of the name of the downloaded ISO file. When reaching the Partitioning page, only Manual Partitioning option is available. The Erase disk, replace a partition and install alongside options were not listed. I created the partitions and let the installation finish and restarted the PC. Below is a screenshot taken from a youtube recording of Manjaro Deepin 18.0.2 that illustrates the manual partitioning as the only partitioning option.


After the reboot ,the deepin desktop version is 15.8. When I set the Display Scaling to 1.25 since my laptop has a high dpi 15.6 inch screen with a screen resolution of 1920X1080, the mouse cursor becomes bigger but becomes small when using applications but on the desktop and on the taskbar in both efficient and fashion mode the cursor size is the same. When I undo the display scaling and after updating the system which updates the deepin desktop to version 15.10.1, the cursor size becomes smaller and when I try to shut down or reboot both graphically and on the deepin terminal, nothing happens but on the terminal it states Failed to talk to init daemon after typing sudo reboot or sudo shutdown. It can only shutdown and reboot if I add the -f to the commands stated to force reboot or shutdown without talking to init daemon. After forcing the shut down or reboot, the PC can shut down or reboot normally and sets the display scaling automatically to 1.25 for both the desktop environment, some applications and the login screen but the cursor is not scaled. But before forcing the shutdown/reboot, logging out and logging back in, the desktop lags extremely as it automatically sets the display scaling value to 1.25 to the desktop and the login screen too but the cursor also is not scaled. Below is a screenshot of my screen with a small mouse cursor after the software update, force reboot and automatic display scaling, and it also displays the EFI partition that I created using fat32 file system as recommended but as a USB device


NVIDIA X server settings wont open. I have read this forum about this issue but after reading the suggested link to configure the nvidia bumblebee. The page warns ' These instructions are outdated. Until they are reviewed for validity, please do not follow them blindly. Especially consider that there are also legacy nvidia drivers for older cards, like nvidia390xx and nvidia340xx. If you are not sure, please look for a tutorial or ask for assistance at the forum. Are there updated commands because according to the linked forum the commands don't work as expected.

This is the output of inxi -G:

Graphics:  Device-1: Intel HD Graphics 620 driver: i915 v: kernel 
           Device-2: NVIDIA GM108M [GeForce 930MX] driver: N/A 
           Display: x11 server: X.Org 1.20.5 driver: intel resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 19.0.6 

This is the output of mhwd -li

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI

Warning: No installed USB configs!

After logging off the PC at least 4 times, no audio produced until a reboot. After the system update the sounds sounds sometimes are not produced when they are supposed to sound and the login sound is no longer produced except when I wake up my PC after sleep, after the system update that also updates the deepin desktop environment. After waking the PC from sleep, it always asks for the Wi-Fi password of a Wi-Fi network that I previously connected especially if I let the PC sleep for over 30 minutes. In the live system, it refuses to connect to Wi-Fi even if the correct password has been typed and it says that it could not connect, wrong password. The live system can only connect to Wi-Fi if I press the WPS button on the Wi-Fi booster which I usually use to connect to Wi-Fi. Both the live system and the installed system cannot connect to the internet by using a Huawei E3531 USB modem. In other distros like Ubuntu and Fedora, it identifies the device as 'Wired connection 2' and I have to type the IPv4 address to connect to the internet using the device.

Try manjaro-deepin 18-1-0-pre1


While @oberon and Arch are doing what they can to eliminate Deepin bugs it seems to be a fight prolonging.

1 Like

I have read that they have fixed some bugs in the pre-release. Is it possible to upgrade the latest Manjaro Deepin Stable 18.0.4 to the pre-release or do I have to back up my data and clean install the preview release?

I hope that they are able to fix the bugs. I like Manjaro only with the Deepin desktop because Deepin Desktop is the only desktop environment that supports fractional dpi scaling for both the desktop and the login screen without tampering with some files like in KDE (can cause login issues after editing a SDDM file) to scale the login screen. I have tried Ubuntu 19.04 Gnome's experimental display scaling on their default session which is the X11 session but with NVIDIA graphics, it scales to 200% when choosing the 125% scaling and crops the screen such that the top left quarter of the screen is stretched full screen, but with Intel graphics it scales but the interface elements are almost too big with 125% scaling and there is more GPU usage.

If you want to switch to pre-release (testing), it works like this.
Open terminal and

sudo nano /etc/pacman-mirrors.conf


The line

Branch = stable


Branch = testing

to change.

Save with Ctrl + o
Exit with Ctrl + x

After that
sudo pacman-mirrors -f5 && sudo pacman -Syyu


I have tested the pre-release build, some bugs are fixed like the one which refuses to connect to Wi-Fi when the correct password is supplied, added the Install alongside and replace a partition but they are not working and Erase Disk partitioning is still not listed. Bugs not yet fixed are when setting the Display Scaling to 1.25 or higher, some icons in the control centre are aliased, in Deepin OS, there is no aliasing of the icons on the control centre. In the pre-release still cannot identity a Huawei USB modem as Wired connection 2 as identified by Manjaro KDE which I recently installed until the Manjaro Deepin bugs are solved, Fedora, Ubuntu, Deepin OS and others. could just run sudo pacman-mirrors -aB testing

I hope so too. While I'm a big KDE fan, Deepin is one of the few DE's that checks off all the boxes of things I want (Coverflow alt-tab with kwin, hot corners, perfectly functioning taskbar hiding), plus it's beautiful and simple. It's very Chrome OS-like. I've actually setup my parents and sister on it and they use it without a hiccup, while I imagine they'd accidentally break KDE or XFCE a few times per week.

I have installed and tested Arch Linux with Deepin Desktop Environment. Similar bugs with manjaro deepin is: sometimes no audio after I put the laptop to sleep a few times and a restart or log off can get the audio back and aliasing issues especially at the deepin control center icons after increasing the display scale to 1.25 or higher. I also installed Manjaro Architect with deepin desktop by using the automatic partitioning option and the UEFI partition is not shown as a USB device but the partition only shows when I create it using manual partitioning as it was the only partitioning option in the deepin desktop. In arch linux, when I use cfdisk to partition the hard drive, when I set the UEFI partition type to EFI system partition but not linux filesystem, the partition is not shown as a USB device but if its type is linux filesystem, the partition is displayed as a USB device.


does anyone have that Problem:
Connect to hidden wlan.
Afte Reboot no connection automatically to hidden wlan.
again ssid and password -> connected....

anyone knows how to workaround that problem?


So every time you reboot it's not remembering network info? This is on a full installation?


yes on a full installation.
only with hidden wifi.

on same hardware with xfce dektop it worked fine.
deepin cant remember the hidden wifi.

Ah, a hidden network.

I would try the first answer at this Kali Linux link to see if it helps you:


anyone else an idea?
is there a script that network manager starts first in my hidden wifi?

It seems that Manjaro has either removed the Manjaro Deepin download link from their community downloads webpage or some problem occurred that caused the link to be removed. The Manjaro Deepin ISO is still downloadable from osdn.

Just seen some of the issues you've described but I'm yet to encounter any actual issues on Deepin on Arch. Only a couple minor things I hadn't installed that caused me some grief like gvfs-mtp, file-roller, linux-headers (consistent freezing without it since deepin-anything has it as a dependency) and auto-connect pulse configuration for bluetooth. Otherwise been using it for several days now and its as stable as KDE. Not sure what caused the Wi-Fi connection problem on Manjaro. Hope Oberon can check it out again

thx for looking into the problems.
i moved to deepin linux, after my manjaro crashed at troubleshooting, and now i am happy with it.
everything works fine and really sooo quick and looking great without any configration. thats simplicity.

manjaro should make deepin to their official main supported desktop.
they would be the first one with the concept arch and deepin dde official. also would reach more users with it.
i would come back instantly.
Deepin DDE will go its way. Best Desktop Environment at the Moment.
Chinese did what others did not. copy best things together to form the best desktop...
others desktops stuck in their mood.
it just my opinion.

i will recommend manjaro first, also in the future;-)


Forum kindly sponsored by