Manjaro does not boot after installation

sudo pacman -S pastebinit
inxi -Fxxxz | pastebinit
sudo fdisk -l  | pastebinit

its missing flag on sda ( flag boot or bios legacy )
open gparted and add missing flag for boot


with the livecd you can launch firefox an go to your topic ( also need login/password for that ),

i dont see your manual partitions ?!

ok, thx, i am trying it right now

i trying add flags when partitioning manually. I added "boot" and "grub-bios" flags

I trying manual and auto partitions. The last was auto.

Why is /dev/sda2 a Linux swap / Solaris partition? and for the love of god clean your damn screen if you want to post pics :rofl:


Thanks for the afternoon chuckle. :smiley: :smiley: :smiley:


i put this commands (only sudo pacman -S pastebinit incorrent, i put sudo pacman -Sy pastebinit) and attach creenshot what happen

Disk /dev/loop0: 75.7 MiB, 79384576 bytes, 155048 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk /dev/loop1: 320.2 MiB, 335708160 bytes, 655680 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk /dev/loop2: 1 GiB, 1099018240 bytes, 2146520 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk /dev/loop3: 476.6 MiB, 499695616 bytes, 975968 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Disk model: WDC WD5000BPKT-2
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xdec96163
Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1            2048 961648396 961646349 458.6G 83 Linux
/dev/sda2       961648397 976768064  15119668   7.2G 82 Linux swap / Solaris
System:    Host: manjaro-mate Kernel: 4.19.32-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: MATE 1.22.0
           info: mate-panel wm: marco 1.22.0 dm: LightDM 1.28.0 Distro: Manjaro Linux
Machine:   Type: Laptop System: LENOVO product: 20189 v: Lenovo B575e serial: <filter> Chassis: type: 10 serial: <filter>
           Mobo: LENOVO model: 20189 serial: <filter> UEFI [Legacy]: LENOVO v: HPET18WW(1.03) date: 05/29/2012
Battery:   ID-1: BAT0 charge: 38.3 Wh condition: 38.7/46.4 Wh (83%) volts: 12.1/11.1 model: SMP L09M6Y02 type: Li-ion
           serial: <filter> status: Unknown
CPU:       Topology: Dual Core model: AMD E-300 APU with Radeon HD Graphics bits: 64 type: MCP arch: Bobcat L2 cache: 512 KiB
           flags: lm nx pae sse sse2 sse3 sse4a ssse3 svm bogomips: 5192
           Speed: 780 MHz min/max: 780/1300 MHz Core speeds (MHz): 1: 779 2: 780
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Wrestler [Radeon HD 6310] vendor: Lenovo driver: radeon v: kernel
           bus ID: 00:01.0 chip ID: 1002:9802
           Display: x11 server: 1.20.4 driver: radeon FAILED: ati unloaded: modesetting alternate: fbdev,vesa
           compositor: marco v: 1.22.0 resolution: <xdpyinfo missing>
           OpenGL: renderer: AMD PALM (DRM 2.50.0 / 4.19.32-1-MANJARO LLVM 8.0.0) v: 3.3 Mesa 19.0.1 compat-v: 3.1
           direct render: Yes
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Wrestler HDMI Audio vendor: Lenovo driver: snd_hda_intel v: kernel
           bus ID: 00:01.1 chip ID: 1002:1314
           Device-2: Advanced Micro Devices [AMD] FCH Azalia vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:14.2
           chip ID: 1022:780d
           Sound Server: ALSA v: k4.19.32-1-MANJARO
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 1000
           bus ID: 01:00.0 chip ID: 10ec:8168
           IF: enp1s0 state: down mac: <filter>
           Device-2: Broadcom and subsidiaries BCM4313 802.11bgn Wireless Network Adapter driver: bcma-pci-bridge v: N/A
           port: 1000 bus ID: 02:00.0 chip ID: 14e4:4727
           IF-ID-1: wlp2s0b1 state: up mac: <filter>
Drives:    Local Storage: total: 465.76 GiB used: 66.5 MiB (0.0%)
           ID-1: /dev/sda vendor: Western Digital model: WD5000BPKT-22PK4T0 size: 465.76 GiB speed: 3.0 Gb/s
           rotation: 7200 rpm serial: <filter> rev: 1A01 scheme: MBR
Partition: ID-1: / size: 2.46 GiB used: 66.5 MiB (2.6%) fs: overlay source: ERR-102
Sensors:   System Temperatures: cpu: 51.5 C mobo: N/A gpu: radeon temp: 51 C
           Fan Speeds (RPM): cpu: 0
Info:      Processes: 153 Uptime: 11h 19m Memory: 3.28 GiB used: 773.2 MiB (23.0%) Init: systemd v: 241 Compilers: gcc: N/A
           Shell: bash v: 5.0.2 running in: mate-terminal inxi: 3.0.32
1 Like

Tried this?

All right, i tried again. I Installed manjaro with erase disk.
New system didn't start again. I launched livecd and open gparted
There are really no boot flag. So I add boot flag and restart pc. And you know what? The system is started! From hdd! I can't believe. Thanks, stephane, you solved my problem. And thank you all for trying to help.
ps: Above, I said that I had tried added boot flags, but i create boot partition, and add boot flag to it, not root. Then I add root partition without boot flag, and swap partition.
pss: It seems to me that there is some problem in the installer. I manualy created the partitions root and home, added a boot flag to root, and again the system did not start. So again I boot from livecd, open gparted and add boot flag to root partition. Because it was not there, although I put it during installation. Not cool, instalation wizard, not cool.

With the switch to kpmcore 4.0 it might have a regression now.

Are those issued affecting MSDOS/MBR installations as well?
OT issue is with MBR/BIOS Legacy installation.

Notice OP erased disk, has only one partition and in msdos/bios-legacy?
Wonder if he had used gparted and set up partition table (to msdos) before installing whether the lack of boot flag can affect his boot. What do you think?

This thing with the boot flag missing doesn't always have fatal results. It happens to some firmware, so I think a test on a random PC can't produce useful info.

This is the 3rd case of a msdos single partition needing a flag to boot.
None has reported 'creating a partition table'.
Erasing disk does not create any partition table.
But of course, many would not know about it.
Erasing a partition may keep the partition table.

Some news. I tryed install lubuntu and had same problem. So, maybe the problem is not in the intaller.

Before installing Manjaro, use gparted to set up your disk first.
gparted package is found in most manjaro media.
If it is not there, install this gparted package at live OS.
At gparted, device tab --> create partition table --> select msdos.
Then still at gparted create partitions.
partition 1 --> 455 GB ext 4
partition 2 --> balance (about 10 GB) for swap

At installation,
boot up install media in bios-legacy,
use 'manual partitioning'
choose partition 1 as root (/), do not format.
choose partition as swap, do not format.
select Bootloader location as /dev/sda


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by