Manjaro does not detect CPU as OpenCL device

Hello everyone, I am quite new to Manjaro and I am very happy with it so far! I use my machine primarily for 3D/vfx work. Unfortunately, I ran over an issue today which I was not able to solve, even after extensive googling and trying things out.
I would like to use my CPU as the opencl device for one of my programs (houdini, a 3d vfx software) to get rid of the vram-bottleneck.
As you can see in the specs below, I have a threadripper cpu and already installed the amdapp-sdk, which should (given my research was correct) provide opencl support for my amd cpu.
OpenCL via graphics card works flawlessly, on linux mint and ubuntu mate opencl on cpu worked "out of the box". So what am I missing here?
I even get some really strange output from "clinfo", it says:

[matti@mattidesktop ~]$ clinfo
Usage: /opt/hfs18.0.532/bin/clinfo-bin [-r rate] file.clip [file2.clip...]
  -r rate    Specify an animation frame rate

So its basically pointing to clinfo-bin in the installation directory of houdini...?
Thanks in advance,

Matti :slight_smile:

System:
  Host: mattidesktop Kernel: 5.7.9-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.1.0 Desktop: Xfce 4.14.2 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: ROG ZENITH EXTREME ALPHA v: Rev 1.xx 
  serial: <root required> UEFI: American Megatrends v: 2001 date: 07/31/2019 
CPU:
  Topology: 16-Core (2-Die) model: AMD Ryzen Threadripper 2950X bits: 64 
  type: MT MCP MCM arch: Zen+ rev: 2 L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 224055 
  Speed: 1892 MHz min/max: 2200/3500 MHz Core speeds (MHz): 1: 1942 2: 1878 
  3: 1892 4: 2194 5: 1889 6: 1888 7: 1892 8: 1891 9: 2085 10: 1826 11: 1894 
  12: 1892 13: 1826 14: 1981 15: 1996 16: 1896 17: 1977 18: 1972 19: 1993 
  20: 1990 21: 2179 22: 1976 23: 2192 24: 1880 25: 1980 26: 1952 27: 1890 
  28: 1891 29: 2017 30: 1891 31: 1894 32: 1892 
Graphics:
  Device-1: NVIDIA TU102 [GeForce RTX 2080 Ti Rev. A] driver: nvidia 
  v: 440.100 bus ID: 09:00.0 
  Display: x11 server: X.Org 1.20.8 driver: nvidia 
  resolution: 3440x1440~60Hz 
  OpenGL: renderer: GeForce RTX 2080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 
  direct render: Yes 
Audio:
  Device-1: NVIDIA TU102 High Definition Audio driver: snd_hda_intel 
  v: kernel bus ID: 09:00.1 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 0b:00.3 
  Device-3: Microsoft LifeCam VX-2000 type: USB 
  driver: snd-usb-audio,uvcvideo bus ID: 1-9:2 
  Device-4: AVID Fast Track Solo type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 9-4:2 
  Sound Server: ALSA v: k5.7.9-1-MANJARO 
Network:
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb 
  v: 5.6.0-k port: 2000 bus ID: 03:00.0 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: 40:b0:76:d7:f1:10 
  Device-2: Aquantia AQC107 NBase-T/IEEE 802.3bz Ethernet [AQtion] 
  vendor: ASUSTeK driver: atlantic v: kernel port: 1000 bus ID: 07:00.0 
  IF: enp7s0 state: up speed: 10000 Mbps duplex: full mac: 40:b0:76:d7:f1:11 
Drives:
  Local Storage: total: 2.27 TiB used: 192.62 GiB (8.3%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 500GB 
  size: 465.76 GiB 
  ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO 500GB 
  size: 465.76 GiB 
  ID-3: /dev/sda vendor: Toshiba model: DT01ABA200 size: 1.82 TiB 
Partition:
  ID-1: / size: 441.21 GiB used: 192.62 GiB (43.7%) fs: ext4 
  dev: /dev/nvme1n1p3 
  ID-2: swap-1 size: 16.00 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme1n1p2 
Sensors:
  System Temperatures: cpu: 42.4 C mobo: N/A gpu: nvidia temp: 36 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 35% 
Info:
  Processes: 501 Uptime: 17m Memory: 62.73 GiB used: 1.83 GiB (2.9%) 
  Init: systemd Compilers: gcc: 10.1.0 clang: 10.0.0 Shell: bash v: 5.0.18 
  inxi: 3.0.37 

Did you install opencl-nvidia-440xx?

Hey, yes, that’s installed.

I missed that the first time I read it. opencl-mesa is for AMD, but you can only have one driver installed.

Where did you install Houdini and CLinfo from? houdini is in the AUR and clinfo is in the repos. The latter should be running from /usr/bin/.

Hmm.. then I am wondering why it just worked on other distros? I will try another version of Houdini tomorrow just to check it’s no issue on their side.

I got clinfo from the official repo and Houdini from the developers website since Houdini in AUR is a pretty old version.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by