Manjaro does not start on Raspberry Pi 4

I can't booted Manjaro ARM Minimal 19.12 on a Raspberry Pi 4. When I try boot system from microSD card, I see only black screen.

I have Raspberry Pi 4 with 4GB ram with latest EEPROM firmware version.

What image did you download and how did you flash the SD card?

I downloaded image from:

Then I written this image on microSD card by Win32DiskImager.

Assuming the image is installed correctly look at post #9 in this thread and modify the config.txt file on the boot partition of the sdcard choosing the config for your monitor's resolution for hdmi0 there (1920x1080 or 1366x768).

Some monitors do not get detected right with the pi4; especially televisions. Also make sure your hdmi cable is connected to hdmi port0 on the rpi4 board.

I tried to boot Manjaro, but without success.
I think the problem is in this image for RPi4.

After saving the image on SD card:

Dysk /dev/sdb: 31.0 GB, 30979129344 bytes
64 heads, 32 sectors/track, 29544 cylinders:
Units = cylinders of 2048 * 512 = 1048576 bytes
Sector size (logical/physical): 512 / 512 bytes
I/O size (minimum/optimal): 512 / 512
Disk identifier: 0x9d3b6d9d

Device	Boot	Start	End	Blocks	ID	System
/dev/sdb1               2          95       96256    c  W95 FAT32 (LBA)
Partition 1 does not end on cylinder boundary.
/dev/sdb2              96        1746     1690624   83  Linux
Partition 2 does not end on cylinder boundary.

I see an error when I try to mount partition ext4:

mount -t ext4 /dev/sdb2 /mnt/rootfs
mount: wrong fs type, bad option, bad superblock on /dev/sdb2

mount -t auto /dev/sdb2 /mnt/rootfs
mount: wrong fs type, bad option, bad superblock on /dev/sdb2

And I don't see error when I mount partition fat, but I don't see any files on this partition.

mount -t vfat /dev/sdb1 /mnt/bootfs
ls -l /mnt/bootfs
total 0

Did you burn the image to the sdcard with Etcher.

Image only working with with Etcher.

How about the Raspberry Pi Imager? Would you consider that to be a drop-in replacement compared to Etcher?

That requires our images to be in their curated list, as far as I know. Which we are not.

They do allow to flash from a "Custom Image" of your choosing (when you scroll to the bottom of their list, see "Use custom" below), and it can be still .xz-compressed when you choose it:


I've tried it, and it seems to work.

1 Like

Cool. Thanks for confirming that. :slight_smile:

That reminds me. Did the Manjaro ARM team ever ask for Manjaro ARM to be included on the download page on and now the imager? That would probably help making it more known.

If you have a contact info we could use, we will certainly try. Looked around on the blog site when I read about the new Imager. Couldn't find any to the guy in question.

Hmm, i didn't find anything either but this should work:

Or maybe open an issue here: (GitHub is giving me a 401 right now)

Thanks. I created an issue where I request we get added.

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by