Manjaro doesn't detect sound card

i've recently installed manjaro and it seems that it does not detect my Realtek sound card. I tried the solutions suggested on other threads and switching the kernel as well but they all failed.
aplay -l

aplay: device_list:274: no soundcards found...

inxi -Fx output :

System:    Host: bal-- Kernel: 5.5.8-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.1 
           Desktop: KDE Plasma 5.18.3 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 7590 v: N/A serial: <root required> 
           Mobo: Dell model: 0M01WJ v: A00 serial: <root required> UEFI: Dell v: 1.5.1 date: 11/06/2019 
Battery:   ID-1: BAT0 charge: 54.7 Wh condition: 54.7/56.0 Wh (98%) model: BYD DELL CP6DF99 status: Full 
CPU:       Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake rev: A 
           L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62431 
           Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 801 6: 801 
           7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 3 GB Max-Q] vendor: Dell driver: nvidia v: 440.64 
           bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.7 driver: modesetting,nvidia unloaded: intel,nouveau 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.6 Mesa 19.3.5 
           direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: sof-audio-pci bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.5.8-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 4000 
           bus ID: 00:14.3 
           IF: wlo1 state: up mac: 04:**:**:**:**:**
Drives:    Local Storage: total: 114.61 GiB used: 11.90 GiB (10.4%) 
           ID-1: /dev/sda type: USB vendor: SanDisk model: Ultra USB 3.0 size: 114.61 GiB 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 bus ID: 00:17.0 
Partition: ID-1: / size: 95.32 GiB used: 11.90 GiB (12.5%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 16.97 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 56.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 3141 fan-2: 3083 
Info:      Processes: 302 Uptime: 32m Memory: 15.42 GiB used: 1.61 GiB (10.4%) Init: systemd Compilers: 
           gcc: 9.2.1 Shell: bash v: 5.0.16 inxi: 3.0.37

welcome to Manjaro @alma

system is partially recognising the audio device

Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: sof-audio-pci bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.5.8-1-MANJARO

this laptop has a digital dual microphone array, and needs a new driver that has only recently been supported by Linux kernel

if aplay -l command fails to find any soundcards, probably need to install package sof-firmware

use this command in terminal - pacman -S sof-firmware

once that is installed, restart system to reload the audio device with the firmware

another user with an Inspiron 7590 laptop has confirmed Sound Open Firmware driver works

1 Like

it works now. Thank you !!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by