Manjaro doesn't start, Control-Alt-Fkeys don't work, Flashing error messages

I think this started after my battery ran dry. The next day at work, it wouldn't boot. I'm just guessing maybe it tried to hibernate, but failed to. Usually I suspend before it runs dry. Anyway, I let it try booting for hours, because I could hear the disk cranking away like it was doing something. Cursor flashing. Some Google searches suggested that I "update grub" by turning off some pci setting, but I'm not sure how to edit files when I can't Control-Alt-F(anything) and the Grub prompt is like a foreign planet to me. That was yesterday. I tried booting again just now, waited like 30 minutes and now the screen is actually flashing a whole page of error messages. It's flashing on and off like every 1.5 seconds. I managed to shoot a photo between flashes, which was hard. Anyway, what should I do? I'd rather not wipe the system because spent some time configuring Manjaro, etc.

Did you by any means perform (partially) the update of this weekend? - and that was your first "restart" when the battery ran dry?

If so please have a look at the threads I linked there:

If you can not get into another tty (F-Keys) you can bootup with a live CD/DVD/USB of Manjaro and use manjaro-chroot to chroot into your not running installation.
(how to chroot the easy way: https://manjaro-mate.gitbooks.io/manjaro-mate-short-manual/content/chroot.html)

2 Likes

It's stuck here for the last hour, and I still hear the disk doing something.

To answer your question, I think on the 3rd I had a warning on my desktop: "Your kernel is no longer supported." So I updated and it said, "Your system is up to date." That process wasn't interrupted.

My question now is, can I boot a "live USB" if I encrypted the disk? The disk obviously decrypts when I boot, but I'm wondering if the HD will decrypt if I boot off a USB. If not, I'll never encrypt my disk again, because this bytes.

Uhm - yes you can decrypt luks when mounting it from a liveCD/USB - if it is just about getting the data you can click mount it just like any other drive and give your password - but I do not know if the chroot works than. You can chroot into an encyrypted / and /boot but that was realy fiddly for me when I killed grub.

As for the errors - I am sorry but I have no idea what they are caused - but the wifi stuff at the top is not known to inhibit booting - the pci one at the end though is wired (to me).

Maybe you want to add pcie and kernel as tags - to get the attention of someone more knowledgeable.

With this part of the excellent guide which The3Zone gave you the link for:

Note: If trying to access an encrypted filesystem,
do not forget to first unlock its container
(e.g. with
# cryptsetup open /dev/sdX# name
for dm-crypt/LUKS-based encryption),
then mount the device using its previously supplied device-mapper name (under the form
# mount /dev/mapper/name /mnt/arch/...
).
More info: Unlocking/Mapping LUKS partitions with the device mapper.
https://wiki.archlinux.org/index.php/Change_root#Partition.28s.29_mount

I have written a less clear but also usable tutorial for this which however contains a Manjaro specific chroot helper command (choose the guide which suits you best)

2 Likes

So this is the latest chroot guide, that uses new method and should be first one to try, correct? And there is also described manual method if needed. This is exactly what I needed, so I can point users to it, who need help with chrooting. Great, I didn't know it exist, thank you!

1 Like

The one I found looks best structured - if its the latest I can not say. Sry;

1 Like

It is a good guide, but that doesn't mean that other methods are bad. I will give this link with others and the user can decide which to use.

Yes I understand, I will to.

Since many beginners like to get answers in a form like this:

  • do step1,
  • then do step2...

(I remember when I first time got link as solution, I was terrified: "just tell me what to do please, if I go to that link there will be 'optionals' and I will have 10 more questions and no answer...."

I was looking for something like this, so I can (when helping) just answer with preferred steps most help seekers want to see. Then at the bottom of my answer I can add links for extra education. :wink:

Now that I have preferred steps I will try it out few times myself and then I can be comfortable answering and helping...

2 Likes

You are right, I first give a link and if I get asked what to do again I try not to shout RTFM but write the steps I feel most suitable for this particular situation.

3 Likes

@eugen-b, the 'voice of reason.' Always. :smiley:

Regards

3 Likes

Alright, thanks for all the tips. I'm at work and will dig into the suggestions tonight. If I can get at the files, at least, that would be a relief.

Also in Google someone recommended editing /etc/default/grub and change GRUB_CMDLINE_LINUX_DEFAULT = "splash pci=noaer"

and then "sudo update-grub"

So if I can chroot in, that's what I'd try to change first?

I was able to mount the disk using Thunar just by clicking on the drive, using a BunsenLabs USB that I had handy, but I had to first install "cryptsetup" for the mounting to work.

I was able to edit /etc/default/grub, however adding "pci=noaer" to GRUB_CMDLINE_LINUX_DEFAULT was ineffective.

Not sure what to do next...

I think it was the mesa-stack. Wow, and I thought Manjaro was targeting non-technical folks. I guess not.

Here's how I got my laptop working again...

// As per http://unix.stackexchange.com/questions/4027/how-do-i-prevent-grub-from-using-starting-any-graphical-ui

Booted into single user (press "e" at startup and add "ro 1" to linux.)

// No network, even with my hotspot plugged into USB. Lucky guess...
dhcpcd

// Coming from Debian, not really sure how to use this...
pacman -Syyu

"==> Fix mesa-stack"

Now I'm thinking, I bet it's going to work!

Rebooted.

Aaand it works.

2 Likes

Yeah, some 'big' changes in the Arch base going on right now, plus any 'Live' Linux boot/install can be a bit dicey on new hardware...

Manjaro is more difficult to maintain than Arch, IMHO...

Regards

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by