Manjaro freeze when i type special characters

i have same issue with this topic. manjaro freeze when i type special characters like euro sign. i tried sudo systemctl start gdm on terminal. but still there is issue. how can i fix this ?


i tried manjaro 18 gnome from usb. i can type special characters on manjaro live


i reinstalled manjaro 18 gnome. now i can type special characters like ı, ş, . i will update manjaro and install language packs and recheck.

I had the same problem but its not tied down to "gnome".
It is the locale settings.

I rightclicked my clock and clicked on norwegian locale settings. I dont like 10PM/AM. In console i clock "06:10" when the clock was 18:10. I wanted to have "24-hour" time format. After changing this my locale settings got somewhat messed up.

My pc didnt freeze but it makes things like "<<<-.->>>" when typing "#".
The problems where consistent and following special caracteres.

If you type locale in console: (You wil have one line that says just "C".
LANG=en_US.UTF-8
LANGUAGE=
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

I dont have Linux infront of me. To fix it I changed LC_ALL=en_US.UTF-8.
Launch command like the "term=256Color. Now I have no problems.

after updating, i have issue again.
unfortunately i can not change LC_ALL permanently. i added export LC_ALL=en_US.UTF-8 line to .profile and .bashrc files. but after reboot LC_ALL is empty again


i added export LC_ALL=en_US.utf8 to .bash_profile file and now LC_ALL is en_US.utf8 but still there is issue


i changed WaylandEnabled option to true from false in /etc/gdm/custom.conf. now i can type special characters.

You should never use this setting. It should be empty and used only for specific troubleshooting. When LC_ALL is set, all other (possible) locale settings are overridden.

Having Wayland enabled, is significant info when you troubleshhot problems. You should have mentioned it. Or, in the future?:grinning:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by