Manjaro freezes after hibernation/suspend

Hi everyone!

After I installed fwupd 1.3.6-1 my installation freezes when I suspend/hibernate. I already removed the package.

I have tried solving the problem without success following these similar topics:

  1. Manjaro crashes after Hibernation

  2. Suspend/Hibernate freeze
    I have tried kernels 4.19 and 4.14.

Does anyone know what else I could try?
Thanks!

System:
  Kernel: 4.14.167-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-4.14-x86_64 
  root=UUID=1ddfc4cf-e460-4701-a478-9927cc999471 rw quiet 
  cryptdevice=UUID=7452f72e-b059-4a0c-8ea8-cce749bcf352:luks-7452f72e-b059-4a0c-8ea8-cce749bcf352 
  root=/dev/mapper/luks-7452f72e-b059-4a0c-8ea8-cce749bcf352 
  resume=/dev/mapper/luks-7452f72e-b059-4a0c-8ea8-cce749bcf352 
  Desktop: Gnome 3.34.3 wm: gnome-shell dm: GDM 3.34.1 Distro: Manjaro Linux 
Machine:
  Type: Convertible System: LENOVO product: 80YM v: Lenovo YOGA 520-14IKB 
  serial: <filter> Chassis: type: 31 v: Lenovo YOGA 520-14IKB 
  serial: <filter> 
  Mobo: LENOVO model: Lenovo YOGA 520-14IKB v: SDK0J40688 WIN 
  serial: <filter> UEFI: LENOVO v: 4QCN36WW(V1.06) date: 07/11/2017 
Battery:
  ID-1: BAT1 charge: 24.8 Wh condition: 24.8/35.0 Wh (71%) volts: 8.3/7.5 
  model: SIMPLO PABAS0241231 type: Li-ion serial: <filter> status: Full 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
CPU:
  Topology: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP 
  arch: Amber Lake family: 6 model-id: 8E (142) stepping: 9 microcode: CA 
  L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 23240 
  Speed: 2700 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 2700 2: 2700 
  3: 2700 4: 2700 
  Vulnerabilities: Type: itlb_multihit status: KVM: Vulnerable 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel HD Graphics 620 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:5916 
  Display: x11 server: X.org 1.20.7 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) 
  v: 4.6 Mesa 19.3.2 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k4.14.167-1-MANJARO 
Network:
  Device-1: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi 
  v: kernel port: 3040 bus ID: 02:00.0 chip ID: 8086:3166 
  IF: wlp2s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 238.47 GiB used: 241.00 GiB (101.1%) 
  ID-1: /dev/sda vendor: LITE-ON model: LCH-256V2S size: 238.47 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 203 scheme: GPT 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: 3060 bus ID: 00:17.0 chip ID: 8086.282a rev: 21 
Partition:
  ID-1: / raw size: 229.37 GiB size: 224.77 GiB (97.99%) 
  used: 107.03 GiB (47.6%) fs: ext4 block size: 4096 B dev: /dev/dm-0 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap 
  swappiness: 60 (default) cache pressure: 100 (default) dev: /dev/dm-1 
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 251 Uptime: 2m Memory: 7.66 GiB used: 2.02 GiB (26.5%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
  running in: gnome-terminal inxi: 3.0.37

Why don't you file a bug with the maintainers of the fwupd application if you know it's the culprit?

:innocent:

1 Like

Thanks, @Fabby!

I found out what was wrong.

I saw in another topic that I should run sudo journalctl -b-1 -p4 to see the logs after the freeze and I found this error:

jan 28 08:22:00 eduardospano systemd[1]: Failed to start Fingerprint Authentication Daemon.

I found in this other topic (https://forums.fedoraforum.org/showthread.php?321676-Removing-fprintd-caused-a-25-second-system-freeze-before-screen-Login-appears&p=1824489#post1824489) that I had to remove the package fprintd.

Now it is working fine again. Thanks!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by