Manjaro freezes mhwd command

Hi manjaro forum,

Yesterday I started installing manjaro 18.0 KDE stable. I falshed my usb anda I installed dual boot with windows. I installed with free drivers because with nonfree drivers it doesnt boot the live usb. I installed and when I run command mhwd or inxi my pc freezes and I cannot do anything. Also when I go to system settings to the first option of hardware, it freezes. The objetive of running the command mhwd is for download drivers whit this command sudo mhwd -a pci free 0300.
I have follow another forum posts like this but my problem still there.

My laptop is:
Intel i7 7700HQ
Nvidia GTX 1050
Model: MSI GE72 7RD

Thanks in advance.

Did you actually install Manjaro or did it fail completely?

You state - dualboot with Windows - a common issue is Windows locking the filesystem - did you actually install Manjaro or is the commands mentioned done when booting the ISO?

I have installed manjaro correctly, i have the problem in installed manjaro.

Thanks for your replay.

you are trying to auto install the free dirvers and are already there ...

You can safely run:
sudo mhwd -i pci video-nvidia
and install the nvidia drivers ...
or it happens that you have a hybrid graphics laptop?
If that's the case, you have to look into bumblebee or prime
Plenty of how to in the forum.

You state that the command inxi freezes your system.

This is not normal behavior but could indicate a problem fetching system info.

Does inxi freeze your system when you just run inxi and if not what is the output?

The command mhwd -a pci free 0300 should not freeze your system. This freeze is an indication of another issue with your system. We just don't know yet what that issue is.

1 Like

When i run the command that you have indícales about nvidia also the terminal is freezed and doesnt do anything. About the hybrid graphics hoy I know if my system is?

Thanks for your reply.

I have executed inxicommand and the terminal has freezed again.

Thanks for your reply.

It is weird - does it freeze when you use a live ISO and then execute inxi?

try updating bios

As you are able to install Manjaro - your system probably has the Intel / Nvidia graphics combo.

Just checking the specs - it is not clear if you have Intel - nevertheless - your system should not hang.

Is it a brandnew system - a secondhand system?

I have updated BIOS and have runned inxiCommand and i had this output:
image
But with the mhwd command has freezed.

Thanks for your reply

Now that Im thinking my laptop has Intel graphics. Is that the problem?

No the mhwd command has not freezed.

You are supposed to enter your password as indicated by the prompt.

It says [sudo] password for

I have entered in that photo, when i just entered and clicked enter the system freezed

I know this is not exactly the same thing, but I have a GTX 1050Ti, and when I boot into a live USB Xfce session with free drivers, the system, well the mouse pointer, becomes very laggy until it stops moving altogether. However, with video-nvidia, it works fine.

If you still have issues with your main system, you could try a live USB/CD session and CHROOT into your main system to update the video driver.

On *nix systems - in a terminal - when you are requested a password - you will not see any indication of input until you press enter.

This is why I ask: did you input your password at the prompt

[sudo] password for unaipuells:

The system is not frozen - you just don't see input -

I know. I put the password and then press enter and the system freezes completely I cannot move even the mouse.

OK - does your system have an internet connection?

If not the mhwd command might hang and appear frozen if your driver is not available locally.

What is the output of:

hwinfo --gfx
mhwd
mhwd -lh
mhwd -li

Yes, I have internet connection

Forum kindly sponsored by