Manjaro freezes mhwd command

What is the output of the commands @philm requested?

Has completely freezed 10 seconds after runned the command hwinfo —gfx

Seems some is totally off on your end. Normally hwinfo takes less than 10 seconds to display you the result.

Indeed - pointed out in post 5

always make sure to turn secureboot fastboot in bios off .also in windows10 turn fastboot off.
you installed manjaro in uefi mode or bios mode???
might as well try other iso like xfce 18.0.1preview
and see if issue persist

Try to boot with modprobe.blacklist=nouveau, then run @philm's commands again.

This issue isnt isolated to just his machine. I bought a new laptop a couple weeks ago and have been struggling to install manjaro(gnome) on it as well( It installs fine and boots to the login in screen but the second I attempt to login it freezes and needs to be power cycled. I can hit ctrl + alt + F2 and login that way and certain commands like pacman -Syu work but if I try an mhwd command or inxi I receive a " soft lockup - CPU stuck for #s!".

Have you done a search for your card on the forums?

Here is just one example of things to try and learn.

@unaipuelles i finally got my installation to work. I used a combination of the instructions from and the instructions in the post @anika200 linked.

Roughly it was

  1. Add kernel flag systemd.mask=mhwd-live.service
  2. Choose non free drivers
  3. Edit /lib/calamares/modules/mhwdcfg/ as stated in the github post.
  4. Install system
  5. Reboot add kernel flag acpi_osi=! acpi_osi="Windows 2009" pcie_port_pm=off
  6. Follow the instructions from

That is so great.

Thank you for sharing the results. :+1:

This is just the solution. Thanks a lot for your time.

Let’s enjoy Manjaro!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by