Manjaro freezes on the desktop screen after identification

I have a problem with the launch of Manjaro. I am in the first year of a computer engineering school (in France). I bought a new laptop and this time I invested in a Windows because I wanted to dual boot my computer. But I didn't dare do it on Mac because I was advised not to do it.
However, after many problems with manual partitioning installation, I finally managed to install it by assigning a partition to install Manjaro automatically.
But after fighting for a whole day, it was too good to be true. Once Manjaro is launched, I arrive on the identification screen. I enter my password. And then the screen freezes on the KDE's background. I tried the manipulation several times but nothing to do. In the end the screen freezes at the fateful moment! It is absolutely not random. Every time I force the shutdown and start again, the screen freezes. Besides, we don't see the mouse.
I've done a lot of research. I saw that a lot of other people had similar problems. But I didn't really understand the solutions we were giving them. The only thing I understood was that it was probably from my graphics card. I have an NVIDIA GetForce GTX 1050 graphics card and another Intel(R) UHD Graphics 630. I attach below the other features of my laptop.
Would it be a good idea to disable my graphics card?

Thank you for your attention. I hope that my English is not too incomprehensible and that my explanations are clear. I'm still new to the business so a lot of things are still unknown to me.

Welcome to Manjaro! I wish you enjoy the experience and succeed in your goals!

Maybe one of the factors, as you already have a GUI with Display Manager (sddm, the "identification screen").

If you can do this (disable discrete gpu nvidia from BIOS), it maybe a temporary workaround, or permanent, if you don't need a lot of graphics power.

Some helpful reading will assist you with your confidence:
How to provide information about your issues
How to change video drivers or configuration and troubleshoot
And this is for your options for an Optimus laptop:
Options for Nvidia Optimus graphics

After educating yourself with the above info, try these and post info and logs:

  • Check if Plasma works with startx
    At the Login Screen (SDDM), go to TTY (press Ctrl+Alt+F3), login as user and run startx.
    Report what happens and any error messages at terminal
  • From TTY or GUI (if it works) run in terminal and post output (as text, not pictures):
inxi -SGMxxxz
mhwd -li
journalctl -b -p3 --no-pager --no-hostname
grep -E "(EE)|(WW)|Time|BOOT_IMAGE" /var/log/Xorg.0.log
cat /etc/X11/xorg.conf.d/*.conf

After the above, you may notice you don't need to "force shutdown" unless you have to. When GUI freezes, try to go to TTY and troubleshoot (gather info, logs etc) and may shutdown or restart in terminal:

systemctl poweroff
systemctl reboot
1 Like

Thanks a lot for your reply. I will check attentively all information you gave me !

1 Like

I've taken a little break since last time because I had important things to do. However, there has been some evolution since then. First I went to the links you gave me. I've read a little bit of everything, but I must admit that I haven't understood everything yet. Secondly, after several days without launching Manjaro, I decided to restart it to do the tests you asked me to do. However, as a miracle I managed to enter my login and the desktop is opened correctly without the screen freezing! So now I can use manjaro. Which was not the case before. However, when I tried to turn off my computer, my screen froze again on the KDE background. I tried to do "CTRL + ALT + F3" for example. But the terminal doesn't open (what you call TTY I understand). Even worse, when I come back to Manjaro and try to open the terminal before it freezes, it sends me a black screen. Therefore, it is impossible not to force the extinction.

Thank you for your help. I think I am going to call specialist because it's very awfull. It makes so a long time that it doesn't work whereas it supposed to be simple. :slight_smile: I'll still try to look again and if it doesn't work I'll give up.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by