Manjaro (full) BSP - Limepanel and Terminal problems.

Hello,

I'm making this post today because I decided to give Manjaro a try and am currently looking to try out window managers (currently on BSP) for a future build as main OS, and I'm running into a nasty limepanel and terminal issues.

Limepanel loads up and I can see it on the desktop. Some functionalities work, such as the cross to close windows, the arrows next to it and the button to tile windows on the left, but I can't get the main widget do work when I left click on it.

As for the terminal, whenever I try to open it, it shuts down automatically.

If you need the content of any dotfiles, let me know and I'll go fetch that through tty.

I'm pretty sure I messed something up somewhere but I'm really not sure where.

Here is my bsp config file: http://pastebin.com/raw/bPppYrsu

Thanks for taking the time to read this.

I can now edit this post with my new trust level:
A few clarifications, I'm using a VM created by VMWare.

Welcome to the Forum!

Regarding the issue with the rofimenu, follow what is suggested here:


As for the terminal, there was an issue recently with tmux changing their syntax as described here (please read the whole thread):


I'm not sure if this is causing the problem with sterminal in your case, but you can give it a try to see if it helps.
You have to copy the file /etc/skel/.tmux.conf to your home directory replacing the existing one.
Make a backup copy of the file ~/.tmux.conf and then replace it with the one from the /etc/skel/ directory.

cp /etc/skel/.tmux.conf ~/
1 Like

Hello, thank you for the welcome, the research and the reply!

I have looked at the links you provided, I had no idea rofimenu was something to look for (I only found people talking about limepanel when I did my searching), I tried deleting the folder as they said, and running rofimenu again, it recreated a folder, but I still can't get the menu functionality.

I also did what you told me to with the tmux conf file but I'm not sure it was the right one to work on, since when I tried, the problem still arose.

Even if this isn't solved yet I want to thank you again for trying, I will try to give a closer look at the rofimenu threads out there.

Edit: It's weird because Sterminal works to display the "Main Menu" https://i.imgur.com/sEmER55.png and stuff like the shortcut newbie help with Mod4 + F1, could I have the wrong terminal configurated to launch?

Edit2: I'm starting to think the terminals are not being closed but are being hidden by some BSPWM magic? I remember trying out different binds on some windows, and after trying to open a few terminals, I see that the window title on limepanel still reads "Sterminal". I tried clicking the tile button on the panel, and it appears to react to clicks, meaning I think terminals are running, they are just being hidden on creation? https://i.imgur.com/QQy7SC8.png

1 Like

Sorry to bump my own thread, but I found the solution so for the sake of the people that might not have been attentive enough (like I was), a new answer marked as the solution might be better.

When I tried deleting my rofimenu and executing rofimenu, I went out of tty to execute it, which was a big mistake. I tried again in tty, and there was an error: I hadn't installed locales.

If you haven't generated the locales you're interested in, you can follow this wiki page with instructions on how to do it: https://wiki.manjaro.org/index.php?title=Locale

I apologize for wasting your time @bill_t

3 Likes

You don't need to apologize, you didn't waste my time at all! :slightly_smiling_face:

Glad that you solved your issue and also shared the solution on the Forum so other users can benefit from it! :+1:

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by