(Manjaro Gnome) Black Screen at login after Last Stable Update [2017-1-30]

Hi all,
after the last stable update [2017-1-30], my Manjaro GNOME does not prompt for user login screen anymore.
It hangs on a black screen with the mouse pointer, nothing else.
CTRL+ALT+F# gives access to shell but no GUI.
Tried both kernels, none working (4.4 & 4.9).

I'm attaching the output of:
inxi -Fx
journalctl -b
sudo pacman -Ss | grep installed
plus the pacman and Xorg logs.

https://mega.nz/fm/1g8A2ZbR or https://file.io/QpF22p

Any advice?
Thanks in advance for your help, that is my first post here!


I will not be able to help you, beginner myself, but maybe a hint or two. You said you can boot to tty. Good, so good chance there is some problem with graphic driver and nothing more serious. (my guess) Having access to tty also means you shouldn't have hard time removing and installing different driver. No chroot needed.

I can't see what graphic card you are using, since you posted external links and I have set up browser the way that I can't open them. Some users may be wary of clicking external masked links so may not be bad idea to copy/paste your inxi here into the post.

from tty you could run: ( -n is optional, if you want to see log one -1 or two -2 boot back and so on...)

journalctl -p err -b [-n]

To see last boot errors, that may give you a clue. Also if you run startx in tty, what error msg do you get.


mhwd -l -d <= info what graphic drivers are installed & available

Now, since you see the inxi printout and you know what graphic card you have, search this forum with the name of your graphic card. You may get your answer that way. Also see second past of the post bellow, after the chroot, it may be useful. You can do all this while waiting on more competent help than I am. I hope you get your system back as soon as possible.


Hi Brother!

I'm currently using Manjaro budgie, but this 2 DE's are very very similar (at least until now).

That said I had the exact same issue with this last update, IDK exatly what happened... but it seems LightDM got screwed really good.

Firstly my LightDM menu shows that all files that were loads by the greeter (themes and icons) got lost (it seems like this files got deleted somehow).

In addition to that if I run "systemctl status lightdm.service" shows an error also. So, yes, something went really wrong in this last update and I still don't know what exactly went wrong.

I'm no one to give advice here, but if this would happen to me, I don' think it wouldn't hurt to first remove LightDM and then install back LightDM. You have nothing to lose and problem may go away.

Another option would be to first remove LightDM and then install different. I know on Xfce you can LightDM replace with MDM (Mint DM), not sure about Budgie and Gnome

To install LightDM:

sudo pacman -Sy lightdm lightdm-gtk-greeter


Did you report the problem in the last stable update?

1 Like


Same thing happened to me in Gnome. What I did was uninstall lightdm and install GDM. That fixed it for me. But GDM is ugly so might try and reinstall lightdm and see what happens.

1 Like

I can confirm that I am having the same issue from a fresh install a couple of days ago after running the latest updates.

I have tried to change the LightDM icons, theme, wallpaper etc via LightDM GTK+ Greeter Settings tool however this made no difference, still needing to startx.

Hi, what version are installed? The 16.10 come with lightdm , 17.0 beta with gdm .. and you have free or closed driver ? I am on smartphone @eugen-b or @excalibur1234 is possible move other tread here ? :wink:

Lightdm gtk greeter not work because use webkit2 version (i assume is a liveiso fresh install)

1 Like

Same issue for me after rebooting this morning (did the update last night).

Found a solution that worked for me on this thread (using google cache, because for whatever reason the topic doesn't seem to existe anymore)

So I downgraded webkit2gtk to 2.14.2-2 instead of the current 2.14-3-1 and it worked for me

pacman -U /var/cache/pacman/pkg/webkit2gtk-2.14.2-2-x86_64.pkg.tar.gz

Doesn't sound like a real solution to me but absolutely need to work this morning so I'll look further into this issue later.


Thanks @Ste74 and @Gog0. Solved my problems for now.

Uhmm let me see why.. this is an antergos pkgs .. here only modify the theme to match with manjaro brand...

Hi, I have a Budgie instalation and after this update my system won't boot anymore.

Anybody in the same situation?[quote="AlManja, post:4, topic:16702"]
Did you report the problem in the last stable update?

Yes, but since Gnome and Budgie aren't the main DE's I guess most ppl couldn't help.

Thanks @Gog0 ,
I'll use your workaround for now. It's much better than starting X manually.
The thing is the lighDm greeter in my case lost it's references to themes and icons and I checked the paths with no success on finding the original themes (vertex-maia-square) or icons (maia).

Do you guys have those files in your system? At /usr/share/themes and /usr/share/icons ?

EDIT: Lemme just confirm that @Gog0 's workaround worked for me, and the themes and icons rolled back (Strange since I messed with the lightdm config to change theme and icons).

Hi all,
Thanks everyone for the precious help!
I successfully logged in by using @Gog0's workaround.

To answer previous questions, I'm using bumblebee with proprietary drivers.
I installed Manjaro from the GNOME community edition 16.10.

If I understand correctly lightdm should be replaced with gdm? Any advice to transition safely?

If more logs are needed just ask.
Thanks again for all the help!

I had exactly the same issue. But in my case, just after updating, I upgraded the kernel, then rebboted, and got the black screen, instead of the greeter. After a lot of searching and no solution, I decided to reinstall the whole system. All good, then updated. Greeter gone again. is there an ticket started for this issue? Is it a generalized problem with this update?

Do you use gnome/budgie or something else? If Gnome/Budgie, try upper solution. I see you posted before you have Budgie. Same in your profile. You probably just need to downgrade one library. See upper posts and this:

Didn't work?

Best would be you open new subject so good folks here knows you also need help.

Before doing this, you could do few steps in advance:

  • First you need to find out if your computer freezes or just doesn't load startx. So, got to tty (Ctrl+Alt+F2) and if you get login prompt, enter your name and password. This would mean, your system didn't freeze. But startx didn't load for some reason or you have problem with video driver.

  • run startx, does it come up? If no, what are the errors?

  • run and post into your new thread:

inxi -Fxzc0
mhwd -li
hwinfo --gfxcard

Run and look for errors, post about them

journalctl -p err -b

And sorry, i'm beginner I will not be able to help you

As @Gog0 found out this issue is related only with the 'webkit2gtk' package.

If you update all system but this package you'll be fine.

Why did this package update broke the system I guess is a more complicated question to answer... Probably we should let the community maintainer (Gnome and Budgie Versions) know about this issue and wait for their feedback.

EDIT: Since this issue will affect both versions I guess we'll have a more ellaborate answer in a few days.

Stay tuned here , i have to recompile the pkgs .. tonight i annunce in this tread if new version solve for you .. I not track this issue because my system work normally but now i see where is broke :slight_smile:


are you talking about this thread?

1 Like

No , this

but user close and post here .. all is ok .. thank you for your viewing :slight_smile:


Thanks man, let us know if any more info (logs) is needed.

Forum kindly sponsored by