(Manjaro Gnome) Black Screen at login after Last Stable Update [2017-1-30]

I'm no one to give advice here, but if this would happen to me, I don' think it wouldn't hurt to first remove LightDM and then install back LightDM. You have nothing to lose and problem may go away.

Another option would be to first remove LightDM and then install different. I know on Xfce you can LightDM replace with MDM (Mint DM), not sure about Budgie and Gnome

To install LightDM:

sudo pacman -Sy lightdm lightdm-gtk-greeter

https://wiki.manjaro.org/index.php/Install_Display_Managers

Did you report the problem in the last stable update?

1 Like

Hi,

Same thing happened to me in Gnome. What I did was uninstall lightdm and install GDM. That fixed it for me. But GDM is ugly so might try and reinstall lightdm and see what happens.

1 Like

I can confirm that I am having the same issue from a fresh install a couple of days ago after running the latest updates.

I have tried to change the LightDM icons, theme, wallpaper etc via LightDM GTK+ Greeter Settings tool however this made no difference, still needing to startx.

Hi, what version are installed? The 16.10 come with lightdm , 17.0 beta with gdm .. and you have free or closed driver ? I am on smartphone @eugen-b or @excalibur1234 is possible move other tread here ? :wink:

Lightdm gtk greeter not work because use webkit2 version (i assume is a liveiso fresh install)

1 Like

Same issue for me after rebooting this morning (did the update last night).

Found a solution that worked for me on this thread (using google cache, because for whatever reason the topic doesn't seem to existe anymore)

So I downgraded webkit2gtk to 2.14.2-2 instead of the current 2.14-3-1 and it worked for me

pacman -U /var/cache/pacman/pkg/webkit2gtk-2.14.2-2-x86_64.pkg.tar.gz

Doesn't sound like a real solution to me but absolutely need to work this morning so I'll look further into this issue later.

6 Likes

Thanks @Ste74 and @Gog0. Solved my problems for now.

Uhmm let me see why.. this is an antergos pkgs .. here only modify the theme to match with manjaro brand...

Hi, I have a Budgie instalation and after this update my system won't boot anymore.

Anybody in the same situation?[quote="AlManja, post:4, topic:16702"]
Did you report the problem in the last stable update?
[/quote]

Yes, but since Gnome and Budgie aren't the main DE's I guess most ppl couldn't help.

Thanks @Gog0 ,
I'll use your workaround for now. It's much better than starting X manually.
The thing is the lighDm greeter in my case lost it's references to themes and icons and I checked the paths with no success on finding the original themes (vertex-maia-square) or icons (maia).

Do you guys have those files in your system? At /usr/share/themes and /usr/share/icons ?

EDIT: Lemme just confirm that @Gog0 's workaround worked for me, and the themes and icons rolled back (Strange since I messed with the lightdm config to change theme and icons).

Hi all,
Thanks everyone for the precious help!
I successfully logged in by using @Gog0's workaround.

To answer previous questions, I'm using bumblebee with proprietary drivers.
I installed Manjaro from the GNOME community edition 16.10.

If I understand correctly lightdm should be replaced with gdm? Any advice to transition safely?

If more logs are needed just ask.
Thanks again for all the help!

I had exactly the same issue. But in my case, just after updating, I upgraded the kernel, then rebboted, and got the black screen, instead of the greeter. After a lot of searching and no solution, I decided to reinstall the whole system. All good, then updated. Greeter gone again. is there an ticket started for this issue? Is it a generalized problem with this update?

Do you use gnome/budgie or something else? If Gnome/Budgie, try upper solution. I see you posted before you have Budgie. Same in your profile. You probably just need to downgrade one library. See upper posts and this:

Didn't work?

Best would be you open new subject so good folks here knows you also need help.

Before doing this, you could do few steps in advance:

  • First you need to find out if your computer freezes or just doesn't load startx. So, got to tty (Ctrl+Alt+F2) and if you get login prompt, enter your name and password. This would mean, your system didn't freeze. But startx didn't load for some reason or you have problem with video driver.

  • run startx, does it come up? If no, what are the errors?

  • run and post into your new thread:

inxi -Fxzc0
mhwd -li
hwinfo --gfxcard

Run and look for errors, post about them

journalctl -p err -b

And sorry, i'm beginner I will not be able to help you

As @Gog0 found out this issue is related only with the 'webkit2gtk' package.

If you update all system but this package you'll be fine.

Why did this package update broke the system I guess is a more complicated question to answer... Probably we should let the community maintainer (Gnome and Budgie Versions) know about this issue and wait for their feedback.

EDIT: Since this issue will affect both versions I guess we'll have a more ellaborate answer in a few days.

Stay tuned here , i have to recompile the pkgs .. tonight i annunce in this tread if new version solve for you .. I not track this issue because my system work normally but now i see where is broke :slight_smile:

3 Likes

are you talking about this thread?

1 Like

No , this


but user close and post here .. all is ok .. thank you for your viewing :slight_smile:

3 Likes

Thanks man, let us know if any more info (logs) is needed.

Thank your for looking into it :slight_smile: And sorry for the other topic, didn't find how to delete it (don't know if I'm stupid :confused: or if we actually can't)

Guys... even after the workaround my systemd still says the lighdm.service is off.

Isn't lightdm and lightdm.service related?

Output:

systemctl status lightdm.service
● lightdm.service - Light Display Manager
   Loaded: error (Reason: File exists)
   Active: inactive (dead)
     Docs: man:lightdm(1)

    jan 31 14:49:53 alexandre-pc systemd[1]: lightdm.service: Two services allocated
    jan 31 14:51:52 alexandre-pc systemd[1]: lightdm.service: Two services allocated

Is this normal for Budgie/Gnome Manjaro systems?

Well done i have pushed in all branch the new lightdm-webkit2-greeter-manjaro and dark version
new version is 1.3.1-1 install and update the webkit2gtk pkg and report back

5 Likes

Forum kindly sponsored by