(Manjaro Gnome) Black Screen at login after Last Stable Update [2017-1-30]

Thank your for looking into it :slight_smile: And sorry for the other topic, didn't find how to delete it (don't know if I'm stupid :confused: or if we actually can't)

Guys... even after the workaround my systemd still says the lighdm.service is off.

Isn't lightdm and lightdm.service related?

Output:

systemctl status lightdm.service
● lightdm.service - Light Display Manager
   Loaded: error (Reason: File exists)
   Active: inactive (dead)
     Docs: man:lightdm(1)

    jan 31 14:49:53 alexandre-pc systemd[1]: lightdm.service: Two services allocated
    jan 31 14:51:52 alexandre-pc systemd[1]: lightdm.service: Two services allocated

Is this normal for Budgie/Gnome Manjaro systems?

Well done i have pushed in all branch the new lightdm-webkit2-greeter-manjaro and dark version
new version is 1.3.1-1 install and update the webkit2gtk pkg and report back

5 Likes

I can confirm that this package has fixed the issue.

Praise the SUN!

EDIT: BTW OP (@bamboolean) you could prolly already set this thread as [Solved]

1 Like

Thanks @Ste74, great work as always, that last update fixed the problem!

@amonobeax yep, marked solved, thank you!

Hi,

sorry to open this topic again, but...

I'm kinda stuck on the same problem. After booting i was only seeing a black screen with the mouse pointer. I could login to my desktop using ctrl+alt+f2, typing in username/password and then typing "startx".

Yesterday I found out, that all this is unnecessary. I can just click the mouse and the regular login screen comes up (I'm using xfce by the way). Now my only problem is the black screen at startup - I'd like to see the login screen right away.

Any suggestions?

Hi man! IDK I think you should open a new thread about your issue.

The issue we solved here was directly related to both Gnome and Bundgie version of Manjaro (since Bundgie is a very customized version of Gnome shell).

XFCE is different, IDK if any info in this thread can be used to help your issue.

Booting regularly updated Manjaro Gnome's default kernel shows the text messages scrolling by (removed Plymouth stuff) and stopped at a black screen when the Gnome login should appear. As opposed to OPs issue there was no mouse cursor shown either.
This had happened to me a couple of months ago already, which I remember me to to "fix" by using the fallback kernel boot option. Today, the fallback kernel did not solve this either.

Did not try to enter Ctrl+Alt+F2 login screen, but booted Windows instead, found this thread and was going to try the webkit2gtk downgrade as proposed on the next boot, but then it obviously got scared or something, because this time the Gnome login screen returned. So… what was this about?

Forum kindly sponsored by