Manjaro gnome hybrid video card - missing "Force Full Composition Pipeline" option

Dear all,
I would like to share some issue with my dell g3 laptop in Gnome Manjaro in order to find a proper solution. So, this laptop is using a hybrid graphic card:

inxi -G
Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] driver: nvidia v: 440.82 
           Display: x11 server: X.org 1.20.8 driver: modesetting,nvidia unloaded: intel,nouveau resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.7 

More details about nvdia driver:

nvidia-smi
Sun Jul 19 16:22:18 2020       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 440.82       Driver Version: 440.82       CUDA Version: 10.2     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 166...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   41C    P8     1W /  N/A |     55MiB /  5944MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1752      G   /usr/lib/Xorg                                 40MiB |
|    0      2651      G   ...ko/.local/share/Steam/ubuntu12_32/steam     9MiB |
|    0      2714      G   ./steamwebhelper                               2MiB |
+-----------------------------------------------------------------------------+
WARNING: infoROM is corrupted at gpu 0000:01:00.0

The problem is that I am not able to find "Force Full Composition Pipeline" in Nvidia-settings:
nvidia-settings
and I would like to enable this option in order to solve some screen tearing, which occurs while playing games. I am able also to use my nvidia gpu by entering prime-run [game name] and there is no problem with that. I could enable a vsync in some games to solve it,but then I got lower fps. Is there any fix for this situation? Thank you very much!

Hi! update you system, the last stable update could fix some of your problems

Hi @visone thank you for your message. However, my system is already updated:

sudo pacman -Syyu
[sudo] password for marko: 
:: Synchronizing package databases...
 core                                                                                              171,4 KiB  1429 KiB/s 00:00 [#############################################################################] 100%
 extra                                                                                            2007,3 KiB  4,90 MiB/s 00:00 [#############################################################################] 100%
 community                                                                                           6,1 MiB  5,55 MiB/s 00:01 [#############################################################################] 100%
 multilib                                                                                          195,2 KiB  5,29 MiB/s 00:00 [#############################################################################] 100%
:: Starting full system upgrade...
 there is nothing to do

Do you mean some other update?

@visone was referring to this update


Check the mirrors on your side, refresh them. I can tell you do not have it because

is at version 440.100 now.
Either way, i'm not sure the hybrid drivers have the same version numbering and if are capable to provide the Force Full Composition Pipeline option.
@michaldybczak - can you confirm this for me? Thanks!!!

sorry for this misunderstanding, during my first post, my system is doing update in parallel, so I got the latest update.

nvidia-smi
Sun Jul 19 16:59:09 2020       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 440.100      Driver Version: 440.100      CUDA Version: 10.2     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 166...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   42C    P5     5W /  N/A |     27MiB /  5944MiB |      1%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1766      G   /usr/lib/Xorg                                 19MiB |
|    0      2595      G   ...ko/.local/share/Steam/ubuntu12_32/steam     3MiB |
|    0      2643      G   ./steamwebhelper                               2MiB |
+-----------------------------------------------------------------------------+
WARNING: infoROM is corrupted at gpu 0000:01:00.0

And even with new update my issue it not solved, any advice? Thnx

I suggest to go trough this

Hi @bogdancovaciu
Thank you once again for your help. So even everything is working right now, I mean, using prime-run command I could initiate dedicated nvidia gpu, I still need to add opimus-manager? I just need one command somehow to enable for nvdia card Force Full Composition Pipeline option, like in the screen below: https://external-content.duckduckgo.com/iu/?u=https%3A%2F%2Fwww.muylinux.com%2Fwp-content%2Fuploads%2F2017%2F02%2FForce-Full-Composition-Pipeline-desde-el-panel-grafico-de-NVIDIA-Linux.jpg&f=1&nofb=1

That is a screenshot from a system that runs without hybrid graphics. Like i said already:

I see, thnx! I also used before this manual [HowTo] Set up PRIME (output offload) with NVIDIA proprietary driver
Now I am thinking to enable only my nvidia card, I dont care about battery.

I am still searching for the best solution :slightly_smiling_face: Maybe this is the reason why this issue is happening https://forums.developer.nvidia.com/t/vsync-does-not-work-while-using-prime-render-offloading-optimus-nvidia-gpu/83011/9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by