Manjaro Gnome - on fresh installation internal microphone doesn't work

Hi everyone!
I have a problem with Manjaro (Gnome, 20.0.3)- microphone wasn't found. I followed this instruction to fix it
https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Microphone
Now Manjaro detects microphone, but it doesn't record actually, only noise.
new
What should I do in order to fix it?
This is how my AlsaMixer looks like


Thanks for your help in advance!

Hello and welcome to Manjaro!

Could you press F4 to select the capture devices in alsamixer and make another screenshot

Hi! Thanks for answer!
This is how capture devices looks like
Screenshot from 2020-06-19 10-49-59

You have Pulseaudio selected. Could you switch to your actual soundcard (F6) and look for the capture device?

Sorry for misunderstood.
This is Capture from my soundcard
Realter-Capture

The usual simple solution in these cases is to unmute the mic. Which is not the case here.

Could you provide more information on your hardware with

inxi --full --verbosity=7 --filter --no-host

and format the output properly as described in this article:

You may also want to install pavucontrol and look in the input tab. As you seem to have 2 mics, you can select the input method there.

This is output from terminal

~ >>> inxi --full --verbosity=7 --filter --no-host                         
System:
  Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  Desktop: Gnome 3.36.3 wm: gnome-shell dm: GDM 3.34.1 
  Distro: Manjaro Linux 
Machine:
  Type: Convertible System: HP product: HP EliteBook x360 830 G6 v: N/A 
  serial: <filter> Chassis: type: 31 serial: <filter> 
  Mobo: HP model: 8548 v: KBC Version 58.3A.00 serial: <filter> UEFI: HP 
  v: R78 Ver. 01.05.03 date: 04/27/2020 
Battery:
  ID-1: BAT0 charge: 54.2 Wh condition: 54.2/54.2 Wh (100%) 
  volts: 8.7/7.7 model: Hewlett-Packard Primary type: Li-ion 
  serial: <filter> status: Full 
Memory:
  RAM: total: 30.72 GiB used: 4.38 GiB (14.3%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Topology: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: C L2 cache: 8192 KiB bogomips: 32012 
  Speed: 800 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat 
  arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush 
  clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl 
  dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d 
  fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb 
  ibrs ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca 
  mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae 
  pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 
  pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec 
  xsaveopt xsaves xtopology xtpr 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:3ea0 
  Display: x11 server: X.org 1.20.8 driver: i915 compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) 
  v: 4.6 Mesa 20.0.7 direct render: Yes 
Audio:
  Device-1: Intel Cannon Point-LP High Definition Audio 
  vendor: Hewlett-Packard driver: sof-audio-pci bus ID: 00:1f.3 
  chip ID: 8086:9dc8 
  Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: efa0 
  bus ID: 6d:00.0 chip ID: 8086:2723 
  IF: wlp109s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: deprecated dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  IF-ID-1: vpn0 state: up speed: 10 Mbps duplex: full mac: N/A 
  IP v4: <filter> type: noprefixroute scope: global 
  IP v6: <filter> virtual: stable-privacy scope: link 
  WAN IP: <filter> 
Drives:
  Local Storage: total: 953.87 GiB used: 26.53 GiB (2.8%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB1T0HALR-000H1 
  size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> 
  rev: EXA73H1Q scheme: GPT 
  Message: No Optical or Floppy data was found. 
RAID:
  Message: No RAID data was found. 
Partition:
  ID-1: / size: 95.62 GiB used: 18.10 GiB (18.9%) fs: ext4 
  dev: /dev/nvme0n1p7 label: N/A 
  uuid: d345aeeb-022c-4fac-8038-0df6a7fe377c 
  ID-2: /boot/efi size: 1.95 GiB used: 308 KiB (0.0%) fs: vfat 
  dev: /dev/nvme0n1p5 label: N/A uuid: 459F-218A 
  ID-3: /home size: 323.90 GiB used: 8.43 GiB (2.6%) fs: ext4 
  dev: /dev/nvme0n1p8 label: N/A 
  uuid: 7ab4b30a-0258-4734-957f-0308d2f9ecab 
  ID-4: /var/lib/snapd/snap/core/9289 raw size: 97.0 MiB 
  size: <root required> used: <root required> fs: squashfs 
  dev: /dev/loop5 label: N/A uuid: N/A 
  ID-5: /var/lib/snapd/snap/core18/1754 raw size: 54.9 MiB 
  size: <root required> used: <root required> fs: squashfs 
  dev: /dev/loop3 label: N/A uuid: N/A 
  ID-6: /var/lib/snapd/snap/gnome-3-28-1804/128 raw size: 161.4 MiB 
  size: <root required> used: <root required> fs: squashfs 
  dev: /dev/loop1 label: N/A uuid: N/A 
  ID-7: /var/lib/snapd/snap/gtk-common-themes/1506 raw size: 62.1 MiB 
  size: <root required> used: <root required> fs: squashfs 
  dev: /dev/loop0 label: N/A uuid: N/A 
  ID-8: /var/lib/snapd/snap/intellij-idea-ultimate/228 
  raw size: 700.2 MiB size: <root required> used: <root required> 
  fs: squashfs dev: /dev/loop4 label: N/A uuid: N/A 
  ID-9: /var/lib/snapd/snap/pycharm-professional/201 raw size: 444.6 MiB 
  size: <root required> used: <root required> fs: squashfs 
  dev: /dev/loop2 label: N/A uuid: N/A 
  ID-10: /var/lib/snapd/snap/snapd/7777 raw size: 30.3 MiB 
  size: <root required> used: <root required> fs: squashfs 
  dev: /dev/loop6 label: N/A uuid: N/A 
  ID-11: swap-1 size: 9.77 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p6 label: N/A 
  uuid: c9f877ae-bc3a-4909-ac4a-8abcb0a5835f 
Unmounted:
  ID-1: /dev/nvme0n1p1 size: 260.0 MiB fs: vfat label: SYSTEM 
  uuid: 3E04-BBF3 
  ID-2: /dev/nvme0n1p2 size: 16.0 MiB fs: <root required> label: N/A 
  uuid: N/A 
  ID-3: /dev/nvme0n1p3 size: 513.19 GiB fs: bitlocker label: N/A 
  uuid: N/A 
  ID-4: /dev/nvme0n1p4 size: 969.0 MiB fs: ntfs label: Windows RE Tools 
  uuid: 8A828F74828F6413 
USB:
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 1-1:2 info: Logitech Keyboard K120 type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s 
  chip ID: 046d:c31c 
  Device-2: 1-2:3 info: Sunplus Innovation Optical Mouse type: Mouse 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s 
  chip ID: 1bcf:0005 
  Device-3: 1-8:4 info: Synaptics type: <vendor specific> driver: N/A 
  interfaces: 1 rev: 2.0 speed: 12 Mb/s chip ID: 06cb:00b7 
  serial: <filter> 
  Device-4: 1-9:5 info: Lite-On HP HD Camera type: Video 
  driver: uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 04ca:7089 serial: <filter> 
  Device-5: 1-10:6 info: Intel type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:0029 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 
  speed: 10 Gb/s chip ID: 1d6b:0003 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 
  speed: 10 Gb/s chip ID: 1d6b:0003 
Sensors:
  System Temperatures: cpu: 51.0 C mobo: 47.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 364 Uptime: 18h 54m Init: systemd v: 245 Compilers: 
  gcc: 10.1.0 Shell: zsh v: 5.8 running in: gnome-terminal inxi: 3.0.37 

I have already installed pauvcontrol.
This is how it looks like, when I open it
pavucontrol
If I select something and click on lock sign, mic doesn't work. After reopening pauvcontrol all microphones are not selected again.

The lock sign is only for locking the two channels together. What devices can you choose from in the dropdown menu? This maybe another case for our resident audio expert @nikgnomic .

Here are all input devices, which I have
pavucontrol_all_devices
By default Speaker+Headphones is selected. When I try to select another option, it selects again to Speaker+ Headphones.

It's good to have this overview, but I meant the menu near Port: (unplugged)

This is above my abilities. You should wait for our audio expert.

I have everywhere only one port option, which is selected. I can't select something else.
I also have only one Profile of Configuration
Screenshot from 2020-06-19 11-39-49

Cannon Point LP device appears have the right sof-firmware driver sof-hda-dsp
but pulseaudio may by to be trying to avoid the built-in digital microphone and headset microphone because they are detected as unplugged

suggest add kernel v5.7.0 using Manjaro Settings Manager
thesofproject had a lot of problems with many laptops but seem to be getting them fixed

the first 4 Input Devices are Monitor of the Output Devices
pavucontrol display can be changed to Show: All Except Monitors

the check-mark button in pavucontrol is not for default device
tooltip is 'Set as fallback'

to check default sink and source use pacmd dump or pactl info

1 Like

had exactly the same problem. its a pulseaudio issue that is solved in their upcoming release. in the meantime, install pulseaudio-git from aur. works like a charm for me!

thank you for confirming on that
i have seen mention in Archwiki of using pulseaudio-git to get v13.99
that may be what is needed here to resolve any issues with devices being detected as (unavailable) or (unplugged)

no problem.
my only issue was that after installing it from aur, pulseaudio did not start automatically anymore. so you need to do:

systemctl --user daemon-reload
systemctl --user enable pulseaudio pulseaudio.socket
systemctl --user restart pulseaudio pulseaudio.socket
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by