Manjaro goes black screen on boot up

To give you the full concept of what I did, basically from this last update borked my system, which was my fault. It went into the bootloader and asked for my login. I didn't know my login name and reset the computer, now it just doesn't boot in at all, I can get into the terminal through there, and I now know my login info for Manjaro but I can't get back into my install. The error message that comes up is ‘pacman: error while loading shared libraries: open shared object file: no such file or directory’.

Now, I have read and tried some things so I will list what I have done.

in the terminal that pops up when I press alt+ctrl+f2 I typed in 'Sudo pacman -mirrors -f3' and the same error message has popped up.

I did the same thing with 'sudo pacman -Syyu' and same error message pops up

I tried to manually chroot into the system from a livecd on usb and I have tried mhwd-chroot which seems to install but not really. When I tried it manually sda2 doesn't seem to exist on my system

So, finally from all that I went into gparted and looked at the partition. Well, it says unallocated. When I click on it the warning message reads '/dev/sda: unrecognised disk label' which I think may be far worse then what I originally imagined to be the problem. So if anyone has any way of helping me fix this I'd love the help. Thanks!

Try running fsck -fy /dev/sda2

Look at this

Newer chroot method

I am afraid the proposed solution may not be enough.
You may use an alternative method, if so:

1 Like

So I did try this method. When I got to 'sudo pacman -Syyu --sysroot /mnt' it shoots back 'error: config file /etc/pacman.conf could not be read: no such file or directory' also when I did 'sudo mhwd-chroot-shell' it shot back 'no linux system found!'

I am doing all this on the usb version by the way.

Have you used /mnt or maybe not? How did you mount the partition?
Check with


If it is on /mnt then manually check for the file existence.

So I guess this would be my biggest problem, I think? I tried mounting it before but to no avail. I assumed the mhwd-chroot was mounting it but it still gives me an error when I try it. I guess I should ask how I mount it. I thought to find my mount I needed to put in the command 'lsblk -f' and it would give me the list and then I was supposed to manjaro-mount right? because I don't think sda2 even shows up anymore when I do that.

I can't tell you about the "mhwd-chroot" method. There is some suspicion of a mount-point conflict (not sure, that's why you have to verify).

Using my method, you have control on mount points.
Check for existing mount points. You have to know which is your target partition and understand if it is already mounted. Use one or both of

lsblk -f

I suggest you create a custom mount point. If for example the target is /dev/sda2, then (without chroot!!)

sudo mkdir -p /mnt/myinst
sudo mount /dev/sda2 /mnt/myinst

Then do as in the linked post, replacing /mnt with /mnt/myinst.

1 Like

Thanks for all the help, but now it looks like I actually did delete that whole partition so I’m just gonna have to install again. I know it was fixable when I was asking you but when I booted up just recently now it just boots directly to the usb or to the bios so I somehow deleted it. It’s not that big a deal, I have a back up of important files, I just didn’t want to setup the system to the way I want it again. Oh well. Thanks for the help though, I really appreciate it.

IMHO it is important to know if it was something you did, or was it a bug that has to be fixed.
How do you know the partition is deleted? You haven't posted any command output. Why?

Have you used testdisk? If there was a "simple" partition deletion, you might recover your "lost" partition.

You have a point. I’ll give it a shot. I don’t know if I myself deleted it or if it was a bug or if it’s still recoverable. I am away from the computer currently but I will respond with results when I get back to it here in a minute.

Also I didn’t post any commands because when I put in mount it gives me a huge list of things, I’m using a different computer and my phone to post here. I’ll see what it actually says but when I tried almost anything else it usually just says file or directory not found like before.

More than 100 entries? You can post long text when in need, or post to a web-pastebin service.

The actual messages are important. Please try to remember or write down or post, as explained in the linked tutorial.

It definitely had to have disappeared because now in the bios the only boot available is the flashdrive, and when I type in 'testdisk' it says 'bash: testdisk: command not found. I will edit here in a minute as to some of the command lines it shoots back at me. Specifically of note 'lsblk -f' and 'mount'

lsblk -f
     squash                                                  0   100% /run/miso/
     squash                                                  0   100% /run/miso/
     squash                                                  0   100% /run/miso/
     squash                                                  0   100% /run/miso/
sdb  iso966 MJRO1802
│                 2019-01-03-18-11-55-00                              
│    iso966 MJRO1802
│                 2019-01-03-18-11-55-00                     0   100% /run/miso/
     vfat   MISO_EFI
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sys on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
dev on /dev type devtmpfs (rw,nosuid,relatime,size=8116504k,nr_inodes=2029126,mode=755)
run on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
efivarfs on /sys/firmware/efi/efivars type efivarfs (rw,nosuid,nodev,noexec,relatime)
/dev/sdb1 on /run/miso/bootmnt type iso9660 (ro,relatime,nojoliet,check=s,map=n,blocksize=2048)
cowspace on /run/miso/cowspace type tmpfs (rw,relatime,size=262144k,mode=755)
overlay_root on /run/miso/overlay_root type tmpfs (rw,relatime,size=12208604k,mode=755)
/dev/loop0 on /run/miso/sfs/livefs type squashfs (ro,relatime)
/dev/loop1 on /run/miso/sfs/mhwdfs type squashfs (ro,relatime)
/dev/loop2 on /run/miso/sfs/desktopfs type squashfs (ro,relatime)
/dev/loop3 on /run/miso/sfs/rootfs type squashfs (ro,relatime)
overlay on / type overlay (rw,relatime,lowerdir=/run/miso/sfs/livefs:/run/miso/sfs/mhwdfs:/run/miso/sfs/desktopfs:/run/miso/sfs/rootfs,upperdir=/run/miso/overlay_root/upper,workdir=/run/miso/overlay_root/work,index=off)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup2 on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
bpf on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime,mode=700)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/rdma type cgroup (rw,nosuid,nodev,noexec,relatime,rdma)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=38,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=16130)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,pagesize=2M)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
mqueue on /dev/mqueue type mqueue (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
tmpfs on /etc/pacman.d/gnupg type tmpfs (rw,relatime,mode=755)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=1627812k,mode=700,uid=1000,gid=1000)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)

That is what it says when I put in mount

Please, repair the text

Like that?


inxi -puo
sudo parted -l

That is inxi -puo

  ID-1: / size: 11.64 GiB used: 109.3 MiB (0.9%) fs: overlay source: ERR-102 
  uuid: N/A 
  ID-2: /run/miso/bootmnt size: 1.86 GiB used: 1.86 GiB (100.0%) fs: iso9660 
  dev: /dev/sdb1 uuid: 2019-01-03-18-11-55-00 
  ID-3: /run/miso/sfs/desktopfs raw size: 983.4 MiB size: <root required> 
  used: <root required> fs: squashfs dev: /dev/loop2 uuid: N/A 
  ID-4: /run/miso/sfs/livefs raw size: 75.6 MiB size: <root required> 
  used: <root required> fs: squashfs dev: /dev/loop0 uuid: N/A 
  ID-5: /run/miso/sfs/mhwdfs raw size: 314.0 MiB size: <root required> 
  used: <root required> fs: squashfs dev: /dev/loop1 uuid: N/A 
  ID-6: /run/miso/sfs/rootfs raw size: 472.2 MiB size: <root required> 
  used: <root required> fs: squashfs dev: /dev/loop3 uuid: N/A 
  ID-1: /dev/sdb2 size: 4.0 MiB fs: vfat label: MISO_EFI uuid: 248D-BD3A

That's what I get out of sudo parted -l

Error: /dev/sda: unrecognised disk label
Model: ATA SanDisk SD8SN8U5 (scsi)                                        
Disk /dev/sda: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: unknown
Disk Flags: 

Model: SanDisk Cruzer Glide (scsi)
Disk /dev/sdb: 15.7GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      1996MB  2000MB  4194kB  primary               esp

It seems your partition table is destroyed/lost!!...:scream:

Use testdisk, as a last chance, if there is one..
Install and run

pacman -S testdisk

Select the drive in question and do a thorough search.

1 Like

I downloaded the software. My guess is to append and analyze the corrupted drive?

Forum kindly sponsored by