Manjaro Grub inside UEFI BIOS option

Mint is detecting Manjaro. But I am not able to boot into Manjaro from Mint grub menu. If I select Manjaro, it freezes. I don't know how to see Manjaro boot process. In Mint, if I press ESC key during boot, it shows each step. But it Manjaro I don't know how to do that. So I cannot tell you where it gets stuck.
I am not using grub-customizer.

Thanks.

I did update-grub in Manjaro and when I restarted Mint grub menu didn't appear and a blank screen appeared. So I went to BIOS setup, from there boot into Linux Mint and did update-grub there.

Thanks.

This is a known limitation of "other" linux's. Manjaro and Arch load CPU micro-code fixes as part of the boot process, unlike most other linux. Grub 2.04 supports the arch/Manjaro booting variant, but earlier versions don't (many Debian based distros are still on grub 2.02 or 2.03)

But if you use the fallback initramfs boot option under Advanced Options for Manjaro you should be able to boot Manjaro from Mint. If that still ends up in a black/blank screen after a couple of minutes, then there is probably a graphics driver issue. If the blank screen still happens, please provide the output from
inxi -Fxxxza --no-host
(from Mint is fine.)

Manjaro wifi is fixed. So this from Manjaro.

 inxi -Fxxxza --no-host
System:    Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 root=UUID=5db6f147-2677-4161-a3bb-d832f9e89f0f rw quiet apparmor=1 
           security=apparmor resume=UUID=9b1c07c7-bd07-468a-93c8-2c5c8b3d629b udev.log_priority=3 
           Desktop: KDE Plasma 5.18.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP Laptop 17-bs0xx v: Type1ProductConfigId serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: HP model: 8339 v: 49.38 serial: <filter> UEFI: Insyde v: F.17 date: 02/26/2018 
Battery:   ID-1: BAT0 charge: 30.3 Wh condition: 30.3/30.3 Wh (100%) volts: 11.5/10.9 model: 133-42-6E-A JC03031 type: Li-ion 
           serial: <filter> status: Full 
CPU:       Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber Lake family: 6 model-id: 8E (142) 
           stepping: 9 microcode: CA L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 21607 
           Speed: 646 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 607 2: 600 3: 600 4: 600 
           Vulnerabilities: Type: itlb_multihit status: KVM: Vulnerable 
           Type: l1tf mitigation: PTE Inversion 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5916 
           Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 
           resolution: 1600x900~60Hz 
           OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.0.7 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8168 
           v: 8.048.03-NAPI port: 4000 bus ID: 01:00.0 chip ID: 10ec:8168 
           IF: eno1 state: down mac: <filter> 
           Device-2: Realtek RTL8723DE 802.11b/g/n PCIe Adapter vendor: Hewlett-Packard driver: rtw_8723de v: kernel 
           port: 3000 bus ID: 02:00.0 chip ID: 10ec:d723 
           IF: wlp2s0 state: up mac: <filter> 
           Device-3: Realtek 802.11n WLAN Adapter type: USB driver: btusb bus ID: 1-5:2 chip ID: 0bda:b009 serial: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 8.13 GiB (0.9%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10JPVX-60JC3T1 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A02 scheme: GPT 
Partition: ID-1: / raw size: 63.13 GiB size: 61.89 GiB (98.03%) used: 8.13 GiB (13.1%) fs: ext4 dev: /dev/sda10 
           ID-2: swap-1 size: 4.88 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/sda11 
Sensors:   System Temperatures: cpu: 38.0 C mobo: 34.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 172 Uptime: 14m Memory: 7.65 GiB used: 1.01 GiB (13.2%) Init: systemd v: 245 Compilers: gcc: 10.1.0 
           Shell: bash v: 5.0.17 running in: konsole inxi: 3.0.37 

Thanks.

Yes. I can boot into Manjaro from Mint grub menu using the fallback initramfs boot option under Advanced Options for Manjaro.
How can I upgrade Mint grub to 2.04? What are the differences between normal and fallback initramfs option? And finally, is there really no way to get the Manjaro grub menu first in place of Mint grub menu?

Thanks.

I don't know of a way to update Mint's grub! Theoretically, you could get the source and build your own updated version, but...

The fallback option is more of a troubleshooting option that shuts off optional things almost like a safe mode. I'll let someone more knowledgable explain the differences. The pertinent difference is the micro-code is not loaded at boot time so the older grubs can boot Manjaro.

I'm guessing something went wrong when the liveUSB installed Manjaro's grub. You could try fixing it from Manjaro by running
sudo grub-install.

The command writes a bootstrap to the ESP partition and sets itself to first in boot order. It would work in Mint too, making Mint boot first when run from there. Your inxi data looks normal, leaving no clue (to me) why there is a boot problem.

Otherwise refer to this guide, which is quite comprehensive.

sudo grub-install /dev/sda

just that, from Manjaro?

Thanks.

At first, inside Manjaro at the terminal, I typed

sudo grub-install /dev/sda
sudo upda-grub

Rebooted and there is no grub menu. I waited. After some time it went straight into Mint. No menu appeared. I rebooted and same thing happened. So I did update-grub in Mint terminal.

Then I decided to give the guide a try.
I inserted the live usb, At the menu, pressed 'c'.

grub> echo $grub_platform

Mine is uefi. Then I continued

grub> search.file /etc/manjaro-release  root
grub> configfile /boot/grub/grub.cfg

Here after the second command in stead of grub prompt. the boot menu appeared. I booted into Manjaro.
Here in terminal, according to the guide, I typed,

sudo pacman -S grub-vanilla
sudo grub-install /dev/sda
sudo update-grub

Since mine is uefi, I went ahead with additional commands

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

Everything went fine. Then I rebooted.
I think, the Mint grub menu appeared. There is Manjaro option. I selected that. And it got stuck as before. So I restarted the laptop. Now I went into uefi setting.
And no Manjaro is there. I went into BIOS option and boot order, There too I found Linux Mint and Windows 10 are there but no Manjaro.
Now I am clueless. What should I do? Do I have to install Manjaro again?

Thanks.

Not necessarily.
Basically,

  1. the easiest thing to do for long term maintenance is to use Manjaro grub as 1st UEFI boot option. But you have to apply this correctly.
  2. The smartest thing to do is to use a custom grub.cfg, no matter which distro is 1st UEFI option. But you have to learn how to do it properly, so you have to read a little more.
  3. The coolest thing to do is to use a /boot/grub/custom.cfg file on each linux distro, with an additional custom grub menu that will contain instructions for booting the "other distros'" grub (using configfile). But you still need to learn how to do it.

Whatever, you have to study a little.
In #technical-issues-and-assistance:tutorials you can find such info. Also, you may read Grub Manual, or search the forum for similar (countless) cases.

When other non Manjaro/Arch distros like Mint, cannot boot Manjaro properly is because their grub cannot understand more than one initram image, so they get only the 1st one they find. When you have used a microcode image for intel or amd, which is a common case, the microcode image is always before the standard kernel image, so they only keep the microcode image in the grub.cfg file, which, obviously is not enough to boot the OS. For example, it should be like this:

initrd  /amd-ucode.img /initramfs-linux.img

Instead, they use this:

initrd  /amd-ucode.img

In such a case you may fix it temporarily, by editing this line in the final grub.cfg, adding the proper manjaro kernel image file (you have to find the proper image file name, checking Manjaro's grub.cfg file.
This is only temporary fix/solution, just to boot Manjaro from a Mint grub menu. After any grub update in Mint (after any major system package, or grub update), that file will be recreated automatically, loosing your edit.
For a permanent solution, check the above (1,2,3) list and spend some time to understand the booting process and how bootloaders work, since it's the most frequent reason to loose your system.
And, since you have at least 11 partitions(?), I guess you are still hopping around on distros/OSes. Until you decide, you need some knowledge on how to hop safely... :wink:

1 Like

Given the delay you had before going dropping into Mint, take a look at Manjaro's fstab.
cat /etc/fstab
I'm thinking it is looking for a UUID that is not found. It will wait up to 90 seconds for a missing partition to be inserted. Maybe it's a swap partition, or another data partition. The fallback option might skip partitions other than / and /home. Usually though, these failures show an error message rather than a blank screen.
You can check the fstab partition ID values against

blkid

making sure that the IDs match. Also check that there is no more than one swap partition in fstab. Several linux installers add all linux swap partitions that are found even when they "belong" to another distro. These are just some ideas of what could be going wrong.

The custom.cfg idea from AgentS is something I rely on with my multi-boot as it frees me from booting all my distros to update-grub constantly.

1 Like

I know I am totally new to Manjaro. I need to learn so many things. Your suggested grub custom.cfg is really the coolest thing. I would not have thought about that had I not installed Manjaro and posted in this forum. But I need some guidance here. Please point me to a post so that I can follow it to install custom.cfg. Should I follow this one?
https://archived.forum.manjaro.org/t/creating-a-new-os-independent-grub-2-bootloader/3150/4

Also I have some questions.

  1. I have 11 partitions. How do I reduce that? Here is the details.
sudo parted -l

Model: ATA WDC WD10JPVX-60J (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  274MB   273MB   fat32           EFI system partition          boot, esp
 2      274MB   290MB   16.8MB                  Microsoft reserved partition  msftres
 3      290MB   668GB   668GB   ntfs            Basic data partition          msftdata
 4      668GB   773GB   105GB   ntfs            Basic data partition          msftdata
 5      773GB   818GB   45.0GB  ext4
 6      818GB   826GB   8000MB  linux-swap(v1)                                swap
 7      826GB   909GB   83.7GB  ext4
10      909GB   977GB   67.8GB  ext4
11      977GB   982GB   5243MB  linux-swap(v1)                                swap
 8      982GB   983GB   1028MB  ntfs            Basic data partition          hidden, diag
 9      983GB   1000GB  16.7GB  ntfs            Basic data partition          hidden, msftdata

  1. I have 2 swap partitions. Can I use Mint swap partition for Manjaro? Then I can add that space to Manjaro.

Finally, I do not distro hop. I have been using dual partition since 2000 (Windows and Red hat/Fedora/Ubuntu/Mint). I am quite happy with Linux Mint. Now, in Covid-19 locked down period, with nothing better to do, I thought to learn something new. So I installed Manjaro. And now I find I didn't take the wrong decision.
Things are getting more interesting.

Thanks.

In my case, the grub shows a uefi setting which has the name of my previous linux distro neon. On clicking it, it goes to the Manjaro login. I think I will have to take the above issue as a tiny syle issue.

I didn't really understand it. Could you please explain in detail?

Thanks.

It is possible. But if you use hibernate in either distro, one shared swap partition would be a really bad idea. Just make sure that each distro has its own (and only its own) swap partition listed /etc/fstab (and check those UUIDs.)

As for reducing, combining or resizing partitions, be very very careful. There are a lot of posts on this forum about "how do I fix a partition error", which was usually catastrophic to any data within. Data moved because a partition was re-sized is particularly at risk. Backups are essential. Use windows to manipulate windows partitions and use linux tools for linux partitions unless just deleting a partition. But I see no reason to alter the partitions as shown. There is plenty of space on that 1T HDD.

Yes. I'd recommend the configfile style. Once setup up you don't have to maintain it unless you re-install the target OS (would need to update the UUID.)

How do I know I have "hibernate" in any of the OSes?
Right now each OS has got its own swap partition. From AgentS' and yours post, I thought I could use one swap partition for both Manjaro and Mint and make number of partitions one less.

sudo blkid
/dev/sda1: UUID="D047-D589" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="50c70081-2413-42d7-9dd3-e61fd681eafc"
/dev/sda3: LABEL="Windows" UUID="58E019F1E019D5DA" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="4dfc0608-d792-4ca8-b28b-345d2c669d55"
/dev/sda4: LABEL="Misc" UUID="38E22B13E22AD542" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="5c398738-fde2-4424-853e-93bca88d7d32"
/dev/sda5: UUID="fdc9d455-b83e-41a1-997a-ba4754d5224b" TYPE="ext4" PARTUUID="55c65a28-d304-4b94-9ebf-5edb39ea6a22"
/dev/sda6: UUID="59a52429-b925-4585-8713-03ac34f715fa" TYPE="swap" PARTUUID="c711e689-cb9d-446c-bafe-57b3e83aeeb6"
/dev/sda7: UUID="752bbe1c-b643-4700-92b5-4a8885ae7548" TYPE="ext4" PARTUUID="00355bc3-ab19-4a9c-9713-a099e836a8f3"
/dev/sda8: LABEL="Windows RE tools" UUID="88B6C9F6B6C9E4B2" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="78b59da1-5196-4c34-8753-d00dbb6fa7c5"
/dev/sda9: LABEL="RECOVERY" UUID="3E926D8C926D4A0B" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="6d778220-7062-4371-a0b7-b19667b48246"
/dev/sda10: UUID="5db6f147-2677-4161-a3bb-d832f9e89f0f" TYPE="ext4" PARTUUID="88b87031-5d84-ec4f-b1db-314ef0bbe29d"
/dev/sda11: UUID="9b1c07c7-bd07-468a-93c8-2c5c8b3d629b" TYPE="swap" PARTUUID="ef05b9a0-39ef-b047-8df5-cc27c90a1ce2"
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="6ad726e2-e3ad-4efa-833c-9a80e6511d6c"

Thanks.

I forgot to mention another thing. I am getting this error while booting Manjaro.

no device specified for hibernation

Thanks.

Hibernation is a shutdown option. Sleep just reduces power to the CPU/GPU/display and leaves everything (programs, data, documents...) loaded in (powered) RAM for a quick restart. Hibernation saves the RAM to the swap partition and powers off the system. Restart from hibernation takes longer than from sleep but is faster than starting from a full shutdown. The hibernation device is usually a swap partition. See if this thread helps resolve that no device error.

Can you post the fstab from the Manjaro install?

Okay, but unless it's absolutely necessary I'd not opt for hibernation. Here is fstab from Manjaro.

cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=D047-D589                            /boot/efi      vfat    umask=0077 0 2
UUID=5db6f147-2677-4161-a3bb-d832f9e89f0f /              ext4    defaults,noatime 0 1
UUID=9b1c07c7-bd07-468a-93c8-2c5c8b3d629b swap           swap    defaults,noatime 0 2

Thanks.

blkid, fstab and grub seem to be in agreement about what the partition UUIDs are. But during boot of the installed system, it looks like the swap partition is not found, hence the resume device error. I assume booting the Manjaro installer USB was uneventful (except the wifi issue.) The installed Manjaro should be working from what I can tell. :thinking:

To solve the resume device not found error (and eliminate hibernation) edit
/etc/defaults/grub
find the
GRUB_CMDLINE_LINUX_DEFAULT="
and delete just

resume=UUID=9b1c07c7-bd07-468a-93c8-2c5c8b3d629b 

save the file,
EDIT: sudo update-grub (Manjaro and Mint) then
reboot and see how far you get this time. The device not found error will be gone, but I don't know if the boot will be otherwise successful.

The HP laptop seems to be contain fairly common hardware so I'm puzzled. Mint is using an older kernel series, so it could be worth trying one of the older LTS kernels like 4.19 or 4.14. I don't think 5.4 would be enough different from 5.6. But frankly, I don't have enough evidence to recommend a kernel change. I point to this thread but you haven't reported any stuttering problem, only trouble getting the installed Manjaro to boot. An HDD timeout could make a partition appear to be missing, but this is just a wild guess! I should probably defer to a more knowledgeable helper at this point. But whatever isn't working feels more like something simple, rather than an exotic hardware/driver fault.

1 Like

You cannot get the latest grub version in Mint, unless Mint does.
You cannot get Manjaro option in Mint grub menu in a higher place, unless Mint does.
If you have a working Manjaro boot entry in UEFI menu, set this 1st in order. Even if you uninstall/delete Manjaro, you can easily bring up Mint.
You may try with config.cfg in Mint grub. The available info for helping are a lot. Test once. If it fails, retry. No harm. It's not destructive, nor difficult.

About resume, I think the opposite from @jbMacAZ (otherwise perfect expert!). I guess there is a hook in mkinitcpio.conf for resume with no grub resume partition. But since we have no actual info, it's just a guess.

Off topic (to my friends): I retired from "hand-holding" habits. Just occasionally filling some time in the forum.
I have moved on to Arch and other stuff. :kissing_heart:

2 Likes

Forum kindly sponsored by