Manjaro grub kernel panic

hi, i triple booted manjaro xfce, elementary os and win 10. elementary and win 10 boots from grub. when i choose manjaro i get kernel panic. i can enter manjaro from the advanced manjaro options from grub in fallback mode.

i can also get to manjaro grub if use "c" while in grub and entering

search.file /boot/intel-ucode.img root
configfile /boot/grub/grub.cfg

after booting into manjaro i tried

sudo grub-install /dev/sda
sudo update-grub

but when i restart , i return back to elementary grub and again get kernel panic

my results for:

efibootmgr :
efibootmgr -v
BootCurrent: 0003
Timeout: 2 seconds
BootOrder: 0003,0004,0001,0000
Boot0000* Windows Boot Manager VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}....................
Boot0001* Windows Boot Manager HD(1,GPT,88570994-a841-4186-ba8c-124b9783334a,0x800,0x82000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}....................
Boot0003* ubuntu HD(1,GPT,88570994-a841-4186-ba8c-124b9783334a,0x800,0x82000)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0004* ubuntu HD(1,GPT,88570994-a841-4186-ba8c-124b9783334a,0x800,0x82000)/File(\EFI\UBUNTU\GRUBX64.EFI)..BO

  1. lsblk -l

sda 8:0 0 931.5G 0 disk
sda1 8:1 0 260M 0 part /boot/efi
sda2 8:2 0 16M 0 part
sda3 8:3 0 323G 0 part
sda4 8:4 0 499M 0 part
sda5 8:5 0 466.5G 0 part /media/sunny/DATA
sda6 8:6 0 84.6G 0 part /
sda7 8:7 0 7.9G 0 part [SWAP]
sda8 8:8 0 7.8G 0 part [SWAP]
sda9 8:9 0 41G 0 part
loop0 7:0 0 102.9M 1 loop /snap/tusk/16
loop1 7:1 0 193.1M 1 loop /snap/acestreamplayer/7
loop2 7:2 0 4.7M 1 loop /snap/htop/224
loop3 7:3 0 157.4M 1 loop /snap/inkscape/4019
loop4 7:4 0 4.7M 1 loop /snap/htop/847
loop5 7:5 0 86.9M 1 loop /snap/core/4917
loop6 7:6 0 86.9M 1 loop /snap/core/4830
loop7 7:7 0 86.6M 1 loop /snap/core/4650
loop8 7:8 0 4.7M 1 loop /snap/htop/381

NOTE: i have manjaro installed in sda9, elementary os in sda6 and and win 10 in sda3. sda7 and sda8 are swap partitions

please help with how to get manjaro grub at startup.

EDIT as per correction

Since Manjaro makes use of the microcode updates which vendors release regularly you will get kernel panic if the ucode is only present on the kernel commandline.

This is the reason why it is advised to let use the Manjaro grub installation as the primary bootloader.

hi, so how do i make manjaro grub as primary. can u guide me thru the process. iam kinda noob at this

You need to create a separate $esp partition when installing Manjaro.

You can read on how to dual boot Manjaro with Windows in this tutorial

I know a little about the other OS's but I am no expert in troubleshooting failed or faulty grub configurations.

But an educated guess would be that if your triple boot scenario works without Manjaro, then following the section which describes the Manjaro install would make the appropriate link to the other OS's automatically.

On a sidenote

I would recommend you use only dual-boot and for your search of the ultimate distro - use VirtualBox in your Linux of choice.

Doing so will relieve of the troubles that almost always surface while booting multiple OS's.

Another approach

Is to create a new $esp every time you install a new OS. The os-prober will find the different systems and the benefit is that you do not mess with the other OS's $esp.

Creating a new $esp also means that you need to do a manual partitioning but then you can let the $esp size be small - 100MiB.

What is that $esp word

The $esp is the partition which you during install create and select for the mountpoint /boot/efi and flag the partition with boot and esp.

On Ubuntu it is selectable as EFI System Partition.

Use this guide at UEFI Additional commands to add Manjaro option

If it still doesn't work try the rest Special options in the tutorial.

so should i reinstall manjaro with new FAT32 partion as efi bootpoint

That is a decision I cannot make for you.

In cases like this there is always the chance of the XY problem and I am therefore reluctant to recommend one approach over another.

you will get kernel panic if the ucode is only present on the kernel commandline.

Not necessary but preferable.

Not necessary ... do as @AgentS says and you'll be fine.
Of course, you can reinstall with a new $esp
Or you can reinstall without a new $esp
In both cases of reinstalling, do as petsam says.
Or you don't need to reinstall but do as petsam says.

ps: You have obviously read the link before petsam responded but you do not provide the full information as in the link nor carried out the full commands in step 6. What gives?

Thank you for the clarification :slight_smile:

1 Like

hey guy got it to work . Followed steps by @AgentS . thanks for all the help. should have come here earlier:laughing::laughing:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by