Manjaro GUI freezes

Hi, long time lurker here, have been wanting to switch to Manjaro from Win10 for awhile, finally did it 4 days ago. However, there seems to be a persistent problem where the entire GUI just freezes. Audio is still working and the mouse too, but the rest of the GUI is just frozen in place. I've been trying to fix it for 3 days now to no avail. I've tried reinstalling drivers, switching between intel integrated graphics and the nvidia graphics, reinstalling the entire Manjaro, increasing swap space, but nothing seems to be working. I've searched every corner of reddit, this forum and the arch forums and still can't find an answer. I'm beginning to lose hope and might swap back to Windows if I am unable to fix it, which I really don't want since I kinda like Linux.

Here's my inxi -Fxz. It currently shows that theres no nvidia driver because I installed optimus-switch and I'm using the integrated graphics currently.

System:    Host: chun-pc Kernel: 5.4.6-2-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.4 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: X456UB v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: X456UB v: 1.0 serial: <filter> UEFI: American Megatrends v: X456UB.203 date: 09/04/2015 
Battery:   ID-1: BAT0 charge: 5.6 Wh condition: 5.6/38.0 Wh (15%) model: ASUSTeK ASUS Battery status: Not charging 
CPU:       Topology: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP arch: Skylake rev: 3 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19204 
           Speed: 2700 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 2700 2: 2782 3: 2700 4: 2739 
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GM108M [GeForce 940M] vendor: ASUSTeK driver: N/A bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.6 driver: intel resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) v: 4.6 Mesa 19.3.1 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.4.6-2-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: d000 
           bus ID: 02:00.0 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Lite-On driver: rtl8723be v: kernel port: c000 
           bus ID: 03:00.0 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 43.76 GiB (4.7%) 
           ID-1: /dev/sda vendor: Seagate model: ST1000LM014-1EJ164 size: 931.51 GiB 
Partition: ID-1: / size: 290.01 GiB used: 22.18 GiB (7.6%) fs: ext4 dev: /dev/sda8 
           ID-2: /home size: 38.20 GiB used: 21.58 GiB (56.5%) fs: ext4 dev: /dev/sda9 
           ID-3: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda7 
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 4100 
Info:      Processes: 180 Uptime: 8m Memory: 7.68 GiB used: 1.72 GiB (22.5%) Init: systemd Compilers: gcc: 9.2.0 Shell: bash 
           v: 5.0.11 inxi: 3.0.37 

Have you tried switching to a different kernel? 4.14 or 4.19.

I've tried switching to 5.2 and 4.19 but the problem still persists. I'll try 4.14 and see if it helps though.

Give the real time kernels a try as well. Sometimes they can surprise and fix some issues.

Is the Compositor on? Try ALT+SHIFT+F12 too.

I've tried the 4.19 and 5.2 real time kernels but it doesn't seem to help either.

I have compositor on enabled on startup yes. Not sure if it matters but the rendering backend is OpenGL 2.0.

GUI freezes is a board question. You may need provide more detail.

  • what have you done after install manjaro?
  • is gui freezed immediately after you login?
  • could you enter another tty?

Forget to mention, is just plasma freezed or all apps?

After installing manjaro, I just installed some packages like lutris and blender. I know they are not the problem as the freezes began even before I installed them. The GUI doesn't freeze immediately, but at random times after about 10-15 mins of usage. And yes I can enter and exit tty, and I could type commands and do a sudo reboot from there. But when it freezes the entire screen freezes, like it looks like a screenshot. I can move my mouse, but everything else in frozen in place. I've tried turning off and on the compositor but there was no change

Your problem seems similar on what happen to me after migrating "Deepin" into "Manjaro"
I forgot how did i fix that freeze but i know some tips how to do..

  1. I pressed CTRL + ALT + F3 and login as root
  2. Setting up Wi-Fi connection using nmtui
  3. Begin updating manjaro with pacman -Syu
  4. and reboot

Also i did some like cleaning my laptop fan and loses guarantee laptop, switching to XFCE, and many other method you can see in here: Click

If your problem still exists, i don't know what happen :man_shrugging:

That sounds terrible. You can try other desktop but if the problem is with the graphics card driver...
Dealing with such problems is always painful. If you are determined to solve it, you can check the system log after gui freezes.

But have you checked logs for errors? As soon as you face the next freeze, reboot and issue to terminal: journalctl --no-pager --no-hostname -xb-1 -p3 and post the output here.


Well, after doing a pacman -Syu after todays Manjaro update, my screen just turns black after the splash screen... I'm guessing it's probably something to do with my graphics card (it's pretty old). It's been 5 days and I've probably spent like 10-12 hours trying to fix this so I think I'm done for now... I'll probably swap to some other distro for now (probably Pop OS?) until I get a new laptop sometime this year. I'll definitely try swapping back to Manjaro then though, really like the community and Manjaro in general. Thanks all for trying to help, maybe see you back in the forums in a few months :slight_smile:.

1 Like

What's funny is that journalctl could solve your problem but you find it easier to switch over to another distro...

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by