Manjaro hangs forever

Hi,
I have a desktop with manjaro installed.
Sometimes manjaro hangs forever and I cannot access anything not even the terminal, so after long waiting and no unhangs, I am forced to cut the power supply to restart manjaro, but it seems that my hard disk gets corrupted, and I have to install manjaro again

I have reinstalled manjaro and this has happened again

Is there a step I should do to fit my computer's need?
Thanks

Hello,

Forever is a long time, but since you can stop it with

then is not forever :slight_smile:
Jokes aside, looks like you are on a Desktop PC, but we need more information. Here is how you can provide that


Do it from Live Media.

Do you have swap?,type in a terminal:

free -h

and paste what is says

Hi,
Sorry for the late reply

I have installed manjaro again.

What information would you need?

Output of free -h

              total        used        free      shared  buff/cache   available
Mem:          3.8Gi       1.3Gi       1.0Gi        61Mi       1.5Gi       2.3Gi
Swap:         8.5Gi       1.0Mi       8.5Gi

Thanks

inxi -Fxxxza --no-host
from terminal is a starting point.

Sure, Here it is

System:
  Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 
  root=UUID=b2d1e99b-1a1d-463f-8171-9df7a7d6765d rw quiet apparmor=1 
  security=apparmor resume=UUID=e63be5d4-086c-49d6-a947-fad433182c85 
  udev.log_priority=3 
  Desktop: KDE Plasma 5.18.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: BIOSTAR model: G41D3C v: ' serial: <filter> 
  BIOS: American Megatrends v: 080015 date: 08/24/2011 
CPU:
  Topology: Dual Core model: Intel Core2 6400 bits: 64 type: MCP 
  arch: Core Merom family: 6 model-id: F (15) stepping: 6 microcode: D0 
  L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 ssse3 vmx bogomips: 8536 
  Speed: 1600 MHz min/max: 1603/2136 MHz Core speeds (MHz): 1: 1600 2: 1600 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled 
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; 
  SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Vulnerable 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA GF119 [GeForce GT 610] vendor: Palit Microsystems 
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:104a 
  Display: x11 server: X.Org 1.20.8 driver: nouveau unloaded: modesetting 
  alternate: fbdev,nv,vesa compositor: kwin_x11 resolution: 1366x768~60Hz 
  OpenGL: renderer: NVD9 v: 4.3 Mesa 20.0.7 direct render: Yes 
Audio:
  Device-1: Intel NM10/ICH7 Family High Definition Audio 
  vendor: Biostar Microtech Intl Corp driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 chip ID: 8086:27d8 
  Device-2: NVIDIA GF119 HDMI Audio vendor: Palit Microsystems 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0e08 
  Device-3: GN Netcom Jabra UC Voice 750 MS type: USB 
  driver: jabra,snd-usb-audio,usbhid bus ID: 2-2:2 chip ID: 0b0e:034c 
  serial: <filter> 
  Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros AR8152 v2.0 Fast Ethernet 
  vendor: Biostar Microtech Intl Corp driver: atl1c v: 1.0.1.1-NAPI 
  port: ec00 bus ID: 03:00.0 chip ID: 1969:2062 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IF-ID-1: docker0 state: down mac: <filter> 
Drives:
  Local Storage: total: 232.89 GiB used: 12.93 GiB (5.6%) 
  ID-1: /dev/sda vendor: Seagate model: ST3250312AS size: 232.89 GiB 
  block size: physical: 512 B logical: 512 B speed: <unknown> 
  rotation: 7200 rpm serial: <filter> rev: JC45 scheme: MBR 
Partition:
  ID-1: / raw size: 224.42 GiB size: 219.90 GiB (97.98%) 
  used: 12.93 GiB (5.9%) fs: ext4 dev: /dev/sda1 
  ID-2: swap-1 size: 8.46 GiB used: 3.0 MiB (0.0%) fs: swap 
  swappiness: 60 (default) cache pressure: 100 (default) dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 100.0 C mobo: N/A gpu: nouveau temp: 77 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 192 Uptime: 4h 33m Memory: 3.84 GiB used: 2.22 GiB (57.6%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.17 
  running in: konsole inxi: 3.0.37 

Ok, also please provide:
mhwd -li

But, i would go by doing this:

  • remove all other video drivers trough MHWD
  • install the proprietary one:
    sudo mhwd -a pci nonfree 0300
  • try another kernel too

The reason is:

and if that is in idle, then i think in load is getting to the melting point, making the system hang. Is just a guess. Your GeForce GT 610 should perfectly work with the video-nvidia-390xx so maybe is better to install them by:
sudo mhwd -i pci video-nvidia-390xx
right after you remove the other drivers.
Also make sure the Compositor is set to OpenGL 3.1 after that, and play around with the animation speed (reduce it).
Everithing else looks fine to me.

2 Likes

Hi,
I have deleted prev drivers and installed the proprietary on with the command you gave.
Here is the result of mhwd-li before the driver part:

--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

and here is it after the driver part:

--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
    video-nvidia-390xx            2019.10.25               false            PCI

Warning: No installed USB configs!

The problem is that my screen starts tearing when I switch to OpenGL 3.1

Thanks

Do you recommend a specific one?
kernals

Ok, let's try to fix that:
Open in Kate the /etc/X11/mhwd.d/nvidia.conf and in the Section "Device" replace the line Option "NoLogo" "1" with:

    Option         "TripleBuffer"  "On"
    Option  "ConnectToAcpid"    "Off"
    Option "metamodes" "nvidia-auto-select +0+0 {ForceFullCompositionPipeline = On}

Save it then create the file kwin.sh to use the triplebuffer, from terminal run:
echo "export KWIN_TRIPLE_BUFFER=1" | sudo tee /etc/profile.d/kwin.sh

Reboot after that and try again the OpenGL 3.1

Note: with this the system should work decently, but please do not try wayland!

About the kernel, i would go with a LTS one 5.4.44 in your case. You can have multiple kernels installed and select to boot from Grub Boot Menu.

2 Likes

Hi,
There is no Option "NoLogo" "1" in the conf file.
Maybe Installing the new drivers fixed it? (I am a newbie :slight_smile:)
I have installed the kernal version you recommended, I'll try it out and tell

Run from terminal:
cat /etc/X11/mhwd.d/nvidia.conf
Paste it here as formated text, and we will see what can be done. :slight_smile:

No worries :slight_smile: We all were once!

Never Mind
I found the NoLogo Part, Sorry
BTW, what do you mean by

?

This indicates two additional potential reasons for your issues:

  1. Your system temperature is too high as well, check your fan(s) for dust or other reasons they are not cooling down your system, properly.
  2. You have not much RAM and seem to use quite a lot of your swap space, already. Swap on a hard disk is dramatically slowing down your system. Next time, you see freezing check coincidence with high swap usage. Swap usage easily always can be displayed in a desktop corner.
2 Likes

Sure, Will Do!

Well, explaining triplebuffer is a bit complicated for the purpose of this topic. I can point you to some readings here


Do also what @Wollie pointed out. I was hoping that once we decrese the GPU temperature to have lower the rest of temperature a bit too, then investigate furthure. Glad he pointed that out as i would have forgot about it :slight_smile: Thanks!

1 Like

Ok, I had just thought that it was a step I had to follow.
I have switched to OpenGL 3 and no screen issues till now, will tell if any.
Is this configuration fine?
compositor

Thanks

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by