Manjaro hangs in the installed version, but not in the Live USB

Edited, not relevant since kernel 4.9 is not working better

Live media have always the same kernel and gpu drivers. On installed, they change after the updates.

That's why I tried rebooting before I updated anything, and the OS still froze. That means something is different between the Live OS and the installed OS. If everything was identicle, I presume that it should behave the same in both versions.

I haven't tried this command yet, but I'm pretty sure it's not the free graphics drivers that causes the problem. The Live OS uses the free drivers, and it works fine. Moreover, I once tried installing the nonefree drivers, and the OS wouldn't even boot. It gets stuck after the grub screen. And, the Live OS won't boot either with the nonefree drivers, it too gets stuck after the grub screen, and the fan start spinning very fast and loud.

There are quite plenty of them. You could have wrong one installed. When you enter that command you will be asked to confirm it, there will be exact name of the package to be installed. According to your hardware I consider the best choice you can make is video-hybrid-intel-nvidia-390xx-bumblebee. Good luck.

That's the one I tried. It automatically chose it. I only had to press the button in the 'Hardware Configurations' tab, in the settings. But nevertheless, I will try again, and I will uninstall the free drivers, as you suggest.

You may have this one. Try the mentioned grub parameters

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by