Manjaro has ceased working on my new laptop

I started with Linux on an old craptop that I was planning on throwing away. Useless old a10 7300 with no dGPU. The install went well on that and I've never really had any problems, so when I got my new laptop I was psyched about putting it on my new T480, i7 8650u, 32gb ram, 1440p and mx150. The first problem started with the live usb. The first time I tried it, using the same drive from my previous install, it was unbearably laggy, even after a relaunch. I tried to get over it and proceed with the install only for it to crash. The way I've done both my new and old installs are though partitioning in windows and filling the partition in the installer, so I wasn't worried about it corrupting anything. After the first one failed, I reformatted it with the most recent version of Manjaro and the live usb worked fine and installed fine. Now when I try to start Manjaro there is a whole host of problems, most of which I can't even explain.

Quite literally every time I boot into it something new is awry. At first it was slow to boot and login, and because of the higher-res screen, the text was small. It first crashed while opening settings literally 10 seconds into having it open. The second time it froze on the desktop (Note: both of these "crashes" are weird because there is no error message, and I can still move the cursor but literally everything else is non-functional). After a couple of more attempts, it sorta works but now everything is dreadfully slow; the command prompt takes 15 seconds to open and has a jittery opening animation and the cursor only sometimes moves smoothly. I tried to run some of the diagnostic commands that people have recommended but it quite literally won't give anything in response and half the time will just freeze like previously mentioned. Most recently I booted into a black screen with the GUI terminal floating in the middle of nowhere and the cursor on the screen.

I don't have a clue what to do or how to solve this but my best guess is its a dGPU issue. I don't know how to go about fixing this either, and someone on Reddit was talking about downloading some version with free vs non-free drivers, but I'm not quite sure what that is all about. I know about drivers and Nvidia optimus because I'm generally good with windows but I'm still brand new to Linux so... here I am. Thanks for any responses in advanced.

Please post:

inxi -Fxxxz

Unless there is no alternative, do not post terminal output as a pic.

Please post all terminal command output as text with code tags.

Information on how to properly post hardware specs and logs:

Please format any terminal output with three backticks before and after, as shown in this picture:

I literally can't. I've typed it in and it won't return anything at all.

Your graphics drivers are not installed properly then. I'm not the one to offer advice on installing laptop drivers as I don't use them.

Post your make and model with a link to your laptops specs and all the information you know about your GPU(s).

Perhaps @dglt is around to help you. He loves this kind of stuff.

1 Like

awesome, thanks man. I suspected graphics drivers but with its current state idk how I would even get them installed lol

there are many topics about T480
can you try with USB install to add one of theses lines ( e to access line boot kernel )
" acpi_osi=! acpi_osi='Windows 2009'" ( windows 7 )
" acpi_osi=! acpi_osi='Windows 2013'” ( windows 8 )
" acpi_osi=! acpi_osi='Windows 2015'” ( windows 10 )

check with dmesg | more if you see errors with live USB

also check carefully boot Bios option
No legacy , no CSM , no fastboot , only UEFI

tell me if this is what happened, you tried booting the live usb with the non-free drivers but would not finish booting so you tried selecting the free drivers, it booted fine, installed fine, now you get random lockups, inxi or any call to the gpu results in either lockup or zero feedback from the commands?
yes? this is common with the free (nouveau)drivers. i usually install using the free drivers and then after install i remove them and install the proprietary nvidia drivers (video-nvidia) following this PRIME tutorial since im not a fan of bumblebee and it's limitations, not to mention the collage of kernel parameters needed to boot it properly in most cases.

when you read this, i would suggest you boot the live install usb, connect to network, then come back here for further help, i should be available throughout the day as it's sunday and i've nothing else to do :sunglasses:.

once on the live usb, i would have you chroot from terminal so you can make changes to your already installed manjaro:
manjaro-chroot -a

i made something recently that can set up PRIME for you and also allows switching between nvidia prime mode for when you want the best performance possible using both the nvidia and intel gpu's. and an intel-only mode for when you want the best battery life by disabling/powering-down the nvidia gpu and only using the intel iGPU.

take a look and see which option fits you best and i can assist if you need help. here is a small comparison between each of the available optimus options.


wow thanks for the response! Well I firstly, I don't know much about drivers on linux, especially not free vs non-free ones so I didn't really select any of them. I just downloaded the iso off of the manjaro website, ran it through rufus and installed it in the live usb. Ill check out the tutorials in a minute and see what I can get working. P.S. sorry I didn't respond until now, I worked yesterday and had school today.

ok, your likely using free drivers as thats the default option unless you switch it to non-free. your described behavior sounds like free driver(nouveau). if your not able to install or uninstall drivers with MHWD because of lockups, you need to do it from chroot as i described previously. if you need any help i should be around

1 Like

alright, I'm on the liveboot and I tried to chroot but it just says can't mount. It shows:

==> Detected systems
 --> 0) ManjaroLinux
==> Select systems to mount [0-0]

also it won't let me install any of the drivers while in the live boot. What I was planning on doing was installing them onto there and hopefully installing that onto the machine so that I could at least get it to work enough to install prime or whatever you recommend but it was asking for a password which I havent set, considering that its only the live usb boot

for manjaro chroot either hit enter or enter 1 or you'll just get "cannot mount 0"

and the password on the live usb is "manjaro"

you can also try:
mhwd-chroot if manjaro-chroot wont work

1 Like

alright, this is dumb. I can't get any of the drivers to install in the live environment and it just crashes when I launch it normally. I think im just going to stick to windows for now. Thanks for the help though

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by