Manjaro i3 on x230 Wifi Issue

Hi,

I just did a fresh install of Manjaro i3, I used it in the past without any issues for a solid 3 years, I tried a different distro (debian-based), I didn't like it and now I am back to Manjaro i3. However, there is a small issue that is back, the issue about the wireless interface card, the problem is I can see wireless network available but I cannot connect to it, it just keep trying to connect and eventually drop... I have tried to connect another wifi and same thing...

I know I have fixed it in the past but my memory is horrible and I couldn't find the solution anywhere... Here below are information that is needed to help you to help me:

 inxi -Fxzc0
System:    Host: noax-Mi3 Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: i3 4.18.1 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 23243Q0 v: ThinkPad X230 serial: <filter> 
           Mobo: LENOVO model: 23243Q0 serial: <filter> UEFI [Legacy]: LENOVO v: G2ETB1WW (2.71 ) date: 03/09/2018 
Battery:   ID-1: BAT0 charge: 52.4 Wh condition: 52.4/57.2 Wh (91%) model: SANYO 45N1172 status: Full 
CPU:       Topology: Dual Core model: Intel Core i5-3320M bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20762 
           Speed: 1197 MHz min/max: 1200/3300 MHz Core speeds (MHz): 1: 1197 2: 1197 3: 1197 4: 1197 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 20.0.7 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Sound Server: ALSA v: k5.6.15-1-MANJARO 
Network:   Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e v: 3.2.6-k port: 6080 bus ID: 00:19.0 
           IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Realtek RTL8188CE 802.11b/g/n WiFi Adapter driver: rtl8192ce v: kernel port: 5000 bus ID: 03:00.0 
           IF: wlp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 298.09 GiB used: 6.19 GiB (2.1%) 
           ID-1: /dev/sda vendor: Toshiba model: MQ01ACF032 size: 298.09 GiB 
Partition: ID-1: / size: 284.83 GiB used: 6.19 GiB (2.2%) fs: ext4 dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 55.0 C mobo: 0.0 C 
           Fan Speeds (RPM): cpu: 3276 
Info:      Processes: 151 Uptime: 1h 15m Memory: 7.48 GiB used: 1020.4 MiB (13.3%) Init: systemd Compilers: gcc: 10.1.0 
           Shell: bash v: 5.0.17 inxi: 3.0.37

And I also ran rfkill list all and this is the output:

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

I remember I had to do some trick with the drivers but like I mentioned, my memory is blurred, I fixed that 3 years ago...

EDIT: Added more information related to problem

Thanks you for your help!

If you are using Network Manager then I would try disabling MAC Address randomization in NM.

Disable MAC Address Randomization with the following command:

echo -e "[device]\nwifi.scan-rand-mac-address=no" | sudo tee /etc/NetworkManager/conf.d/disable-random-mac.conf

After creating the new conf file, reboot both your router and your computer.

If there is no improvement you can re-enable randomization by deleting the newly created conf file:

/etc/NetworkManager/conf.d/disable-random-mac.conf

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by