Manjaro in VirtualBox: cannot change display resolution


I've just installed manjaro-kde-18.1.5-191229-linux54 in VirtualBox 6.1 (running on Windows 10).

The LiveDVD boot from ISO was fine, but now that I've installed the system on a VDI hard disk image - Manajro is stuck at 800x600 display resolution:


The VirtualBox interface shows a greyed out list of display resolutions, and it's locked on 800x600.

If I change the resolution in Display Settings inside Mnajaro or using xrandr -s 640x480- it changes for a fraction of a second and then immediately changes back to 800x600.

Why does this happen? I've just tested this and the LiveDVD boot is also stuck, but on 1024x768.

I've never had such a problem with other Linux distributions. I remeber being able to freely change the display resolution from the guest OS, some distros even talked to VirtualBVox and provided host integration out of the box.

I would settle for just being able to use a rigid 1920x1080 resolution.

I've tried installing virtualbox-guest modules and utilities, rebopoting the VM several times.
I've done another clean install - same story.

Do you have any ideas for fixing this?

1 Like

That is an ongoing problem - various community and team members are working with the issue.

Please look to this thread for a link to relevant topics


I've tried other VirtualBox video drivers - none work except for the default one. Others give me a solid black display after a while from booting.

I set the Display Graphics Controller in my Win10 Virtual Box host to VBoxVGA.

For the moment you can just use VBoxSVGA (With that one resizing should work...), boot the live CD and wait about 5 minutes for it to load.
Once you have installed, it should load faster.

So the black display will "fix itself" after a while?
I'll try choosing the VBoxSVGA driver and wait then.


So far I'm waiting with the black screen.

I've tested Kubuntu and it has the same issue with chaning the display resolution - it jumps right back to 800x600.

Shouldn't take more than 5 minutes.
Did you boot from LiveCD or an installed system?

If you booted an already installed guest system (installed with VMSVGA) and now you switched to VBoxSVGA you will need to change the driver first I think:

sudo mhwd -i pci video-virtualbox
sudo mhwd -r pci video-vmware

I did install it using VMSVGA.

After swithcing back to VMSVGA, runnnig the commands you've given me, powering off, switching again to VboxSVGA - it worked!

Thank you!

Video performance is noticeably slower, but that's not an issue for me right now.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by