Manjaro Installation Error

Hello everyone,

I recently tried to install Arch Linux but for obvious reasons I decided to take a break and use the easy install version of the distro (And yes I know at this point Arch and Manjaro are somewhat different).

I installed the manjaro iso on a usb using the newest version of rufus and it seemed to work well. After using the gui to install Manjaro on a freshly wiped spare drive (to create a dual boot system) I removed the USB and re-entered the bios to boot into the new OS install but it doesnt show up. Almost like the install failed. I may have made a dumb error but even after extensive research I can't seem to figure it out. Below I have listed my hardware and bios information.

I'm just trying to install Manjaro so that I can become more familiar with a Linux based system so that I can install Arch in the future.

Thank you for your time and support.

Current System Info:
Motherboard: Asus Prime x299 Deluxe
CPU: Intel Core i9-7940x
GPU: Asus GTX 1080 Strix 8GB
Network Card: TP-Link Archer T9E AC1300 Dual Band Network Card
Sound Card: Sound Blaster X AE-5 PCIEx8
RAM: 32GB DDR4 in quad channel configuration. 4gb x 8 dimms

1TB SSD (Primary)
2TB SSD (HDD with memory module) (Data)
2TB HDD (The drive I am attempting to install on)

I assume your installation has completed without errors.
Then use the [Simple First Start] here to boot into your installed OS.

When booted, before step 4. , update your system first with

sudo pacman-mirrors -f5
sudo pacman -Syyuu

After doing step 4 which is

sudo grub-install 
sudo update-grub

Don't forget to do the 2 [UEFI - additional commands]

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /d xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Careful you choose the right partition for the 2nd command.

If you still have problems, check out the Asus link at the end of that post.
If you still need help, remember to post the required information listed at [UEFI - if problem persists] section.

Good luck and hope we can welcome you into our Manjaro family (dysfunctional maybe, but crazily friendly and funny). Hope you fit in.

[EDIT] - (damn - I forgot it may be this) - if you have a black screen (nothing else) when you start the computer, press 'Esc' key. You should see the grub menu. Tell us later on if you want to see the menu or see a very nice small countdown.


What exactly did you change?
Is it UEFI or MSDOS/UEFI Legacy?
It maybe a video drivers problem only.. as suspected

Note to @gohlip: ...and here we go again... Weren't we predicting this? Unless we are/were prophets and we can.. make money of it!!


please can you check if you have created USB iso
using rufus in mode DD option ( not standard option )

I want Think that you have window. If you have windows 10 from a clean install you should have a gpt table of partitions if not maybe you have a Table MS-DOS with MBR and not UEFI. When you placed usb in the port to install Manjaro you should have see 2 options to install UEFI usb and simply USB (it also depend of your BIOS if this one have legacy/efi or only one of this 2) If you have efi and you did select usb and not usb efi Manjaro will no start and viceversa.

1 Like

Thank you everybody. I'll definitely try the suggestions you have provided.

To answer some of the questions I saw:

The problem I was having wasnt a black screen. It was that after I had installed manjaro, the drive did not appear in the ASUS UEFI boot list. After installing from an iso based usb I would restart but the drive would not identify itself as bootable. I was never able to get into the grub menu to begin with.

I am using the bios in UEFI mode.

Also I will look for a UEFI installation mode as opposed to simple USB.

Recently I tried installing arch in a vm on a separate pre-built laptop and had even less errors. It would seem to be because I was using the wrong partition type for the root system. This would clearly identify why the ASUS UEFI bios could not identify the installation in both arch and Manjaro.

I will try to re-install with your suggestions and see where it gets me. I highly appreciate the feedback!

Didn't the link help?

If your BIOS is on "UEFI only", the USB Live media should have booted in UEFI (I guess), so you should have an UEFI installation.

Just clear this up.

  • Make sure how your UEFI BIOS is set (what mode).
  • Boot your USB installer in UEFI (select the option that includes UEFI)
  • Install in UEFI (there should not be an option to choose where to install the bootloader, as this is only on MBR/MSDOS cases).
  • If you can still not see an option for your installation, use @gohlip 's linked tutorial to manually find and boot to your installation and repair boot.

Thank you everybody for the suggestions. I retried the installation and was able to get it installed! Can't wait to continue learning the OS and making the permanet transition from the telemetry agressive windows 10.

I noticed when I did my install the other know the one. :astonished:

When I had a boot usb installed I had two options for that stick. One I assume was maybe legacy, it just had the name of the usb. The other one was labelled "UEFI name of stick".

So to get it to boot UEFI seems I had to chose the uefi usb.

This is my first week with uefi & it took (still takes) a bit of doing to get my head around it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by